LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 07-16-2004, 09:08 AM   #16
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 52

Debian: Not Just Another Pretty Face Part I
http://distrowatch.com/dwres.php?res...review-debian2

Excerpt:
"I do not yet have sound configured. The thing to do is:

apt-get install sndconfig

Then I run the command "sndconfig" - it finds my sound card. As user "robert" I must be added to the group "audio" in order for me to hear sound - to do this I issue the command:

adduser robert audio

User robert must log out and log back in for this to go into effect.

My sound isn't loud enough, so I need a sound mixer. I install "aumix" and then run it so I can adjust the volume and pcm settings. Now that sounds much better."

Last edited by macondo; 07-16-2004 at 09:19 AM.
 
Old 07-16-2004, 11:38 AM   #17
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by taipan67
Me again!

First, an apology. My last post sounds a bit petulant & condescending about the /etc/modules.conf thing. Sorry. My fault entirely, i should've explained myself better. In my defence, i'm on a public-access pc, & my time allotment is restricted, so i rush a bit. Plus i can't just paste this stuff across, i have to write it all from memory or notes.
I wouldn't say that you sounded at call condescending, but in any case, no problem .

Quote:
Originally posted by taipan67
Okay, first suggestion - install a kernel-source package & have a good read. Using your favourite package manager will put a source-code tarball in the /usr/src/ directory. Unpack it, either from a console with "tar -xjf (if it's a bz2)filename", or from nautilus or konqueror by right-clicking & selecting "extract to...". First port-of-call i'd recommend in the created directory is the Documents/ sub-directory. In the ALSA-Configuration.txt file i mentioned yesterday, as well as the stuff about aliases & registrations, is some driver-specific options, which i'll leave for another day.
I should "apt get install kernel-source," then? It says that I have to specify which kernel, and gives me options. I don't know what to choose, though. Am I doing my own kernel, or...?

Quote:
Originally posted by taipan67
Regarding yesterday's horror-show, after having time to reflect, if your previous posts are any indication, you should have all that stuff already, but here's how to check... (Everybody please post corrections for my mistakes before we break anything!)

The aliases are read by the kernel from /etc/modules.conf, but to change them needs yesterday's process. For now, open /etc/modules.conf in a viewer, & see if you have "alias snd-card-0 snd-intel8x0", or for that matter any aliases for "snd-something" or "sound-something".
Well, other than the two lines that you had me add (which was apparently an incorrect way to go, eh?), there's nothing with "snd" or "sound." Should I erase those two lines?

Quote:
Originally posted by taipan67
The other thing to check for now, is whether you have the necessary devices in the /dev directory. When i manually created the registration entries suggested in the ALSA-Configuration.txt file, i suddenly acquired a load of /dev/audio* devices. Look for /dev/audio &/or a directory called /dev/snd/, which on mine is full of pcm & mixer devices.

Post what you find for our collective entertainment, & we'll take it from there... While you're at it, can you post your precise kernel-version (eg: 2.6.5)? Your earlier post about /boot/config entries has given me an idea, but i'd like to run THIS theory to ground first.
/dev/audio exists, but cannot be read. /dev/snd/ is mighty full:

controlC0 hwC2D3 midiC1D2 midiC3D1 pcmC0D4c pcmC1D3p pcmC2D3c pcmC3D2p
controlC1 hwC3D0 midiC1D3 midiC3D2 pcmC0D4p pcmC1D4c pcmC2D3p pcmC3D3c
controlC2 hwC3D1 midiC1D4 midiC3D3 pcmC0D5c pcmC1D4p pcmC2D4c pcmC3D3p
controlC3 hwC3D2 midiC1D5 midiC3D4 pcmC0D5p pcmC1D5c pcmC2D4p pcmC3D4c
hwC0D0 hwC3D3 midiC1D6 midiC3D5 pcmC0D6c pcmC1D5p pcmC2D5c pcmC3D4p
hwC0D1 midiC0D0 midiC1D7 midiC3D6 pcmC0D6p pcmC1D6c pcmC2D5p pcmC3D5c
hwC0D2 midiC0D1 midiC2D0 midiC3D7 pcmC0D7c pcmC1D6p pcmC2D6c pcmC3D5p
hwC0D3 midiC0D2 midiC2D1 pcmC0D0c pcmC0D7p pcmC1D7c pcmC2D6p pcmC3D6c
hwC1D0 midiC0D3 midiC2D2 pcmC0D0p pcmC1D0c pcmC1D7p pcmC2D7c pcmC3D6p
hwC1D1 midiC0D4 midiC2D3 pcmC0D1c pcmC1D0p pcmC2D0c pcmC2D7p pcmC3D7c
hwC1D2 midiC0D5 midiC2D4 pcmC0D1p pcmC1D1c pcmC2D0p pcmC3D0c pcmC3D7p
hwC1D3 midiC0D6 midiC2D5 pcmC0D2c pcmC1D1p pcmC2D1c pcmC3D0p seq
hwC2D0 midiC0D7 midiC2D6 pcmC0D2p pcmC1D2c pcmC2D1p pcmC3D1c timer
hwC2D1 midiC1D0 midiC2D7 pcmC0D3c pcmC1D2p pcmC2D2c pcmC3D1p
hwC2D2 midiC1D1 midiC3D0 pcmC0D3p pcmC1D3c pcmC2D2p pcmC3D2c

As for the precise kernel version...hehe...how do I check that?

Quote:
Originally posted by taipan67
As a parting note, can i say don't feel intimidated. I'm a newbie myself, & most of my (limited) linux knowhow has been learned in the last month.
Well, I'd wager that most people in the Linux world are "newbies," but there are definitely different levels of newbishness . I'm at this level:



Quote:
Originally posted by taipan67
ps: Just thought of something which may save a day or two if macondo's following post doesn't help:-

If you DO have the devices mentioned in the /dev directory, make a note of the ownership & permissions for us. I find this easiest in nautilus (no kde installed at present). To access this information, right-click on the device, select "properties", & go to the "permissions" tab. What i'm after is the owner, group & the octal number that governs who has read, write, execute access to the file. It will probably be owner:root, group:audio, permission:660 (or 0660). Perhaps the fastest way would be to open a terminal & run "ls" with an option to only display files in the /dev & sub-directories with an audio group-id. I can't tell you how to do that. Any suggestions, folks?

If you DON'T have any audio-group devices, let me know if you have a directory called /etc/devfs/, & if you do, what's in it. This is where my device registrations are...

Back in the morning, night-night!
The permissions for the "audio" file are owner:root, group:audio, permission:660. The permissions for the "snd" directory are owner:root, group:audio, permission:750. The permissions for the 118 files inside the "snd" directory are owner:root, group:audio, pemrission:660.

I checked for /etc/devfs/ anyway, and I have it. It has one file in it, conf.d.

I hope this information helps!

Thanks for your help. If anyone else is reading this, and wants to hop on the "Help tavilach, a desperate newbie who wants sound!" bandwagon, feel free! I've been struggling with this for a long time, and really need your help!

Last edited by tavilach; 07-16-2004 at 11:40 AM.
 
Old 07-16-2004, 11:48 AM   #18
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by macondo
Debian: Not Just Another Pretty Face Part I
http://distrowatch.com/dwres.php?res...review-debian2

Excerpt:
"I do not yet have sound configured. The thing to do is:

apt-get install sndconfig

Then I run the command "sndconfig" - it finds my sound card. As user "robert" I must be added to the group "audio" in order for me to hear sound - to do this I issue the command:

adduser robert audio

User robert must log out and log back in for this to go into effect.

My sound isn't loud enough, so I need a sound mixer. I install "aumix" and then run it so I can adjust the volume and pcm settings. Now that sounds much better."
Well, I ran sndconfig, and got the following error:

"ERROR: No Sound Modules Found

You don't seem to be running a kernel with modular sound enabled. (soundcore.0 was not found in the module search path). To use sndconfig, you must be running a kernel with modular sound, such as the kernel images shipped with Debian Linux or a 2.2 or greater kernel."

I tried running esd from the terminal (it just hangs...that means it's working, no?), even though it should be running already (I think? I'm in Gnome to test sound, but the setting to "Enable sound server at startup" is disabled by default, and because it only seems to make things worse, by causing osscommon errors when I open mp3's and such, when normally I just get no errors and no sound, I've left it like that...), and then ran sndconfig again...but that didn't do anything . Still the same error.



Perhaps this latest error will give us a clue?
 
Old 07-16-2004, 12:53 PM   #19
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 52
"ERROR: No Sound Modules Found

as root:

modconf

go to the sound modules and hilite your module, press Enter, press Enter in the next screen and OK to install, it will give you a message telling if it succeeded or not.

reboot and at the console start sndconfig again.

Last edited by macondo; 07-16-2004 at 12:55 PM.
 
Old 07-16-2004, 03:10 PM   #20
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by macondo
"ERROR: No Sound Modules Found

as root:

modconf

go to the sound modules and hilite your module, press Enter, press Enter in the next screen and OK to install, it will give you a message telling if it succeeded or not.

reboot and at the console start sndconfig again.
The command modconf, as root, is not found...
 
Old 07-16-2004, 05:48 PM   #21
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 52
"The command modconf, as root, is not found..."

#apt-get install modconf

install the following if you haven't:

#apt-get install x-window-system discover mdetect read-edid

Last edited by macondo; 07-16-2004 at 05:50 PM.
 
Old 07-16-2004, 06:45 PM   #22
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by macondo
"The command modconf, as root, is not found..."

#apt-get install modconf

install the following if you haven't:

#apt-get install x-window-system discover mdetect read-edid
When I installed modconf, the following happened:

Code:
apt-get install modconf
Reading Package Lists... Done
Building Dependency Tree... Done
The following NEW packages will be installed:
  modconf
0 upgraded, 1 newly installed, 0 to remove and 55 not upgraded.
Need to get 1054kB of archives.
After unpacking 3805kB of additional disk space will be used.
Get:1 ftp://ftp.us.debian.org testing/main modconf 0.2.45.1 [1054kB]
Fetched 1054kB in 2s (362kB/s)    
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_CTYPE = "en_US.UTF-8",
        LANG = (unset)
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Selecting previously deselected package modconf.
(Reading database ... 92875 files and directories currently installed.)
Unpacking modconf (from .../modconf_0.2.45.1_all.deb) ...
Setting up modconf (0.2.45.1) ...
I'm assuming that's fine...

As for installing that other thing, I got the following:

Code:
apt-get install x-window-system discover mdetect read-edid
Reading Package Lists... Done
Building Dependency Tree... Done
mdetect is already the newest version.
read-edid is already the newest version.
The following extra packages will be installed:
  discover-data lbxproxy libdiscover2 proxymngr twm xdm xfs xfwp xnest xvfb
The following packages will be REMOVED:
  discover1 discover1-data libdiscover1
The following NEW packages will be installed:
  discover discover-data lbxproxy libdiscover2 proxymngr twm x-window-system xdm xfs xfwp xnest xvfb
0 upgraded, 12 newly installed, 3 to remove and 55 not upgraded.
Need to get 4962kB of archives.
After unpacking 13.0MB of additional disk space will be used.
I hope that's okay, too...seeing as how I went ahead and installed.

While it was installing, it said so much information that xterm didn't even store it all (darn...I want to keep track of everything!)...

I noticed that it discovered hardware (snd-intel8x0)...is that good?

Anyway, I then ran modconf and selected kernel/sound/pci/ac97.

I was going to run sndconfig, after rebooting...but...

I HAVE SOUND!

What happened? Was it that discover thing? Is it configured properly? It sounds kind of hollow, but it might be my speakers. How do it's using alsa?

I HAVE SOUND! I HAVE SOUND!

Haha, macando...you could have told me that little discover bit earlier ...

Edit: OMG! OMG! On Fedora, after every sound I'd hear the loudest clicky noise. I have really, really cheap speakers, so I figured that was it. I don't have that noise anymore, though! I mean, the sound is horrible, but it's usable, becasue there isn't an annoying click after every frickin' IM! Was it alsa that fixed that? WOOT WOOT!

Last edited by tavilach; 07-16-2004 at 06:49 PM.
 
Old 07-16-2004, 07:31 PM   #23
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 52
Don't forget the aumix bit from the article.

"While it was installing, it said so much information that xterm didn't even store it all (darn...I want to keep track of everything!)..."


That's because it only stores 64 lines by default. Here's my xterm properties:

xterm*background: black
xterm*foreground: gray90
xterm*font: 10x20
xterm*scrollBar: true
xterm*rightScrollBar: true
xterm*saveLines: 20000
xterm*cursorColor: yellow

copy/paste it into your /home/your_user_name/.Xresources file with your favorite editor as root. Save and exit.

after that, still as root, on the terminal type this:

xrdb -merge /home/your_user_name/.Xresources

then logout/login

after you come back, you will be able to scroll back (by pressing the middle button of your mouse on the xterm scrollbar) 20000 lines, you will have a yellow cursor, a scrollbar and a larger, easy to see xterm with a black background and white fonts.

"Haha, macando...you could have told me that little discover bit earlier ..."

How would i to know what kind of mess you had done while installing poor old Debian?

Besides, if you would have read the articles on my signature, you would know all this and more. Newbies think Linux is a bag of tricks and refuse to read articles with the answers because they are too lazy, and then go away thinking Linux sucks!

<macondo shakes his head>

Last edited by macondo; 07-16-2004 at 07:35 PM.
 
Old 07-17-2004, 01:12 AM   #24
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by macondo
Don't forget the aumix bit from the article.

"While it was installing, it said so much information that xterm didn't even store it all (darn...I want to keep track of everything!)..."


That's because it only stores 64 lines by default. Here's my xterm properties:

xterm*background: black
xterm*foreground: gray90
xterm*font: 10x20
xterm*scrollBar: true
xterm*rightScrollBar: true
xterm*saveLines: 20000
xterm*cursorColor: yellow

copy/paste it into your /home/your_user_name/.Xresources file with your favorite editor as root. Save and exit.

after that, still as root, on the terminal type this:

xrdb -merge /home/your_user_name/.Xresources

then logout/login

after you come back, you will be able to scroll back (by pressing the middle button of your mouse on the xterm scrollbar) 20000 lines, you will have a yellow cursor, a scrollbar and a larger, easy to see xterm with a black background and white fonts.

"Haha, macando...you could have told me that little discover bit earlier ..."

How would i to know what kind of mess you had done while installing poor old Debian?

Besides, if you would have read the articles on my signature, you would know all this and more. Newbies think Linux is a bag of tricks and refuse to read articles with the answers because they are too lazy, and then go away thinking Linux sucks!

<macondo shakes his head>
Hey now...

I didn't know that my problem was "normal." As for making a mess of my Debian box...I didn't. It was a perfectly normal installation.

Do I seem like someone who just walks away, thinking Linux sucks?
 
Old 07-17-2004, 06:48 AM   #25
taipan67
LQ Newbie
 
Registered: Jul 2004
Location: Sunny old England
Distribution: Gentoo 2004.1
Posts: 10

Rep: Reputation: 0
Good to know you're sorted (in spite of my interferrence) - enjoy!
 
Old 07-17-2004, 08:12 AM   #26
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 52
Do I seem like someone who just walks away, thinking Linux sucks?


i was speaking in general.
 
Old 07-17-2004, 08:15 AM   #27
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 52
Good to know you're sorted (in spite of my interferrence) - enjoy!


There was no interference, there is a lot to learn from your advice, we all benefit from it.
 
Old 07-17-2004, 04:07 PM   #28
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by taipan67
Good to know you're sorted (in spite of my interferrence) - enjoy!
As macondo said, there was no interferance. Your advice was well put and beneficial to anyone reading the thread .

Guys, I still do have a question, though...

How do I ensure that the sound I'm hearing is properly configured? In other words, it sounds pretty bad, and I think it's because of the speakers, but I want to make sure that's it's using ALSA and everything. I believe it is, because that clicky noise is gone, but...I don't know.

 
Old 07-19-2004, 05:44 AM   #29
taipan67
LQ Newbie
 
Registered: Jul 2004
Location: Sunny old England
Distribution: Gentoo 2004.1
Posts: 10

Rep: Reputation: 0
Not sure on that one, i'm afraid. Since configuring my own sound, all i've done is listen to cd's through headphones (no speakers, yet), & it sounds like my hi-fi (which ain't great, but that's down to the 'phones). The speakers are currently a lower priority than broadband...

Regarding my Friday suggestion about installing some kernel source-code, it won't hurt your system, or install a new kernel (unless you wanna build one...). It will just put about 130Mb of code in /usr/src/<kernel-version>, & provides HOURS of reading pleasure. Also, if you unpack it in that directory, your normal user-name won't have permission to do any harm anyway, just read-access. Dunno about the apt-get bit - i'm a lazy bastard, so i just use 'synaptic package-manager' under gnome.

Version-wise, as long as it's a flavour of 2.6.something, it'll have README's about alsa. You can check your running kernel-type by opening a terminal & entering "uname -r", without the quotes (no offence intended).

Don't be afraid to check out the c-files, too. You don't need to be a programmer to read the comments. That's how i discovered that the driver-module being loaded for my ethernet card didn't actually support it...

I'm gonna go see if i've got 'discover', so i don't have to bodge things no more...
 
Old 07-23-2004, 10:59 AM   #30
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Uh oh!

I had lots of Fluxbox issues, and decided to reformat. After reformatting, I did the initial modprobe'ing, installed alsa, installed modconf, installed that discover stuff, ran modconf, enabled the driver, and yet...

No sound!



What did I do wrong, this time? Eek!

Help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound won't work in Sarge akempo Debian 5 03-11-2008 10:26 AM
No Sound - Debian Sarge jrcreasy Linux - Newbie 7 08-27-2005 11:30 AM
No sound on Debian sarge carloscuderia Linux - Newbie 5 04-08-2005 04:25 PM
sound problem with sarge DrkSn Debian 2 12-20-2004 05:52 PM
Sound in Debian Sarge Kernel 2.6 quentusrex Debian 13 08-13-2004 11:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration