LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 07-13-2004, 06:52 PM   #1
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Rep: Reputation: 15
No Sound in Sarge!


I've tried searching the forum for similar problems, but I can't seem to find anything...

I installed Sarge, but had no sound. After playing with the drivers a little, I decided to see if it would work on Fedora. It did! Fedora gave me the following information:

Vendor: Intel Corp.
Model: 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller
Module: snd-intel8x0

lsmod on the Fedora installation yielded:

[module | used by]
snd_pcm_oss | 0
snd_mixer_oss | 3 snd_pcm_oss
snd_intel8x0 | 3
snd_ac97_codec | 1 snd_intel8x0
snd_pcm | 2 snd_pcm_oss snd_intel8x0
snd_timer | 1 snd_pcm
snd_page_alloc | 2 snd_intel8x0 snd_pcm
gameport | 1 snd_intel8x0
snd_mpu401_uart | 1 snd_intel8x0
snd_rawmidi | 1 snd_mpu401_uart
snd_seq_device | 1 snd_rawmidi
snd | 11 snd_pcm_oss snd_mixer_oss snd_intel8x0 snd_ac97_codec snd_pcm snd_timer snd_mpu401_uart snd_rawmidi snd_seq_device
soundcore | 3 snd
parport_pc | 1
lp | 0
parport | 2 partport_pc lp
autofs4 | 0
sunrpc | 1
e1000 | 0
floppy | 0
sg | 0
microcode | 0
dm_mod | 0
uhci_hcd | 0
ehci_hcd | 0
button | 0
battery | 0
asus_acpi | 0
ac | 0
ipv6 | 8
ext3 | 2
jbd | 1 ext3
ata_piix | 0
libata | 1 ata_piix,[permanent]
sd_mod | 0
scsi_mod | 3 sg libata sd_mod

I tried modprobe -l snd_intel8x0, and modprobe -l snd_ac97_codec, but nothing worked! No sound...at all! Am I loading the wrong drivers? Are they not loading correctly?

...I can't even get the console beep to...beep.

I tried turning the "start sound server on startup" on, but that just made things worse...instead of just hearing nothing on sounds, if I turn this option on, I get "osscommon: Unable to open /dev/dsp (in use ?)" (at least for mp3's).

When I tried starting KDE (I've been using Gnome and ESD, mainly), I got:

Sound server informational message:
Error while initializing the sound driver:
Device /dev/dsp can't be opened (Device or resource busy)
The sound server will continue, using the null output device

When I run esd in Gnome, I get the same message (well, perhaps just the third line).

Edit: I tried esd again, and this time it works (it's just hanging there without a new prompt)...but I still don't hear anything!

I'm a complete Linux newbie...all this lsmod and modprobe stuff is very new to me. My friend had a major part in the installation of this system, but I definitely want to go with Debian, as I want to be forced to learn...

...so, how about them sounds?

Help!



For the record, my computer is a Dell PowerEdge 400SC. The information about the sound card can be found above (thank you, Fedora).

P.S. The console beep worked immediately in Woody, but I didn't have speakers, so I didn't test sound...perhaps it would've worked...not that it matters.
 
Old 07-14-2004, 12:46 AM   #2
RunLevelZero
Member
 
Registered: Jun 2004
Distribution: Debian
Posts: 46

Rep: Reputation: 15
audio group

Add yourself to the audio group and for the heck of it " chmod 775 /dev/dsp " and " chmod 775 /dev/mixer ".

and when you say " I tried modprobe -l snd_intel8x0, and modprobe -l snd_ac97_codec, but nothing worked! "
just do a modprobe snd_intel8x0 if it's not already loaded ... the -l is not needed

what do you mean.. did you get an error message and if so what is it? if nothing happened or it didn't complain then it loaded the module. what kernel version was fedora using and what version are you using now? What is the lsmod on debian? You just showed the one from fedora.
 
Old 07-14-2004, 01:45 AM   #3
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Re: audio group

Quote:
Originally posted by RunLevelZero
Add yourself to the audio group and for the heck of it " chmod 775 /dev/dsp " and " chmod 775 /dev/mixer ".

and when you say " I tried modprobe -l snd_intel8x0, and modprobe -l snd_ac97_codec, but nothing worked! "
just do a modprobe snd_intel8x0 if it's not already loaded ... the -l is not needed

what do you mean.. did you get an error message and if so what is it? if nothing happened or it didn't complain then it loaded the module. what kernel version was fedora using and what version are you using now? What is the lsmod on debian? You just showed the one from fedora.
This may seem like a very stupid question, but how do I add myself to the audio group?

Edit: I checked the /etc/group file, and I'm already added (my GUI username).

Anyway, I did the chmod'ing like you said, The snd_intel8x0 definitely seems loaded...I didn't get any errors with or without the "-l"...

I was using Fedora Core 2, with whatever the default kernel was, and I'm currently using Sarge with the 2.6 kernel.

The lsmod on Debian:

ipv6 220384 17
appletalk 32820 20
af_packet 20616 2
snd_intel8x0 31528 0
snd_ac97_codec 54916 1 snd_intel8x0
snd_pcm_oss 47652 0
snd_mixer_oss 16640 1 snd_pcm_oss
snd_pcm 84900 2 snd_intel8x0,snd_pcm_oss
snd_timer 23044 1 snd_pcm
snd_page_alloc 10884 2 snd_intel8x0,snd_pcm
gameport 4736 1 snd_intel8x0
snd_mpu401_uart 7296 1 snd_intel8x0
snd_rawmidi 22688 1 snd_mpu401_uart
snd_seq_device 7944 1 snd_rawmidi
snd 48356 9 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi, snd_seq_device
hw_random 5652 0
ehci_hcd 26116 0
uhci_hcd 27920 0
usbcore 95068 4 ehci_hcd,uhci_hcd
pci_hotplug 32176 0
intel_agp 16668 1
intel_mch_agp 10000 0
agpgart 31272 2 intel_agp,intel_mch_agp
pcspkr 3816 0
tsdev 7168 0
mousedev 9684 2
psmouse 17544 0
floppy 54996 0
parport_pc 31552 0
parport 37320 1 parport_pc
evdev 9088 0
i810_audio 30356 1
ac97_codec 16908 1 i810_audio
soundcore 9824 3 snd,i810_audio
ata_piix 7684 0
libata 36480 1 ata_piix,[permanent]
scsi_mod 112460 1 libata
e1000 74244 0
capability 4356 0
commoncap 7168 1 capability
ide_cd 38788 0
cdrom 35488 1 ide_cd
rtc 12088 0
xfs 511800 0
reiserfs 199536 0
jfs 154364 0
vfat 13184 0
fat 41664 1 vfat
isofs 32440 0
ext3 108392 2
jbd 54040 1 ext3
ide_disk 17152 4
ide_generic 1664 0
piix 12704 1
ide_core 134496 4 ide_cd,ide_disk,ide_generic,piix
unix 25776 374
font 8576 0
cfbcopyarea 3840 0
cfbimgblt 3200 0
cfbfillrect 3712 0

Note: The console beep decided to work! ESD still does not seem to be giving me any more errors, as I mentioned in the first post (I had said earlier that it had been giving me a /dev/dsp busy message, remember?). I don't hear anything, though...


Last edited by tavilach; 07-14-2004 at 01:50 AM.
 
Old 07-14-2004, 03:01 AM   #4
zappz
LQ Newbie
 
Registered: Feb 2004
Location: New Zealand
Distribution: Debian Unstable
Posts: 28

Rep: Reputation: 15
apt-get alsa-base (or is it 'libs''?)
apt-get alsa-utils

See if you have these installed, remember that often the sound is 'muted' by default, so use a mixer to unmute and turn up volumes.
sound server should be set to 'alsa' or 'auto'
 
Old 07-14-2004, 09:30 AM   #5
taipan67
LQ Newbie
 
Registered: Jul 2004
Location: Sunny old England
Distribution: Gentoo 2004.1
Posts: 10

Rep: Reputation: 0
Hi Tavilach,

So you wanna be forced to learn, eh? Me too! That's partly why i just switched from 'sarge' to gentoo 2004.1. When i compiled the 2.6 kernel, i got sound working for the first time ever! (Newly-built system...)

I don't have internet access on that pc yet, so i'm sitting in my local library, & what follows is from memory, so it'll probably be a bit vague. When i get home, i'll try some of this on 'sarge' (it's still there for reference) & let you know if i find anything more helpful.

Now, your lsmod listed above looks healthy enough to me, & if you're running kernel 2.6, it probably has alsa built-in. To check this, have a read of /boot/config-2.6.?-i386 or whatever Debian have called it.

In gentoo, i've configured the following kernel modules to load at boot-time: soundcore; snd; snd-mixer-oss; snd-via82xx (in your case, snd-intel8x0). This is where i've whittled it down to so far without losing sound.

Next, /etc/modules.conf apparently needs these 2 lines (i'm customizing it for your card):
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0

Now this is the bit that made me glad no-one was watching... Fire up gnome (because i know what the desktop looks like), & move your mouse-pointer over the speaker symbol in the top right-hand corner. I'm guessing it has a red diagonal line through it. If we're lucky, a tip will pop up saying that the sound is muted, rather than not installed. If this is so, right-click it, unmute, set the volume levels to your taste & start shooting stuff with gay abandon!

Right, i'm off to see if that load of tosh actually gets MY 'sarge' sound working. Thanks for inspiring me...
 
Old 07-14-2004, 11:07 AM   #6
E Pierce
LQ Newbie
 
Registered: Jul 2004
Posts: 13

Rep: Reputation: 0
it is alsa-libs-1.0.5
 
Old 07-14-2004, 03:53 PM   #7
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by zappz
apt-get alsa-base (or is it 'libs''?)
apt-get alsa-utils

See if you have these installed, remember that often the sound is 'muted' by default, so use a mixer to unmute and turn up volumes.
sound server should be set to 'alsa' or 'auto'
also-base and alsa-utils are installed.

My sound is definitely not muted .

How do I set my sound server to alsa?
 
Old 07-14-2004, 04:04 PM   #8
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by taipan67
Hi Tavilach,

So you wanna be forced to learn, eh? Me too! That's partly why i just switched from 'sarge' to gentoo 2004.1. When i compiled the 2.6 kernel, i got sound working for the first time ever! (Newly-built system...)

I don't have internet access on that pc yet, so i'm sitting in my local library, & what follows is from memory, so it'll probably be a bit vague. When i get home, i'll try some of this on 'sarge' (it's still there for reference) & let you know if i find anything more helpful.

Now, your lsmod listed above looks healthy enough to me, & if you're running kernel 2.6, it probably has alsa built-in. To check this, have a read of /boot/config-2.6.?-i386 or whatever Debian have called it.

In gentoo, i've configured the following kernel modules to load at boot-time: soundcore; snd; snd-mixer-oss; snd-via82xx (in your case, snd-intel8x0). This is where i've whittled it down to so far without losing sound.

Next, /etc/modules.conf apparently needs these 2 lines (i'm customizing it for your card):
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0

Now this is the bit that made me glad no-one was watching... Fire up gnome (because i know what the desktop looks like), & move your mouse-pointer over the speaker symbol in the top right-hand corner. I'm guessing it has a red diagonal line through it. If we're lucky, a tip will pop up saying that the sound is muted, rather than not installed. If this is so, right-click it, unmute, set the volume levels to your taste & start shooting stuff with gay abandon!

Right, i'm off to see if that load of tosh actually gets MY 'sarge' sound working. Thanks for inspiring me...
That boot file has one line with alsa in it...

# ALSA USB devices
#
CONFIG_SND_USB_AUDIO=m

I added those two lines to /etc/modules.conf, but...well...still no sound!

As for the muting...it's definitely not muted.
 
Old 07-14-2004, 10:08 PM   #9
RunLevelZero
Member
 
Registered: Jun 2004
Distribution: Debian
Posts: 46

Rep: Reputation: 15
Adding to a group

" addgroup username audio " that should do it for you and put you in the group. Now make sure that the audio isn't muted because it will be most likely after adding yourself to the group, and if not sweet. You normally don't have to tell you window manager what sound server you are running... it normally will pick this up without issue. Gnome and kde and Xfce4 work fine for me on SID with 2.6.7 custom kernel and they also worked with the stock 2.6.5 kernel on sid. Hope this gets things working because your lsmod looks just fine. You will not need to add those entries into /etc/modules because debian should have taken care of that for you and btw don't touch /etc/modules.conf - that's a no no on debian. Instead edit just the /etc/modules and add whatever module name you need to load. Also for those reading this and that are going to upgrade to kernel 2.6.7 and use usb input devices. modprobe hid won't do it anymore. You need to modprobe usbhid and all is well.
 
Old 07-15-2004, 01:31 AM   #10
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Re: Adding to a group

Quote:
Originally posted by RunLevelZero
" addgroup username audio " that should do it for you and put you in the group. Now make sure that the audio isn't muted because it will be most likely after adding yourself to the group, and if not sweet. You normally don't have to tell you window manager what sound server you are running... it normally will pick this up without issue. Gnome and kde and Xfce4 work fine for me on SID with 2.6.7 custom kernel and they also worked with the stock 2.6.5 kernel on sid. Hope this gets things working because your lsmod looks just fine. You will not need to add those entries into /etc/modules because debian should have taken care of that for you and btw don't touch /etc/modules.conf - that's a no no on debian. Instead edit just the /etc/modules and add whatever module name you need to load. Also for those reading this and that are going to upgrade to kernel 2.6.7 and use usb input devices. modprobe hid won't do it anymore. You need to modprobe usbhid and all is well.
As I stated above, I'm already added. I ran addgroup username audio, just in case, and I am indeed added.

For the fiftieth time, my sound ain't muted .
 
Old 07-15-2004, 07:29 AM   #11
taipan67
LQ Newbie
 
Registered: Jul 2004
Location: Sunny old England
Distribution: Gentoo 2004.1
Posts: 10

Rep: Reputation: 0
Mate!

If it's education you want, stick with 'sarge' - gentoo's a fuckin' doddle by comparison.

Right, i got my sound device working, but can't hear anything because my copy of 'sarge' has no actual alsa drivers!

Most of what follows was gleened from the kernel source-code /Documents/sound/alsa/alsa.configuration file, then modified by alsa itself...

As RunLevelZero said, editing /etc/modules.conf directly is wrong, because modprobe rewrites it at every boot (i think - it's explained at the top of the file). What you do is edit the files in the /etc/modutils/ directory, then run update-modules. This is the file '/etc/modutils/alsa' that the alsa-base.deb creates:-

alias char-major-116 snd
alias char-major-14 soundcore
options snd major=116 cards_limit=4
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias /dev/dsp* snd-pcm-oss
alias snd-card-0 snd-via82xx (for me, at least)
alias snd-slot-0 snd-card-0
alias sound-slot-0 snd-slot-0

If you don't have similar aliases, maybe creating an equivalent file & running update-modules would help...

The other problem i had was no audio devices created. If you're in the same boat, the solution depends on your kernel configuration. If you DON'T load devfs at boot-time, you will need to use mknod or MAKEDEV to create them, & i don't know how to do that, or precisely what devices you need.

If devfs DOES load at boot, you should have an /etc/devfs/conf.d/ directory, which needs your devices registered in it. This is what alsa-base.deb created on mine as filename:/etc/devfs/conf.d/alsa:-

REGISTER ^snd/.* PERMISSIONS root.audio 0660
REGISTER ^snd/controlC0 CFUNCTION GLOBAL symlink /proc/asound/oss/sndstat sndstat

That has been word-wrapped - the symlink bit should be on the controlC0 line. Once again, it's different to the source-code document, but i'll not argue with alsa about their own setup.

See if that helps. I'm off to see if i've got alsa-libs-1.0.5...
 
Old 07-15-2004, 11:08 AM   #12
SlCKB0Y
Member
 
Registered: Oct 2001
Location: Sydney, Australia
Distribution: Debian Unstable
Posts: 288

Rep: Reputation: 46
Re: audio group

Quote:
Originally posted by RunLevelZero
and for the heck of it " chmod 775 /dev/dsp " and " chmod 775 /dev/mixer ".
hmmmmmmmm. Or not
 
Old 07-15-2004, 12:34 PM   #13
RunLevelZero
Member
 
Registered: Jun 2004
Distribution: Debian
Posts: 46

Rep: Reputation: 15
ok

Well the chmod 775 comes from my Slackware days where if you did not do that then your normal users did not have access to them and could not oh... turn up the volume or even use the sound but anyways, have you turned up the pcm volume? If you are only turning up the " master " volume then try also turning up pcm if it is not already. Other than that I think I'm done with this one.
 
Old 07-15-2004, 07:22 PM   #14
tavilach
Member
 
Registered: Jun 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by taipan67
Mate!

If it's education you want, stick with 'sarge' - gentoo's a fuckin' doddle by comparison.

Right, i got my sound device working, but can't hear anything because my copy of 'sarge' has no actual alsa drivers!

Most of what follows was gleened from the kernel source-code /Documents/sound/alsa/alsa.configuration file, then modified by alsa itself...

As RunLevelZero said, editing /etc/modules.conf directly is wrong, because modprobe rewrites it at every boot (i think - it's explained at the top of the file). What you do is edit the files in the /etc/modutils/ directory, then run update-modules. This is the file '/etc/modutils/alsa' that the alsa-base.deb creates:-

alias char-major-116 snd
alias char-major-14 soundcore
options snd major=116 cards_limit=4
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias /dev/dsp* snd-pcm-oss
alias snd-card-0 snd-via82xx (for me, at least)
alias snd-slot-0 snd-card-0
alias sound-slot-0 snd-slot-0

If you don't have similar aliases, maybe creating an equivalent file & running update-modules would help...

The other problem i had was no audio devices created. If you're in the same boat, the solution depends on your kernel configuration. If you DON'T load devfs at boot-time, you will need to use mknod or MAKEDEV to create them, & i don't know how to do that, or precisely what devices you need.

If devfs DOES load at boot, you should have an /etc/devfs/conf.d/ directory, which needs your devices registered in it. This is what alsa-base.deb created on mine as filename:/etc/devfs/conf.d/alsa:-

REGISTER ^snd/.* PERMISSIONS root.audio 0660
REGISTER ^snd/controlC0 CFUNCTION GLOBAL symlink /proc/asound/oss/sndstat sndstat

That has been word-wrapped - the symlink bit should be on the controlC0 line. Once again, it's different to the source-code document, but i'll not argue with alsa about their own setup.

See if that helps. I'm off to see if i've got alsa-libs-1.0.5...
*Runs away, terrified*

Ahh! Any chance of explaining what I should do in...newbie terms? I'm really confused...

 
Old 07-16-2004, 08:25 AM   #15
taipan67
LQ Newbie
 
Registered: Jul 2004
Location: Sunny old England
Distribution: Gentoo 2004.1
Posts: 10

Rep: Reputation: 0
Me again!

First, an apology. My last post sounds a bit petulant & condescending about the /etc/modules.conf thing. Sorry. My fault entirely, i should've explained myself better. In my defence, i'm on a public-access pc, & my time allotment is restricted, so i rush a bit. Plus i can't just paste this stuff across, i have to write it all from memory or notes.

Next, a qualification. My copy of 'sarge' only includes pre-compiled kernel-images of 2.4.25, which didn't contain alsa, & as i said yesterday, the alsa-base package doesn't appear to load the actual drivers... I've been trying to build a 2.6 kernel to test these suggestions with drivers in place, but haven't got one to boot yet, because all my partition superblocks are corrupt. Why this doesn't bother my other 3 kernels, i have no idea.

Okay, first suggestion - install a kernel-source package & have a good read. Using your favourite package manager will put a source-code tarball in the /usr/src/ directory. Unpack it, either from a console with "tar -xjf (if it's a bz2)filename", or from nautilus or konqueror by right-clicking & selecting "extract to...". First port-of-call i'd recommend in the created directory is the Documents/ sub-directory. In the ALSA-Configuration.txt file i mentioned yesterday, as well as the stuff about aliases & registrations, is some driver-specific options, which i'll leave for another day.

Regarding yesterday's horror-show, after having time to reflect, if your previous posts are any indication, you should have all that stuff already, but here's how to check... (Everybody please post corrections for my mistakes before we break anything!)

The aliases are read by the kernel from /etc/modules.conf, but to change them needs yesterday's process. For now, open /etc/modules.conf in a viewer, & see if you have "alias snd-card-0 snd-intel8x0", or for that matter any aliases for "snd-something" or "sound-something".

The other thing to check for now, is whether you have the necessary devices in the /dev directory. When i manually created the registration entries suggested in the ALSA-Configuration.txt file, i suddenly acquired a load of /dev/audio* devices. Look for /dev/audio &/or a directory called /dev/snd/, which on mine is full of pcm & mixer devices.

Post what you find for our collective entertainment, & we'll take it from there... While you're at it, can you post your precise kernel-version (eg: 2.6.5)? Your earlier post about /boot/config entries has given me an idea, but i'd like to run THIS theory to ground first.

As a parting note, can i say don't feel intimidated. I'm a newbie myself, & most of my (limited) linux knowhow has been learned in the last month.

Talk to you tomorrow...

ps: Just thought of something which may save a day or two if macondo's following post doesn't help:-

If you DO have the devices mentioned in the /dev directory, make a note of the ownership & permissions for us. I find this easiest in nautilus (no kde installed at present). To access this information, right-click on the device, select "properties", & go to the "permissions" tab. What i'm after is the owner, group & the octal number that governs who has read, write, execute access to the file. It will probably be owner:root, group:audio, permission:660 (or 0660). Perhaps the fastest way would be to open a terminal & run "ls" with an option to only display files in the /dev & sub-directories with an audio group-id. I can't tell you how to do that. Any suggestions, folks?

If you DON'T have any audio-group devices, let me know if you have a directory called /etc/devfs/, & if you do, what's in it. This is where my device registrations are...

Back in the morning, night-night!

Last edited by taipan67; 07-16-2004 at 10:01 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound won't work in Sarge akempo Debian 5 03-11-2008 10:26 AM
No Sound - Debian Sarge jrcreasy Linux - Newbie 7 08-27-2005 11:30 AM
No sound on Debian sarge carloscuderia Linux - Newbie 5 04-08-2005 04:25 PM
sound problem with sarge DrkSn Debian 2 12-20-2004 05:52 PM
Sound in Debian Sarge Kernel 2.6 quentusrex Debian 13 08-13-2004 11:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 07:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration