LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-22-2006, 12:15 PM   #1
tvynr
Member
 
Registered: Apr 2004
Distribution: Debian
Posts: 143

Rep: Reputation: 15
no nVidia 3D acceleration using Xorg 7, Etch


Hi, there. I just recently upgraded to Xorg 7 and, like so many others, am finding the transition a bit rocky. So here's the story.

I've upgraded to Xorg 7, nvidia-glx=1.0.8762-2, nvidia-kernel-source=1.0.8762-2, and nvidia-kernel-common=20051028+1. I ran "m-a a-i -f nvidia" to install the nVidia drivers the "Debian way" (which I would prefer to use over the official vendor installer). I am using a custom-compiled Linux kernel 2.6.14.6 and the nVidia drivers seemed to compile and work with it quite nicely. The xorg.conf does not have any mention of the dri or GLcore modules; it does use glx. Also, to enable direct rendering and avoid Debian bug #208198, I relinked the libraries in /usr/X11R6/lib (see http://wiki.debian.org/NvidiaGraphic...59ba3d657faeb).

Despite all of this, glxgears is producing a framerate between 300 and 600 FPS and Cedega tests for both OpenGL Direct Rendering and 3D Acceleration fail. Before I upgraded to Xorg 7, my framerate was in the range of 11,000 FPS.

Does anyone have any suggestions? The following console sessions may be useful.

Code:
zpalmer@nestor:~$ glxinfo | egrep '(vendor|version|client|server|render)'
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
client glx extensions:
GLX version: 1.3
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 6800 GS/PCI/SSE2
OpenGL version string: 2.0.2 NVIDIA 87.62
    GL_NVX_conditional_render, GL_SGIS_generate_mipmap, GL_SGIS_texture_lod,
glu version: 1.3
Code:
zpalmer@nestor:~$ grep "WW" /var/log/Xorg.0.log
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) The directory "/usr/share/fonts/X11/misc" does not exist.
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
(WW) The directory "/usr/X11R6/lib/X11/fonts/cyrillic" does not exist.
(WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
(WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
(WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
(WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
(WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
(WW) NVIDIA(0): Option "UseFBDev" is not used
Code:
zpalmer@nestor:~$ cat /etc/X11/xorg.conf
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
        FontPath        "/usr/share/fonts/X11/misc"
        FontPath        "/usr/X11R6/lib/X11/fonts/misc"
        FontPath        "/usr/share/fonts/X11/cyrillic"
        FontPath        "/usr/X11R6/lib/X11/fonts/cyrillic"
        FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath        "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath        "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/Type1"
        FontPath        "/usr/X11R6/lib/X11/fonts/Type1"
        FontPath        "/usr/share/fonts/X11/100dpi"
        FontPath        "/usr/X11R6/lib/X11/fonts/100dpi"
        FontPath        "/usr/share/fonts/X11/75dpi"
        FontPath        "/usr/X11R6/lib/X11/fonts/75dpi"
        # path to defoma fonts
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
        Load    "bitmap"
        Load    "dbe"
        Load    "ddc"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "record"
        Load    "type1"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc104"
        Option          "XkbLayout"     "us"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ExplorerPS/2"
        Option          "Emulate3Buttons"       "true"
EndSection

Section "Device"
        Identifier      "Generic Video Card"
        Driver          "nvidia"
        Option          "UseFBDev"              "true"
EndSection

Section "Monitor"
        Identifier      "Generic Monitor"
        Option          "DPMS"
        HorizSync       30-65
        VertRefresh     50-75
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "Generic Video Card"
        Monitor         "Generic Monitor"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           15
                Modes           "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes           "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes           "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
EndSection

Section "DRI"
        Mode    0666
EndSection
Any help is much appreciated. Thanks for your time!
 
Old 08-22-2006, 01:47 PM   #2
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Rep: Reputation: 49
Quote:
Originally Posted by tvynr
Hi, there. I just recently upgraded to Xorg 7 and, like so many others, am finding the transition a bit rocky. So here's the story.

I've upgraded to Xorg 7, nvidia-glx=1.0.8762-2, nvidia-kernel-source=1.0.8762-2, and nvidia-kernel-common=20051028+1. I ran "m-a a-i -f nvidia" to install the nVidia drivers the "Debian way" (which I would prefer to use over the official vendor installer). I am using a custom-compiled Linux kernel 2.6.14.6 and the nVidia drivers seemed to compile and work with it quite nicely. The xorg.conf does not have any mention of the dri or GLcore modules; it does use glx. Also, to enable direct rendering and avoid Debian bug #208198, I relinked the libraries in /usr/X11R6/lib (see http://wiki.debian.org/NvidiaGraphic...59ba3d657faeb).

Despite all of this, glxgears is producing a framerate between 300 and 600 FPS and Cedega tests for both OpenGL Direct Rendering and 3D Acceleration fail. Before I upgraded to Xorg 7, my framerate was in the range of 11,000 FPS.

Does anyone have any suggestions? The following console sessions may be useful.

Code:
zpalmer@nestor:~$ glxinfo | egrep '(vendor|version|client|server|render)'
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
client glx extensions:
GLX version: 1.3
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 6800 GS/PCI/SSE2
OpenGL version string: 2.0.2 NVIDIA 87.62
    GL_NVX_conditional_render, GL_SGIS_generate_mipmap, GL_SGIS_texture_lod,
glu version: 1.3
Code:
zpalmer@nestor:~$ grep "WW" /var/log/Xorg.0.log
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) The directory "/usr/share/fonts/X11/misc" does not exist.
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
(WW) The directory "/usr/X11R6/lib/X11/fonts/cyrillic" does not exist.
(WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
(WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
(WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
(WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
(WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
(WW) NVIDIA(0): Option "UseFBDev" is not used
Code:
zpalmer@nestor:~$ cat /etc/X11/xorg.conf
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
        FontPath        "/usr/share/fonts/X11/misc"
        FontPath        "/usr/X11R6/lib/X11/fonts/misc"
        FontPath        "/usr/share/fonts/X11/cyrillic"
        FontPath        "/usr/X11R6/lib/X11/fonts/cyrillic"
        FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath        "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath        "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/Type1"
        FontPath        "/usr/X11R6/lib/X11/fonts/Type1"
        FontPath        "/usr/share/fonts/X11/100dpi"
        FontPath        "/usr/X11R6/lib/X11/fonts/100dpi"
        FontPath        "/usr/share/fonts/X11/75dpi"
        FontPath        "/usr/X11R6/lib/X11/fonts/75dpi"
        # path to defoma fonts
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
        Load    "bitmap"
        Load    "dbe"
        Load    "ddc"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "record"
        Load    "type1"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc104"
        Option          "XkbLayout"     "us"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ExplorerPS/2"
        Option          "Emulate3Buttons"       "true"
EndSection

Section "Device"
        Identifier      "Generic Video Card"
        Driver          "nvidia"
        Option          "UseFBDev"              "true"
EndSection

Section "Monitor"
        Identifier      "Generic Monitor"
        Option          "DPMS"
        HorizSync       30-65
        VertRefresh     50-75
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "Generic Video Card"
        Monitor         "Generic Monitor"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           15
                Modes           "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes           "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes           "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
EndSection

Section "DRI"
        Mode    0666
EndSection
Any help is much appreciated. Thanks for your time!

I am not sure if rocky motion is sufficient to judge that you do not have 3-D acceleration, but the line direct rendering: Yes generally means that 3D acceleration is enabled. Try installing planet-racer and see if the mouse is dragging while clicking on any options.

I only know these two methods to test it.
 
Old 08-22-2006, 06:47 PM   #3
tvynr
Member
 
Registered: Apr 2004
Distribution: Debian
Posts: 143

Original Poster
Rep: Reputation: 15
Well, installing PP Racer is not necessary, since I installed it long, long ago. Racer shows an FPS of ~130 with no performance problems. I still can't beat "Tux the Winter Sportsman", though.

I am led to believe that I do not have 3D acceleration because of two things:

1) My roommate's computer, running Debian Etch with Xorg 6.9 (whereas I have Xorg 7.0) is handling 3D just fine. We have the same card and same motherboard. He gets about 11k FPS out of glxgears. I'm getting less than 1k.

2) Cedega was running CounterStrike before in Direct3D mode. It was all happy and good; the game ran smoothly and without difficulty. Now, CounterStrike refuses to run in anything but Software mode. Cedega's tests claim that it has no 3D acceleration, so I'm disposed to believe it.

It's possible that there's something else wrong and that, deep down in there, 3D is actually working. However, to my knowledge, all "direct rendering: yes" means is that applications don't have to go through X libraries to draw on the screen, not necessarily that I have any kind of assistance from my GPU in rendering a 3D environment.

Thanks for the suggestion, though. I'll keep digging and post here if I find anything.
 
Old 08-23-2006, 05:06 PM   #4
tvynr
Member
 
Registered: Apr 2004
Distribution: Debian
Posts: 143

Original Poster
Rep: Reputation: 15
Update: I removed the Debian nVidia packages from my machine and installed the nVidia drivers using the official installer. Essentially, I did apt-get remove on all things prefixed with "nvidia-", then apt-get install xserver-xorg-dev (to fix the common path problem with current nVidia driver installers), and then I ran the official nVidia installer binary.

OpenGL works now, but Cedega still complains I have no 3D acceleration. I have no real way to verify whether or not this is true, but CS is playable for the time being. Does anyone have any suggestions as to how I test Cedega's claim?
 
Old 08-24-2006, 11:13 AM   #5
tvynr
Member
 
Registered: Apr 2004
Distribution: Debian
Posts: 143

Original Poster
Rep: Reputation: 15
Update: I tried removing three kinds of framebuffer support from my kernel which may conflict with nVidia drivers. No success. I also removed the DRI section from my xorg.conf; still no luck.

Right now, I'm trying to collect a little information on why there is a difference between the Debian way and the official vendor installer. I did a diff on some of my root directories and I got this:

The following files are present when the Debian way is used but NOT when the official vendor installer is used:

Code:
/lib/modules/2.6.14.6/nvidia
/lib/modules/2.6.14.6/nvidia/nvidia.ko
/usr/lib/libXvMCNVIDIA_dynamic.so.1
/usr/lib/libXvMCNVIDIA.so.1
/usr/lib/libXvMCNVIDIA.so.1.0.8762
/usr/lib/nvidia
/usr/lib/nvidia/libGL.so.1.2.xlibmesa
/usr/lib/nvidia/libGL.so.1.xlibmesa
/usr/lib/nvidia/libglx.so.xlibmesa
/usr/lib/nvidia/libnvidia-cfg.so.1.0.8762
/usr/lib/nvidia/libnvidia-tls.so.1.0.8762
/usr/lib/nvidia/tls_test
/usr/lib/nvidia/tls_test_dso.so
/usr/lib/xorg/modules/extensions/libGLcore.so
/usr/share/bug/nvidia-glx
/usr/share/bug/nvidia-glx/script
/usr/share/lintian/overrides/nvidia-glx
/usr/share/lintian/overrides/nvidia-kernel-2.6.14.6
/usr/share/nvidia-kernel-common
/usr/share/nvidia-kernel-common/nvidia-kernel.modules.devfs
/usr/src/nvidia-kernel-source.tar.gz
/usr/X11R6/lib/libGL.so
/usr/X11R6/lib/libGL.so.1
The following files are present when the official vendor installer is used but NOT when the Debian way is used:

Code:
/lib/modules/2.6.14.6/kernel/drivers/video/nvidia.ko
/usr/bin/nvidia-installer
/usr/bin/nvidia-settings
/usr/bin/nvidia-xconfig
/usr/lib/libGL.la
/usr/lib/libnvidia-cfg.so
/usr/lib/libnvidia-cfg.so.1
/usr/lib/libnvidia-cfg.so.1.0.8762
/usr/lib/xorg/modules/drivers/nvidia_drv.so
/usr/share/applications/nvidia-settings.desktop
/usr/share/man/man1/nvidia-installer.1.gz
/usr/share/man/man1/nvidia-settings.1.gz
/usr/share/man/man1/nvidia-xconfig.1.gz
/usr/X11R6/lib/libXvMCNVIDIA.a
/usr/X11R6/lib/libXvMCNVIDIA_dynamic.so.1
/usr/X11R6/lib/libXvMCNVIDIA.so.1.0.8762
Can anyone make sense of what this means? I'm a relative newbie (8 months of using Debian as my desktop - Win2K before that), so I'm really not familiar enough to understand what I need to fix here or even what of those two lists are important. Note that the same xorg.conf was used in both cases...


EDIT:

Another thing did just occur to me. The official nVidia driver asked me something along the lines of "would you like to install nVidia's OpenGL 32-bit compatibility libraries?" I'm running a 64-bit AMD system... is there some additional package I need to download and install to get my 32-bit packages to properly run OpenGL/3D?

Last edited by tvynr; 08-24-2006 at 11:23 AM.
 
Old 08-24-2006, 11:30 AM   #6
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 463Reputation: 463Reputation: 463Reputation: 463Reputation: 463
Try editing your Xorg.config file to the following:

Drivers Section
Replace "nv" with "nvidia"

Modules Section
Remove or comment out lines including "dri" and "GLCore"
Ensure there is a line with Load "glx"

Installing drivers is one of the reasons I run Kanotix(Debian Sid) rather than vanilla Debian.

All it takes to install drivers is to run a simple script.
Nvidia graphic cards driver installation:
su
init 3
update-scripts-kanotix.sh
install-nvidia-debian.sh
 
Old 08-24-2006, 11:53 AM   #7
tvynr
Member
 
Registered: Apr 2004
Distribution: Debian
Posts: 143

Original Poster
Rep: Reputation: 15
Thanks for the suggestions. Actually, the end of my OP lists (admittedly in a bit of an odd, verbose way) my xorg.conf. Load "glx" is present, Load "GLCore" and Load "dri" have been removed, and I am indeed using the "nvidia" driver.

I've personally had this and that unpleasant experience with Sid before, so while I have the unstable sources in my sources.list, I keep to Etch unless I have a good reason not to do so (i.e., there are no testing nVidia driver packages).
 
Old 08-29-2006, 12:43 PM   #8
tvynr
Member
 
Registered: Apr 2004
Distribution: Debian
Posts: 143

Original Poster
Rep: Reputation: 15
Update: I've migrated to a Debian stock kernel (2.6.17-2-amd64) and am still using the vendor nVidia installer package. Both Cedega and glxgears still suggest to me that there is no change... so it's not likely to be my kernel config.

A friend of mine has a nearly identical machine and his box is running 32-bit 3D just fine. The only difference between our machines is the amount and speed of RAM, the speed of the CPU, and the fact that I have a hardware muxing sound card. *shrugs*

I will continue to delve into his machine to determine the difference between them, but I am not hopeful.
 
Old 08-29-2006, 12:59 PM   #9
binary1011100
Member
 
Registered: Apr 2006
Location: Manchester, UK
Distribution: Slackware, Debian
Posts: 89

Rep: Reputation: 15
Smile

Quote:
Originally Posted by tvynr
Update: I've migrated to a Debian stock kernel (2.6.17-2-amd64) and am still using the vendor nVidia installer package. Both Cedega and glxgears still suggest to me that there is no change... so it's not likely to be my kernel config.

A friend of mine has a nearly identical machine and his box is running 32-bit 3D just fine. The only difference between our machines is the amount and speed of RAM, the speed of the CPU, and the fact that I have a hardware muxing sound card. *shrugs*

I will continue to delve into his machine to determine the difference between them, but I am not hopeful.
Hi i'm not sure why you changed your kernel back to the stock but never mind, I recommend before you run the nvidia drivers renaming you nvidia config file to something like xorg.conf-backup and then executing the latest NVIDIA driver from the NVIDIA site let the driver auto config your xorg.conf then hopefully 3D should work
 
Old 09-06-2006, 07:47 PM   #10
tvynr
Member
 
Registered: Apr 2004
Distribution: Debian
Posts: 143

Original Poster
Rep: Reputation: 15
Well, I finally got sick of messing with it and blasted my root. A fresh install (AMD64 Sarge, later upgraded to most recent Etch) with a fresh chroot followed by a vendor nVidia drivers installation fixed it. Cedega lights up all green now.

Not sure what was wrong; I probably messed up some link or another a while ago in my previous efforts to fix this problem. Now everything dances. Problem pseudo-solved. Thanks for the replies, everyone!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
no display: Xorg, Nvidia driver broken after Etch update; Failed to load module "glx" forgox Debian 19 07-12-2010 01:26 PM
Etch Xorg 7 and fonts cougyr Debian 13 08-19-2006 10:38 PM
multi screen etch and xorg.conf knobby67 Debian 2 06-23-2006 01:54 PM
xorg 3d acceleration for nvidia card dukeinlondon Debian 3 10-07-2005 04:39 PM
upgraded to etch, xorg causing errors, HELP!!! microsoft/linux Debian 10 09-27-2005 07:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 02:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration