LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 02-03-2005, 06:57 AM   #1
montylee
Member
 
Registered: May 2003
Location: India
Distribution: Ubuntu 7.04, Fedora Core 9
Posts: 168

Rep: Reputation: 30
No GUI in Debian


Hi,

A friend of mine is using Debian Woody (i guess the version is 3.0). It boots from a floppy and boots up in text mode. When i type startx, it tries different graphical modes and gives an "Insufficient memory" error. I want to boot it in GUI mode.
The GUI only works in 8-bit color mode and not on higher values.
I tried several values of video memory but it didn't worked.
Here is some part of X-server log:

This is a pre-release version of XFree86, and is not supported in any
way. Bugs may be reported to XFree86@XFree86.Org and patches submitted
to fixes@XFree86.Org. Before reporting bugs in pre-release versions,
please check the latest version in the XFree86 CVS repository
(http://www.XFree86.Org/cvs)

XFree86 Version 4.1.0.1 / X Window System
(protocol Version 11, revision 0, vendor release 6510)
Release Date: 21 December 2001
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/FAQ)
Build Operating System: Linux 2.6.9-rc1 i686 [ELF]
Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Wed Feb 2 17:07:57 2005
(==) Using config file: "/etc/X11/XF86Config-4"
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "HCL HCM780M"
(**) | |-->Device "Generic Video Card"
(**) |-->Input Device "Generic Keyboard"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc104"
(**) XKB: model: "pc104"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "Configured Mouse"
(**) |-->Input Device "Generic Mouse"

(II) Setting vga for screen 0.
(**) VGA(0): Depth 16, (--) framebuffer bpp 16
(==) VGA(0): RGB weight 565
(==) VGA(0): Default visual is TrueColor
(==) VGA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) VGA(0): videoRam: 64000 kBytes (using 256 kBytes).
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(--) VGA(0): Pixel clocks available:
(--) VGA(0): pixel clocks: 25.510 28.322 25.170 25.170
(II) VGA(0): HCL HCM780M: Using hsync range of 28.00-38.00 kHz
(II) VGA(0): HCL HCM780M: Using vrefresh range of 43.00-72.00 Hz
(II) VGA(0): Not using default mode "640x350" (insufficient memory for mode)
(II) VGA(0): Not using default mode "640x400" (insufficient memory for mode)
(II) VGA(0): Not using default mode "720x400" (insufficient memory for mode)
(II) VGA(0): Not using default mode "640x480" (insufficient memory for mode)
(II) VGA(0): Not using default mode "640x480" (insufficient memory for mode)
(II) VGA(0): Not using default mode "640x480" (insufficient memory for mode)
(II) VGA(0): Not using default mode "640x480" (insufficient memory for mode)
(II) VGA(0): Not using default mode "800x600" (insufficient memory for mode)
(II) VGA(0): Not using default mode "800x600" (insufficient memory for mode)
(II) VGA(0): Not using default mode "800x600" (insufficient memory for mode)
(II) VGA(0): Not using default mode "800x600" (insufficient memory for mode)
(II) VGA(0): Not using default mode "800x600" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1024x768" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1024x768" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1024x768" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1024x768" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1024x768" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1152x864" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1280x960" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1280x960" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1280x1024" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1280x1024" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1280x1024" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1600x1200" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1600x1200" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1600x1200" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1600x1200" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1600x1200" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1792x1344" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1792x1344" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1856x1392" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1856x1392" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1920x1440" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1920x1440" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1400x1050" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1400x1050" (insufficient memory for mode)
(WW) VGA(0): Mode pool is empty
(==) VGA(0): Virtual size is 320x200 (pitch 320)
(**) VGA(0): Built-in mode "Generic 320x200 default mode": 12.6 MHz (scaled from 25.2 MHz), 31.5 kHz, 70.2 Hz (VScan)
(II) VGA(0): Modeline "Generic 320x200 default mode" 12.59 320 336 384 400 200 206 207 224 vscan 2 -hsync +vsync
(++) VGA(0): DPI set to (100, 100)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.1
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
# 0 0 0xf6000000 - 0xf7ffffff (0x2000000) MS[B]
[1] 0 0 0xf4000000 - 0xf4ffffff (0x1000000) MS[B]
[2] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[3] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[4] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[5] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[6] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[7] -1 0 0xf3800000 - 0xf3ffffff (0x800000) MX[B]E
[8] -1 0 0xf8000000 - 0xffffffff (0x8000000) MX[B]E
[9] -1 0 0xf5ff0000 - 0xf5ffffff (0x10000) MX[B](B)
[10] -1 0 0xf6000000 - 0xf7ffffff (0x2000000) MX[B](B)
[11] -1 0 0xf4000000 - 0xf4ffffff (0x1000000) MX[B](B)
[12] 0 0 0x000a0000 - 0x000affff (0x10000) MS[B]
[13] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[B](OprU)
[14] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[B](OprU)
[15] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[16] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[17] -1 0 0x0000d400 - 0x0000d4ff (0x100) IX[B]E
[18] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[B]E
[19] -1 0 0x0000b000 - 0x0000b0ff (0x100) IX[B]E
[20] -1 0 0x0000b400 - 0x0000b4ff (0x100) IX[B]E
[21] -1 0 0x0000b800 - 0x0000b8ff (0x100) IX[B]E
[22] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B]
[23] 0 0 0x000003c0 - 0x000003df (0x20) IS[B]

Fatal server error:
AddScreen/ScreenInit failed for driver 0


When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to submit@bugs.debian.org.


Could anyone help ???
 
Old 02-03-2005, 07:28 AM   #2
slayerboy
LQ Newbie
 
Registered: Sep 2003
Location: Rochester, NY
Distribution: Debian
Posts: 11

Rep: Reputation: 0
how much memory do you have? what kind of video card do you have? Is it integrated or in an AGP or PCI slot? What are the rest of your specs?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian GUI Installer is OUT SlackerLX Debian 2 11-06-2005 02:02 PM
gui on debian 3.0? smuggly Debian 5 08-14-2004 05:50 PM
GUI change in Debian waynevnc Debian 6 06-04-2004 09:15 AM
debian GUI tszhim Linux - Laptop and Netbook 5 05-22-2004 01:17 PM
Debian and GUI installation LinuxSeeker Debian 3 04-05-2004 11:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 11:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration