LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 07-10-2007, 08:38 AM   #1
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215
Blog Entries: 2

Rep: Reputation: 49
no Fn+suspend with Etch?


Have just installed Etch and don't get suspend with the keys Fn+suspend like I used to.

Unlike before it's got acpi, but nothing happens if put lid down. How get suspend? Thanks any help.
 
Old 07-10-2007, 08:47 AM   #2
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 57
Quote:
Originally Posted by lugoteehalt
Have just installed Etch and don't get suspend with the keys Fn+suspend like I used to.
Like u used to with.. debian?
On debian (as on other distro) I have to define my special keys (fn+multimedia) myself, but some are lucky it's done automatically.
Quote:
Unlike before it's got acpi, but nothing happens if put lid down. How get suspend? Thanks any help.
You need to define the action to suspend when lid is down (I am happy it's not by default btw). Either with your WindowManager or from the CLI.
 
Old 07-10-2007, 09:38 AM   #3
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215

Original Poster
Blog Entries: 2

Rep: Reputation: 49
Quote:
Originally Posted by nx5000
Like u used to with.. debian?
On debian (as on other distro) I have to define my special keys (fn+multimedia) myself, but some are lucky it's done automatically.

You need to define the action to suspend when lid is down (I am happy it's not by default btw). Either with your WindowManager or from the CLI.
Previously used Debian Sarg and it was automatic. So I have to fiddle about with ACPI, do I? Bit of a bugger I seem to recall. Perhaps if got rid of it, it wasn't on Sarge, then suspend would work? Thanks.
 
Old 07-10-2007, 09:55 AM   #4
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 57
Which window manager do you use?
You have to know if the acpi event is received, if it is treated as "suspend". KDE does this with klaptop, it works quite well.
A lot of things changed between sarge and etch.

Does suspend work at all, manually?

Last edited by nx5000; 07-10-2007 at 09:58 AM.
 
Old 07-11-2007, 07:10 AM   #5
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215

Original Poster
Blog Entries: 2

Rep: Reputation: 49
Thanks. Enlightenment.

Havn't got room for KDE. Don't know how to suspend manually '$ suspend' ??
 
Old 07-11-2007, 08:44 AM   #6
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 57
Quote:
Originally Posted by lugoteehalt
Thanks. Enlightenment.
Ok, I don't know if there is such applet or whatever in this WM. Probably better with a daemon running (which is actually much better for the cases where your WM is not running)
You could play with this one then look around in /etc/acpi
There are some examples here:
http://www.chaotika.org/~bluesceada/...t&sub=thinkpad
Quote:
Havn't got room for KDE. Don't know how to suspend manually '$ suspend' ??
I use "sudo s2disk" and "sudo s2ram" from uswsusp package.


edit:
It looks like the acpid provides /etc/acpi/sleep.sh and /etc/acpi/hibernate.sh which is quite more complicated than my little line.. maybe worth looking.

Last edited by nx5000; 07-11-2007 at 09:23 AM.
 
Old 07-11-2007, 09:15 AM   #7
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 57
There is an other tool that works on a lot of computer that don't have specific drivers (like mine)
I use this:
xbindkeys

Example you want to call s2disk when you press Fn-f12
xbindkeys --key

Copy the lines in ~/.xbindkeysrc and replace "no command" by "sudo s2disk".

Launch xbindkeys
xbindkeys

Then try fnf12 it should call "sudo s2disk"

I have Volume + , Volume - , Mute, Window key is "xmms2 next"
Quote:
"aumix -v-10"
m:0x0 + c:174

"aumix -v+10"
m:0x0 + c:176

"mute"
m:0x0 + c:160

"xmms2 play"
m:0xffeb + c:41

"sudo s2disk"
m:0x0 + c:96
F12

Last edited by nx5000; 07-11-2007 at 09:24 AM.
 
Old 07-12-2007, 08:44 AM   #8
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215

Original Poster
Blog Entries: 2

Rep: Reputation: 49
Thanks nx5000. $ hibernate works, thought have to be root - chmod u+s /blah/hibernate didn't work. Perhaps sudo hibernate?

acpi seems only to have the power button covered - even that's a bit complex: the shell script involves other things beside 'shutdown'. I'll try your suggestions and see what happens. It's tempting to remove acpi and replace it with apm, which was very good under sarge, giving back light turn off when bios times out, which doesn't happen now. Thanks again.
 
Old 07-12-2007, 09:15 AM   #9
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 57
Quote:
Originally Posted by lugoteehalt
Thanks nx5000. $ hibernate works, thought have to be root - chmod u+s /blah/hibernate didn't work. Perhaps sudo hibernate?
+s bit has only effect on ELF binaries! Not on perl script nor shell script.
I do "sudo s2disk", probably "sudo hibernate" is even better, I didn't know this stuff.
I don't know a lot acpi but even less apm..
 
Old 07-12-2007, 09:34 AM   #10
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215

Original Poster
Blog Entries: 2

Rep: Reputation: 49
Quote:
Originally Posted by nx5000
+s bit has only effect on ELF binaries! Not on perl script nor shell script.
Good stuff - didn't know that thing about ELF binaries.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suspend-resume not working with ati or flgrx driver in Etch 1madstork Debian 2 06-11-2007 07:56 PM
from Etch testing to Etch stable, or to Lenny Perquisitor Debian 7 04-13-2007 03:27 PM
update Debian testing etch RC1 to etch stable cccc Debian 11 01-08-2007 10:02 PM
difference between "suspend to standby" and "suspend to ram" nappaji Linux - Hardware 1 08-23-2006 08:17 PM
S3 Suspend xconspirisist Linux - Software 1 11-15-2004 03:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 08:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration