-   Debian (
-   -   NIC recognized in debian net install but not after install (

Cycle 12-22-2005 12:44 AM

NIC recognized in debian net install but not after install
Forgive me if I have overlooked the answer to this problem already, but I have looked for a while and I really need some help. I've installed Debian on two other occasions and got a fully running system with KDE, Alsa sound, etc. I just built a machine with a Asus A8N-VM CSM board, which uses the nForce 430 chipset. The stable (Sarge) net install CD does not recognize the integrated NIC, but the testing (Etch) net install CD does. After recognizing, it configures the network via DHCP just fine, and if I switch to console 2, I can wget from any web address. However, the first problem, which may in fact be the main problem, is that the net install of Etch completely freezes and stops after installing the base system and after choosing the top-level package configurations for the PC (such as Desktop, File Server, etc). If I skip this process I can finish the install and boot up into what seems to be a working base debian system, but the integrated NIC is not recognized. I really need to figure out why everything stops after choosing the top-level package configurations in the install, as I have a strong feeling that this is perhaps the cause of not having a fully operating system afterwards. Any thoughts? Please let me know if I can clarify anything. Has anyone else had this same problem?

farslayer 12-22-2005 07:49 AM

Have you tried installing Sarge with the 2.6 kernel ? when ytou boot from teh Netinstall CD you enter the command linux26 at the boot prompt. by default Sarge installs the 2.4 kernel and it may not contain the required module for your NIC by default, but the 2.6 Kernel might.

I typically use the Sarge Netinstal CD and the boot prompt commands of linux26 expert this way I have a single CD image I can use to install Sarge, Etch, or Sid. By invoking the expert command you get a lot of extra questions asked so you have more control over the install, one of those questions is:

What build do you wish to install ?
[ ] Sarge (Stable)
[ ] Etch (testing)
[ ] Sid (unstable)

Cycle 12-22-2005 05:40 PM

Tried Sarge with linux26 expert at boot prompt, still doesn't recognize either NIC or SATA II drive. Tried with the "official" Etch release, as well (also with extra parameters), and it also didn't recognize either. Only the most recent nightly build seems to work, but again, only during the install. After rebooting, the NIC is not recognized at all. Any other suggestions? Thanks for your help.

pentode 12-22-2005 05:50 PM

If you have a Knoppix CD, you might try booting with Knoppix and see what it comes up with for a NIC driver (and if it works).

Cycle 12-22-2005 09:14 PM

This might reveal a bit of newb-ness here, but I have an idea, I just need to figure out how to execute the plan, so to speak. My NIC is recognized during the install process when booting from the nightly build CD of Etch, and it is functioning, as in I can ping hosts and wget things. How can I find out what driver is being used for that NIC? Is it feasible for me to somehow copy that driver/module elsewhere and then modprobe it after the install?

farslayer 12-23-2005 07:35 AM


The forcedeth network driver in 2.6.11 does not recognize the on-board NIC, but the version included with the 2.6.14 kernel does. The nvnet driver included on the disk did not work immediately - since the latest forcedeth works, I haven't investigated this.
Update: There has been some instability with both the forcedeth and nvnet 0306 drivers - occasionally the NIC just stops responding. There are new nvnet 0310 drivers which I have not yet tried.


I checked with kernel network is OK (tried even network boot), USB is OK (tried with external disk USB2.0) but I didn't try sound and video.
SO maybe if you throw a cheap NIC in there to get past the install and kernel upgrad to 2.6.14-X your Network may start functioning.. Otherwise take a look at recompiling your kernel with the latest version of the forcedeth drivers.. Even with a 2.6 Kernel install on Debian you end up with 2.6.8-2

apt-get install linux-image-2.6.14

Good luck !!

Cycle 12-23-2005 10:14 AM

I went and grabbed the linux-image-2.6.14 image .deb package from Debian's site here on my windows box (and grabbed the dependencies as well), burned them onto a cd and used dpkg -i to install it on the debian box. And it worked! Booted into the updated kernel and network was up and running. I'm downloading all the standard packages for the system as we speak. Thanks immensely for your help! Much appreciated my friend!

farslayer 12-23-2005 07:52 PM

Glad to hear it worked for you :)

All times are GMT -5. The time now is 04:20 AM.