LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 05-10-2011, 06:45 PM   #1
carlosinfl
Senior Member
 
Registered: May 2004
Location: Orlando, FL
Distribution: Arch
Posts: 2,905

Rep: Reputation: 75
Thumbs down Networking Not Enable On Boot Up


I noticed that when my server boots up, it's network interface on eth0 is always down and I always must run the 'ifup eth0' command in order to get it to work for some reason. I checked my configuration and it looks legit to me...

Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
        address 192.168.0.209
        netmask 255.255.255.0
        network 192.168.0.0
        broadcast 192.168.0.255
        gateway 192.168.0.1
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 10.1.1.6 10.1.1.7
        dns-search iamghost.org
Anyone know why my system is booting with out bringing up my eth0 interface?
 
Old 05-10-2011, 07:06 PM   #2
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, Ubuntu, SLES, CentOS, Red Hat
Posts: 2,025

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
@ Reply

I think

auto eth0 is missing before

iface eth0 inet static
address 192.168.0.209
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 10.1.1.6 10.1.1.7
dns-search iamghost.org

Should look like this:

auto eth0
iface eth0 inet static
address 192.168.0.209
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 10.1.1.6 10.1.1.7
dns-search iamghost.org

Last edited by T3RM1NVT0R; 05-10-2011 at 07:55 PM.
 
1 members found this post helpful.
Old 05-11-2011, 02:08 AM   #3
jim_p
Member
 
Registered: Aug 2009
Distribution: Debian testing
Posts: 506

Rep: Reputation: 118Reputation: 118
Indeed, you are missing the "auto eth0" part as stated above.
 
1 members found this post helpful.
Old 05-11-2011, 09:37 AM   #4
carlosinfl
Senior Member
 
Registered: May 2004
Location: Orlando, FL
Distribution: Arch
Posts: 2,905

Original Poster
Rep: Reputation: 75
Thanks and appreciate the answer. Helpful!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cant able to enable wireless networking in my laptop mrprassad Linux - Wireless Networking 3 05-30-2011 04:04 AM
How to setup IP and enable networking in Delilinux? Nukem Linux - Networking 2 03-19-2004 12:17 PM
Enable networking after reboot SmartNET Linux - Networking 3 01-19-2004 12:51 AM


All times are GMT -5. The time now is 09:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration