LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   netinstall dpkg problem (https://www.linuxquestions.org/questions/debian-26/netinstall-dpkg-problem-322852/)

flying-tuxman 05-12-2005 03:34 PM

netinstall dpkg problem
 
hi,
I just did a netinstall of debian sarge on my pc.
after the install I tried to apt-get install some packages but, rather than install, they get stored on /var/cache/apt/archives.
I tried dpkg in order to install the packages from that dir but it complains about:

dpkg parse error in file /var/lib/dpkg/status near line 1558 package 'mdetect' missing version

I opened the status file with nano and at the line just appears mdetect without any version number, just as any other package listed there.
also i tried dselect-upgrade and it gives the same error message as above.
is this a known bug and is there a way to fix it cos, the way it is, i cant seem to be able to apt-get install anything.

tibob 05-12-2005 04:31 PM

Hi,

Can you publish your /etc/apt/sources.list file here ?
Can you try other sources, like:
deb http://ftp.debian.org/debian/ sarge main contrib non-free

Have you tried apt-get update before doing apt-get install ?

Cheers,

tibob

flying-tuxman 05-12-2005 04:54 PM

hi,
I dont think the problems is with the sources, as the download part of the precess happens normally.
the packages all apperas in the /var/cache/apt/archives directory.
the problem arises when te install part of the procees begins.
then dpkg complain about the error mentioned above.

tibob 05-12-2005 05:37 PM

You're right, the status file seems to be corrupt. Have a look at http://lists.debian.org/debian-user/.../msg14958.html where the same problem is explained.

Good luck,

tibob

flying-tuxman 05-12-2005 08:03 PM

thanks for the tip.
I'll try the solution suggested in the link and post again to let everyone know how/if it worked


All times are GMT -5. The time now is 07:14 AM.