LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 04-23-2010, 03:09 PM   #1
ppcthug
Member
 
Registered: Jan 2005
Location: california
Posts: 35

Rep: Reputation: 22
need 8bpp for game but 8bit gnome is too dark to see


I'm running amd64 squeeze. I recently installed a game through wine that requires 8 bit color mode. when gnome desktop runs normally (24bit) it looks fine but when I stop gdm and startx -- -depth 8 the desktop, menu's and everything appears so dark(brownish) that I have to be two inches from the screen to to make anything out.
I've searched google and here for gnome color palette but I can't find anything remotely similar to my problem. I'm not even sure if its a problem with gnome, x or the video card.
I'm running a radeon x600, and the xorg.conf (that I had to generate with xorg -configure) mentions the radeon driver and rv380 radeon x600 pcie
since I haven't installed the ati drivers I'm assuming its using the debian package one.
 
Old 04-23-2010, 04:25 PM   #2
10110111
Member
 
Registered: Jun 2008
Location: St.-Petersburg, Russia
Distribution: (B)LFS, Ubuntu, SliTaz
Posts: 402

Rep: Reputation: 51
You can create a script to start the game, save it to some place like /path/to/start_your_game.sh, then you will be able to start this game from 24bit GNOME environment with this command:
Code:
startx -- -depth 8 :1 /path/to/start_your_game.sh
This will start a new instance of X server with DISPLAY=:1.0 & depth 8bpp. Then you will be able to switch back to GNOME using Ctrl+Alt+F7, and then again to the game via Ctrl+Alt+F8.

P.S. This is the theory, reality depends on the driver bugs.
P.P.S. You will likely get an authorization error, so you'll have to edit a config file. If you get it, look here:
http://www.linuxquestions.org/questi...borting-512864

Last edited by 10110111; 04-23-2010 at 04:30 PM.
 
Old 04-24-2010, 09:02 PM   #3
ppcthug
Member
 
Registered: Jan 2005
Location: california
Posts: 35

Original Poster
Rep: Reputation: 22
thanks for responding.
I made a script that starts the game, but when I run startx -- -depth 8 :1 /home/me/script/gamescript.sh
I get a fatal error: unrecognized option: /home/me/script/gamescript.sh
probably my fault, I'm still getting used to the command line
I can start the game up in 8bit mode using my original method but it looks the same as the desktop, probably because its a game that runs in windowed mode by nature.
 
Old 04-25-2010, 07:02 AM   #4
10110111
Member
 
Registered: Jun 2008
Location: St.-Petersburg, Russia
Distribution: (B)LFS, Ubuntu, SliTaz
Posts: 402

Rep: Reputation: 51
Ah, my fault. Change it to this:
Code:
startx /home/me/script/gamescript.sh -- -depth 8 :1
options which go after -- are server options while path to executable is an option to startx.
 
Old 04-26-2010, 03:36 PM   #5
ppcthug
Member
 
Registered: Jan 2005
Location: california
Posts: 35

Original Poster
Rep: Reputation: 22
ok using that command I get a blank screen, when I go back to the original desktop with ctrl+alt+f7 I find this in the terminal
Code:
X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux CompName 2.6.32-trunk-amd64 #1 SMP Sun Jan 1
0 22:40:40 UTC 2010 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-trunk-amd64 root=UUID=90e09
665-4700-4fa0-ba71-7912963a44bd ro quiet
Build Date: 05 April 2010 02:21:15PM
xorg-server 2:1.7.6-2 (Timo Aaltonen <tjaalton@ubuntu.com>)
Current version of pixman: 0.16.4
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) uknown.
(==) Log File: "/var/log/Xorg.l.log", Time: Sun Apr 25 12:05:10 2010
(==) Using config file: "/etc/X11/xorg.conf"
NTSC PAL
 XRANDR name: VGA-0 
 Connector: VGA
 CRT1: INTERNAL_DAC1
 DDC reg: 0x60
 XRANDR name: DVI-I
 CRT2: INTERNAL_DAC2
 DFP1: INTERNAL_TMDS1
 DDC reg: 0x64
 XRANDR name: S-video
 Connector: S-video
 TV1: INTERNAL_DAC2
 DDC reg: 0x0
finished output detect: 0 
Unhandled monitor type 0
finished output detect: 1
finished output detect: 2
finished all detect
before xf86InitialConfiguration
Unhandled monitor type 0
after xf86InitialConfiguration
Entering TV Save
save TV timing tables
saveTimingTables: reading timing tables
TV Save done
disable primary dac
(EE) RADEON(0): Value for Option "DepthBits" must be 16 or 24
(EE) RADEON(0): [dri] RADEONInitVisualConfigs failed (depth 8 not supported). 

Disabling DRI.
disable primary dac
disable TV
disable primary dac
init memmap
init common
init crtc1
init pll1
freq: 108000000
best_freq: 108000000
best_feedback_div: 16
best_ref_div: 2
best_post_div: 2
restore memmap
restore common
restore crtc1
restore pll1
finished PLL1
set RMX
set primary dac
enable primary dac
disable TV
SELinux: Disabled on system, not enabling in x server
disable primary dac
disable primary dac
enable primary dac
disable primary dac
finished PLL2
finished PLL1
Entering Restore TV
Restore TV PLL
Restore TVHV
Restore TV Restarts
Restore Timing Tables
Reestore TV standard
Leaving Restore TV
wine: /home/user/.wine is not owned by you

waiting for X server to shut down error setting MTRR (base = 0xf0000000, size = 

0x08000000, type = 1) Inappropriate ioctl for device (25)
I'm guessing the following two lines are the important ones
(EE) RADEON(0): Value for Option "DepthBits" must be 16 or 24
(EE) RADEON(0): [dri] RADEONInitVisualConfigs failed (depth 8 not supported).
 
Old 04-27-2010, 11:08 AM   #6
10110111
Member
 
Registered: Jun 2008
Location: St.-Petersburg, Russia
Distribution: (B)LFS, Ubuntu, SliTaz
Posts: 402

Rep: Reputation: 51
Yes, this means you aren't gonna get any acceleration with 8 bpp on your video card (unless you install fglrx drivers, but i can't say if they support 8 bit though). If your game doen't need any 3D acceleration, try using vesa driver instead of radeon (set it up in xorg.conf).

BTW, why do you think your game requires 8bpp? Maybe wine can emulate it successfully.

Also, have a look at this (xinit way is the way you have already tried):
http://wiki.winehq.org/256ColorMode?...orsWorkarounds

Last edited by 10110111; 04-27-2010 at 11:14 AM.
 
Old 04-27-2010, 07:03 PM   #7
ppcthug
Member
 
Registered: Jan 2005
Location: california
Posts: 35

Original Poster
Rep: Reputation: 22
when I start the game up in 24 bit mode a window pops up that says "GFXCDSurface::create: Failed to create a surface"
according to the wine page for that game the way to get around it was to configure x to run in 8 bit mode.
I tried vesa drivers but any 8bit screen I start just comes up black and crashes after a few minutes.

that 256 color mode wine page is interesting, wish I'd found it before.
xephyr seems to work alrigt, the game gets past the "failed to create a surface" error but locks up. I guess I should take that up on the wine forums
thank you for your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how can i install / create a really dark theme in gnome - compiz? nass Fedora 2 10-20-2008 03:25 PM
dark gnome theme screws firefox up Marks256 Linux - Software 2 01-05-2008 05:22 PM
firefox colors - buttons, text fields, etc & dark gnome theme wet Linux - Newbie 3 12-09-2007 01:32 PM
Dark themes not working in Gnome-2.20 corbis_demon Linux - Desktop 0 11-26-2007 03:44 AM
killall esd before game. run esd after game. missing gnome sounds. fakie_flip Linux - Games 3 09-30-2006 03:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 06:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration