LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 05-21-2005, 10:46 PM   #1
kinji5
LQ Newbie
 
Registered: Apr 2005
Posts: 14

Rep: Reputation: Disabled
mplayer working -- gmplayer not working.


Ok folks, I am back for more help.

Running sarge 2.6.8, with gnome.
PIV 2.4GHz
512MB
ATI Radeon 7000/VE with dual VGA

I installed mplayer from http://people.debian.org/~mjr/mplayer.html
it is the most current version as well.

here is the /etc/mplayer/mplayer.conf

Code:
### mplayer DEBCONF AREA. DO NOT EDIT THIS AREA OR INSERT TEXT BEFORE IT.
#video output driver
vo=vesa:xvidix:radeon_vid.so
#device for dvd
dvd-device=/dev/cdrom
#truetype font
font=/usr/share/fonts/truetype/ttf-bitstream-vera/VeraMoBd.ttf

### END OF DEBCONF AREA.  PLACE YOUR EDITS BELOW; THEY WILL BE PRESERVED.
from command line i can type
Code:
mplayer /home/kinji/Desktop/xxx.avi
It works fine it will play but if i try the gmplayer gui it wont open the same xxx.avi file saying "Error opening/initializing the selected video_out(-vo) device."

Any suggestions?

thanks
 
Old 05-22-2005, 12:41 AM   #2
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
You'll have to edit gmplayer's options from inside the GUI. In other words, run gmplayer, then (in the Blue skin) click the spanner icon (or right click on the controller or window and select "preferences"). Click on the "video" tab and change the settings appropriately.
 
Old 05-22-2005, 01:53 AM   #3
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
there is also a gui.conf file... you may want to check it and maybe change the -vo device to what mplayer is using. my gui.conf is here:
~/.mplayer/gui.conf

since your using the mplayer.conf file in /etc you may want to look for it there...

KC
 
Old 05-22-2005, 11:06 AM   #4
kinji5
LQ Newbie
 
Registered: Apr 2005
Posts: 14

Original Poster
Rep: Reputation: Disabled
Thanks for the reply guys,

I tried both,

In gmplayer, i went to preference, i clicked on "xvidix" but i can not click on "configure driver".

Then i tried editing "gui.conf" file

I found "gui.conf" located in
Code:
/home/"user_name"/.mplayer/
it shows the "vo_driver="xvidix"
I tried chaning it to match my "mplayer.conf" but when i tried playing a file it gave me the same error.

Code:
enable_audio_equ = "no"
vo_driver = "xvidix"
vo_panscan = "0.000000"
vo_doublebuffering = "yes"
vo_direct_render = "yes"
v_framedrop = "0"
v_flip = "-1"
v_ni = "no"
v_idx = "-1"
vf_pp = "no"
vf_autoq = "0"
vf_lavc = "no"
ao_driver = "mpegpes"
ao_volnorm = "no"
softvol = "no"
ao_surround = "no"
ao_extra_stereo = "no"
ao_extra_stereo_coefficient = "1.000000"
dvd_device = "/dev/cdrom"
cdrom_device = "/dev/cdrom"
osd_level = "1"
sub_auto_load = "yes"
sub_unicode = "no"
sub_pos = "100"
sub_overlap = "no"
font_factor = "0.750000"
font_name = "/usr/share/fonts/truetype/ttf-bitstream-vera/VeraMoBd.ttf"
font_text_scale = "5.000000"
font_osd_scale = "6.000000"
font_blur = "2.000000"
font_outline = "2.000000"
font_autoscale = "3"
cache = "no"
cache_size = "2048"
playbar = "no"
load_fullscreen = "no"
show_videowin = "yes"
stopxscreensaver = "no"
autosync = "no"
autosync_size = "0"
gui_skin = "default"
gui_save_pos = "yes"
gui_main_pos_x = "445"
gui_main_pos_y = "669"
gui_video_out_pos_x = "345"
gui_video_out_pos_y = "351"
equ_band_00 = "0.000000"
equ_band_01 = "0.000000"
equ_band_02 = "0.000000"
Thanks for everyones help.
 
Old 05-23-2005, 06:25 AM   #5
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,249

Rep: Reputation: 101Reputation: 101
Try setting gmplayer to use the xv driver. Open mplayer, right click on window, select preferences and change the video driver to xv. It generally works for me.
 
Old 05-23-2005, 08:15 AM   #6
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Can you post the actual error? Also, post the (textual) output of mplayer.
 
Old 06-04-2005, 06:41 PM   #7
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Rep: Reputation: 45
Just had the same problem after a fresh install (FC3)... i went into preferences and changed to the X11 drivers, works fine now (the Opengl ones were like running in slo mo for me)
 
Old 06-06-2005, 08:04 AM   #8
kinji5
LQ Newbie
 
Registered: Apr 2005
Posts: 14

Original Poster
Rep: Reputation: Disabled
Hello Everyone,

Thanks for the post, I didnt get a chance to play with the linux box for a while.. been too busy. I am goign to wait for Debian Sarge main release before i reinstall everything and try to configure it..

I tried goign into preferences and change drivers, but i dont know if it actually applied. When i click onthe driver it seems to default back to the original, which is X11.. i believe. Again once, i am back on the box i will post the errors.

I found out there was another problem wiht my bux, i don't think it is related because i can play vide using command line..

but my Ati Radeon 7000/ve doest seem to run EnemyTerritory. I tried following instructions on how to install firegl drivers, but that didnt seem to work. Also I dont know why i need to install Firegl.. because it is Radeon chipset... but I found an article on-line saying to use them...

anyone know ?

thanks
 
Old 06-26-2005, 09:33 AM   #9
roland_mai
LQ Newbie
 
Registered: Jan 2005
Posts: 3

Rep: Reputation: 0
i had the same trouble with ubuntu. however, i fixed the problem as follows.

to make mplayer work:
vi ~/.mplayer/config

and enter (other stuff might give you problems)

vo = vx


to make gmplayer work:
vi ~/.mplayer/gui.conf

change vo_driver to:

vo_driver = "xv"


If you still have problems. Go to: System->Preferences->Multimedia System Selector
and change Output to X11/XShm/Xv. Make sure to test it. If it doesn't work, try any of the others with xv in the string.

hope this works..
 
Old 06-26-2005, 08:28 PM   #10
kinji5
LQ Newbie
 
Registered: Apr 2005
Posts: 14

Original Poster
Rep: Reputation: Disabled
Thanks I will give it try and post the results.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mplayer not working sripathi_venky Linux - Software 3 11-25-2005 01:30 AM
How do I get Mplayer Working? thorney Linux - Newbie 15 07-18-2005 12:55 AM
mplayer not working gobi_dgm Linux - Software 15 03-14-2005 07:48 PM
mplayer not working einstien Linux - Software 4 02-20-2005 03:56 PM
mplayer is working! shanenin Linux - Software 5 09-28-2003 04:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 08:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration