-   Debian (
-   -   Mouse problems.. very annoying (

xanas3712 05-11-2004 02:06 AM

Mouse problems.. very annoying
I downloaded debian woody as some have suggested in the past and am doing an apt-get upgrade.. but one of the pains I"m having in this process.. which has a few minutes more to completion (I'm upgrading to testing aka sarge first and then to sid perhaps depending on what all works in sarge)..

Anyhow.. during this upgrade.. I'm having some major issues with my mouse. If anyone else has posted this sorry as I can't mouse around much because of the way it is..

Basically everytime I move the mouse it will sometimes click when it should not. I have tried both the explorer and imps/2 settings for the mouse. Funny thing is the first time I booted debian after install I had configured lilo wrong so it was booting with the 2.6.5 kernel. When that happened it actually came up correctly, the problem is that the 2.6.5 kernel (what I'm using in slackware) for some reason disabled networking otherwise I would have stuck with it as it has support for all my hardware built in.

Anyhow.. I'm hoping these problems will be fixed when apt-get is done but I'm curious if they are not what could be going on? If all else fails I'll just configure it as a ps2. Has anyone else experienced problems with an intellimouse explorer in debian woody?

Oh.. something else.. when I installed it set the system up as ext 2 filesytem.. there was no option or anything to format as ext3.. I am asking a newbie question I'm sure but is there a way to convert or what? Or was there something I missed in installation that would have allowed me to use ext 3 instead?

Thanks for any and all help.. and sorry if this is a repeat posting as I can't get around every well with the mouse like this yet..

twolf 05-11-2004 02:15 AM

I had some problems updating too. But then I went back to "XF86Config-4" file and looked under input devices - deleted the classical mouse with "/dev/mouse" and configured my "mini-din" mouse to "/dev/psaux".
After restart it works... Unless I unplug and plug the mouse back in... Then it acts weird.

You can also run "xf86config" to go through the whole "X" setup routine, where one of the options is your pointing device and what driver (device) it should use.

I hope that helps and good luck...


xanas3712 05-11-2004 04:16 AM

well I edited the file and took out the extra.. and that didn't help.. but anyway seems to be fine now that I've updated.. now I can't get sound working yet.. says "permission denied" I never figured out how to solve that exactly in slack excpet that when I installed mandrake using the same homefolder it fixed it for me.. but I am using the same home folder here now (after the install of kde).. and yet.. it didn't fix so *shrug**..

Wandering_Dru 05-11-2004 12:02 PM


Originally posted by xanas3712
now I can't get sound working yet.. says "permission denied" I never figured out how to solve that exactly
You need to be a member of the audio group.

As root, do the following on the command line:

# adduser <your_username> audio
You should be golden once you log out and back in again.

All times are GMT -5. The time now is 05:37 PM.