LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 01-26-2005, 11:29 AM   #1
ruh31
Member
 
Registered: Oct 2004
Location: Germany
Distribution: Ubuntu
Posts: 51

Rep: Reputation: 15
mounting vfat-partition rw for all users


Hi,

I finally switched from SuSE 9.1 to Debian Sarge on my laptop. Almost everything works fine, except of a few issues.

I am using thunderbird as a mail client, since - among other reasons - I can use it under windows and linux, and still use the same data. I stored all my mail data on a fat32-partition, which I can access from windows, of course, and which I used to be able to access from SuSe, too. Now I wanted to mount it in Debian, but somehow it does not work the way I want it to work.

As root, I first set up a directory /windows/d and then did a "chmod 777 /windows/d". Then I added the following lines to /etc/fstab:

Code:
/dev/hda2   /windows/d  vfat  defaults  0  0
... and did a reboot. I loged in as a normal user (kde) and tried to checked, whether the mounting worked. When I try to "cd" to /windows/d, unfortunatelly it tells me:

Code:
bash: cd: d: no authorization
Then I tried to umount and mount it again, but then it says:

Code:
umount: only root can unmount /dev/hda2 from /windows/d
When I switch to root again, it is no problem to "cd" to it, to mount or unmount it, but afterwards as a normal user, nothing works anymore.

Can anyone please help me to set things up properly? Thanks very much,

ruh31
 
Old 01-26-2005, 11:40 AM   #2
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
Try to add the options umask=000 and users to the fstab line, separated from defaults by commas:
Code:
/dev/hda2   /windows/d  vfat  defaults,users,umask=000  0  0
'umask' translates DOS into unix permissions and 'users' allows all users to mount and unmount.
 
Old 01-27-2005, 04:23 AM   #3
ruh31
Member
 
Registered: Oct 2004
Location: Germany
Distribution: Ubuntu
Posts: 51

Original Poster
Rep: Reputation: 15
Thanks, that worked fine.

You said that umask converts DOS permissions in unix permissions. I thought DOS did not have any permissions like unix?
 
Old 01-27-2005, 05:01 AM   #4
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
Quote:
Originally posted by ruh31
You said that umask converts DOS permissions in unix permissions. I thought DOS did not have any permissions like unix?
OK, it's FAT32, but that doesn't know permissions either (AKAIK). That's why you have to tell Linux how to treat the files.
 
Old 01-27-2005, 05:27 AM   #5
ruh31
Member
 
Registered: Oct 2004
Location: Germany
Distribution: Ubuntu
Posts: 51

Original Poster
Rep: Reputation: 15
Okay, thanks again!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting vfat partition in fc3 reksav Linux - Newbie 1 04-12-2005 01:19 AM
Need help mounting a VFat partition r/w frandres Linux - Newbie 7 01-17-2005 08:31 AM
Non Super Users can not access VFAT Partition shane25119 Linux - General 7 09-11-2004 11:25 AM
Mounting extended vfat partition shaggz Linux - General 15 05-26-2003 07:33 AM
Problem mounting vfat partition!!! yalanop Linux - Newbie 1 02-02-2003 04:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 08:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration