LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Mounting NTFS partitions with write access (https://www.linuxquestions.org/questions/debian-26/mounting-ntfs-partitions-with-write-access-304136/)

Tinky1901 03-21-2005 12:19 AM

Mounting NTFS partitions with write access
 
I've read through other threads and sites on how to mount ntfs with write permissions, I used to be able to do it in slackware but for some reason I can't get write permissions for my ntfs drives. Even root can't access write permissions. Please help

proc /proc proc defaults 0 0
/dev/hdb5 / ext3 defaults,errors=remount-ro 0 1
/dev/hdb6 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/hdd /media/cdrom1 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
/dev/hda1 /mnt/files ntfs rw,uid=1000,user 0 0
/dev/hdb1 /mnt/win ntfs rw,uid=1000,user 0 0

f1dave 03-21-2005 01:03 AM

bad idea. BAD BAD idea.

DO NOT mount your NTFS partitions as writable. The last time I checked, (which admittedly was a little while ago) this put your NTFS partition in grave danger and the results aren't particularly healthy. Trust me, there's 20.0G of a useless HDD sitting around my house as testament to that. A better idea is to try and format some part of your drive with FAT, and use that to share data eg (completely legal) music and stuff between windows and linux.

southsibling 03-21-2005 01:59 AM

Can I jump in here...?
 
I've got a follow up question, regarding NTFS vs. FAT file system. To wit:

All of my CD's are loaded into an NTFS file, which I use exclusively (because up to now I have only used exclusively) a Windows XP OS. If I convert that Music partition to FAT (which will be a ho-hum effort with Partition Magic), will I then be able to access it from Linux (I believe...by mounting it on a Linux hd**)?

Thankya...

thegeekster 03-21-2005 02:42 AM

FWIW - By using the newer captive-ntfs driver, writing to a ntfs partition in Linux is much safer then the older ntfs driver.........Therefore, make sure you have the captive-ntfs driver for the kernel if you don't want to convert it to a vfat partition.................

And try these options for the windows partitions:

/dev/hda1 /mnt/files ntfs defaults,umask=000 0 0

The umask here should make it world writable, and defaults implies "rw"...

HTH :)


southsibling,
If all you want to do is listen to the music in Linux and not add more music to the partition while in Linux, then you don't need to convert it to vfat (FAT32)......You can simply mount it read-only and still be able to listen to it in Linux........... :)

syg00 03-21-2005 03:06 AM

You do *NOT* want to do this.
From the captive site;
Quote:

Mounting of NTFS devices usually works, but is no longer supported by the author of Captive.
NTFS read is fine, and FWIW I agree on the FAT32 share drive. Been doing it for years.
You have been warned - how good are your backups, and what is the data worth ???.

f1dave 03-21-2005 04:53 AM

exactly my point syg.

My music is on my windows ntfs partition, and i READ it only. xmms has no issues with that. If i try something silly like altering a song's title, it will refuse. Then, i have two older hdds that i used up until recently to share needed files between the two OSes. Eg if i need to add to a text file or something, then that was on FAT1 or FAT2.

NEVER TRUST NTFS WRITING IN LINUX- YOU HAVE BEEN WARNED (again)

Tinky1901 03-21-2005 06:57 AM

I realise I shouldn't be setting my partition to write but I need to. Heres the deal, my windows died and I installed Debian over the top of that and I need to be able to give write access so I can restructure my other hard drive appropriately. I'm not too worried about giving my user access to write to the drive but obviously I need root to be able to so I can install games and what not. Its pretty pointless having a 200 gig hard drive that I can't write to at all and not being able to format it either. (And its only got 7 gig free full of stuff that I can't delete or backup otherwise).

Tinky

thegeekster 03-21-2005 01:46 PM

If you no longer have the Windows OS installed, then why not convert to FAT32??............Then you mount the drive/partition as vfat in Linux for complete access............... :)

thegeekster 03-21-2005 02:11 PM

Sorry, I forgot to ask if the whole 200 GB drive is a single partition or broken up into smaller partitions............FAT32 partitions must be less than 32 GB.............. :rolleyes:

You can always try using the Knoppix live CD, it uses that captive-ntfs driver to allow write access to a ntfs partition, then maybe you can find some way to resize and move the data from the ntfs to several fat32 partitions. or even better, convert to a Linux partition if you no longer want to use Windows.............. :)

Tinky1901 03-21-2005 07:14 PM

Easier said then done. I need write access to a 200 gig hard drive. out of the total 186 i have 7 gig left. I do not have the ability to back up the data and I cannot loose the data. So this means I cant format, split up the drive or anything like that. I just want to give root write access to the drive and I know its possible because I've had it done in slackware before. Is there an easy solution?

Tinky

m_yates 03-21-2005 07:49 PM

The Debian kernel has ntfs write support turned off. You will need to recompile the kernel with ntfs write support turned on. It is dangerous though. Here is what the help section for ntfs write support says:
Quote:

│ If you say Y here, you will (maybe) be able to write to NTFS file │
│ systems as well as read from them. The read-write support in NTFS │
│ is far from being complete and is not well tested. If you say Y │
│ here, back up your NTFS volume first, since it will probably get │
│ damaged. Also, download the Linux-NTFS project distribution from │
│ Sourceforge at <http://linux-ntfs.sf.net/> and always run the │
│ included ntfsfix utility after writing to an NTFS partition from │
│ Linux to fix some of the damage done by the driver. You should run │
│ ntfsfix _after_ unmounting the partition in Linux but _before_ │
│ rebooting into Windows. When Windows next boots, chkdsk will be │
│ run automatically to fix the remaining damage. │
│ Please note that write support is limited to Windows NT4 and │
│ earlier versions.

f1dave 03-22-2005 04:21 AM

i just love stuff like that.

"Look, we've implemented this but back up you're stuff because it's gonna die regardless" :P

thegeekster 03-22-2005 01:35 PM

Hmmm........As for kernel support, I suppose you can use the Knoppix kernel, since the latest version (3.7) does have write support for ntfs...........Here's the repository entries to add in /etc/apt/sources.list for including Knoppix packages:
Code:

# Knoppix special packages resource at LinuxTag HQ
deb http://developer.linuxtag.net/knoppix/ ./
deb-src http://developer.linuxtag.net/knoppix/ ./

In aptitude, the kernels are called

kernel-image-2.4.27 10.Custom
kernel-image-2.6.5 10.Custom

Or you can just download the kernel package of your choice and use 'dpkg' to install it...........This might be a better way since there's a possibility of breaking something when trying to upgrade anything if the whole Knoppix repository is included in a normal Debian installation........... :)

southsibling 04-09-2005 10:22 AM

Quote:

Originally posted by thegeekster
FWIW - By using the newer captive-ntfs driver, writing to a ntfs partition in Linux is much safer then the older ntfs driver.........Therefore, make sure you have the captive-ntfs driver for the kernel if you don't want to convert it to a vfat partition.................

And try these options for the windows partitions:

/dev/hda1 /mnt/files ntfs defaults,umask=000 0 0

The umask here should make it world writable, and defaults implies "rw"...

HTH :)


southsibling,
If all you want to do is listen to the music in Linux and not add more music to the partition while in Linux, then you don't need to convert it to vfat (FAT32)......You can simply mount it read-only and still be able to listen to it in Linux........... :)

I believe this is what I want to do:

mkdir /mnt/win
mount -t ntfs /dev/hdb2 mnt/win

Am I anywhere close to success?

(hdb2 is the partition where my music CD's are located)


All times are GMT -5. The time now is 05:03 PM.