LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 11-05-2004, 10:24 AM   #1
binboy35
LQ Newbie
 
Registered: Sep 2004
Location: Canada
Distribution: Debian Sarge (kernel 2.4), Slackware 10.0
Posts: 20

Rep: Reputation: 0
mounting cdrom


I have some pdf's on a cdrom that I'd like to upload and read. However, I can't seem to mount the cdrom. I get:

mount failed. medium not found.

So I go in /etc/fstab and all my devices are listed in there and looks like it should according to the Debian User's guide. Any advice? Scratching my head.
 
Old 11-05-2004, 10:55 AM   #2
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,291

Rep: Reputation: 65
list your fstab. if you don't want to, tell us what your cdrom device is. a typical mount command is:
mount /dev/hdc /mnt/cdrom
 
Old 11-05-2004, 12:56 PM   #3
binboy35
LQ Newbie
 
Registered: Sep 2004
Location: Canada
Distribution: Debian Sarge (kernel 2.4), Slackware 10.0
Posts: 20

Original Poster
Rep: Reputation: 0
I tried that command without success. Here is fstab:


proc /proc proc defaults 0 0
dev/hd3 / reiserfs notail 0 1
/dev/hd2 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/hdd /media/cdrom1 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
 
Old 11-05-2004, 03:02 PM   #4
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
First, run (as root) the "dpkg-reconfigure discover1" command and make sure that you haven't enabled discover to manage mount points automatically. (In my experience discover handles this poorly.)

Next, run the "ls /media" command and check that you've actually got the /media/cdrom0 directory that is mentioned in your /etc/fstab. If not, create it as root (mkdir /media/cdrom0). Also run the "ls -lFG /dev | grep cdrom" [notice: the first option is NOT big i, it's small L] command and check that you've got in the /dev directory a symlink cdrom0 that points to /dev/hdc and symlink cdrom that points to /dev/cdrom0. If not, create them as root (ln -s /dev/hdc /dev/cdrom0 && ln -s /dev/cdrom0 /dev/cdrom).

Next, run (as normal user) the "id" command and check that you are a member in the cdrom group. If not, run (as root) the "adduser your_username cdrom" command. Then change to normal user and check with "id" that you've done it correctly.

Then reboot, and you should be able to mount your first cdrom drive as normal user with the "mount /media/cdrom0" command (and unmount it with "umount /media/cdrom0"). You should also be able to eject an unmounted cdrom with the "eject" command.

If nothing else seems to work, you should at least be able to mount your cdrom (as root) with the "mount -t iso9660 /dev/hdc /media/cdrom0" command (assuming that you have the /media/cdrom0 directory).

Last edited by Dead Parrot; 11-05-2004 at 03:07 PM.
 
Old 11-05-2004, 03:24 PM   #5
binboy35
LQ Newbie
 
Registered: Sep 2004
Location: Canada
Distribution: Debian Sarge (kernel 2.4), Slackware 10.0
Posts: 20

Original Poster
Rep: Reputation: 0
Thanks for the reply, I'll try it immediately. However, I just managed to succeed before logging on to linuxquestions. Here's what I did. I typed in:

mount /dev/hdd

then

cd /media/cdrom1

and that was it. I was then able to access my pdf's via both xpdf and gv programs. After I was done:

umount /dev/hdd

But I had to press my cdrom button to eject. No automatic. I am also going to try your recommendations and see how it goes. I always like to learn and try new things. Thank you again for your help.
 
Old 11-05-2004, 03:34 PM   #6
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Maybe you shouldn't fix it if it ain't broken...
 
Old 11-05-2004, 05:50 PM   #7
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,291

Rep: Reputation: 65
yeah, it's fine. don't mess with it. my command didn't work because you don't have the /mnt/cdrom directory. mount can usually guess the filesystem. you can mount according the settings in /etc/fstab by either the mountpoint or the device. in your case, mount /dev/hdd or mount /media/cdrom0 would work for that drive.
you could make a small script called whatever you wish, maybe "cdout" that contains
umount /dev/hdd
eject /dev/hdd
that would umount and eject for you

Last edited by whansard; 11-05-2004 at 05:53 PM.
 
Old 11-05-2004, 06:06 PM   #8
binboy35
LQ Newbie
 
Registered: Sep 2004
Location: Canada
Distribution: Debian Sarge (kernel 2.4), Slackware 10.0
Posts: 20

Original Poster
Rep: Reputation: 0
That's really cool. The script will kill two birds with one stone. lol. BTW, I have a dvd player that's separate from my cdrom. That's why it wouldn't detect, cause dvd=cdrom0. Works fine now with cdrom1. Thanks again folks.

 
Old 11-06-2004, 12:22 AM   #9
kurrupt
Member
 
Registered: Jul 2004
Distribution: Debian, Ubuntu, FreeBSD, RHEL
Posts: 202

Rep: Reputation: 31
to make it easier on your life in the future do this..

first as root create a file in /

so do cd /

then mkdir cdrom

now edit your fstab and add this line:


/dev/hd? /cdrom iso9660 ro,user,noauto 0 0


so then later on all u have to type in is mount /cdrom and its mounted

p.s. the ? in hd? is either a= primary master b=primary slave c=secondary master d=secondary slave

hope this may help with mounting your cds
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CDROM mounting problem => /dev/cdrom is not a valid block device Vizy Linux - Hardware 8 11-04-2010 05:46 PM
cdrom mounting simcox1 Slackware 1 09-18-2005 11:00 AM
about mounting cdrom rabside Linux - Newbie 1 04-23-2004 02:51 PM
Mounting CDRom jgnasser Linux - Newbie 14 04-01-2004 11:07 AM
mounting a cdrom PlatinumRik Linux - Networking 6 05-27-2003 10:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration