LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 07-31-2004, 03:36 PM   #1
EcceVery
Member
 
Registered: Apr 2004
Location: Sweden
Distribution: Gentoo, Debian, CentOS
Posts: 61

Rep: Reputation: 15
mounted volume can only be accessed by root


I have a logical FAT32 partition (hda5) that I want everybody to be able to use. Read, write, cerate....whatever. but, only root can access it, other users only see file-listings of what's in the root of the partition.

Here's my fstab file:

Code:
# <file system> <mount point>   <type>  <options>               <dump>  <pass>
/dev/hda1       /               ext3    errors=remount-ro       0       1
/dev/hda2       none            swap    sw                      0       0
/dev/hda5       /mnt/hda5       vfat                            0       0
proc            /proc           proc    defaults                0       0
/dev/fd0        /floppy         auto    user,noauto             0       0
/dev/cdrom      /cdrom          iso9660 ro,user,noauto          0       0
And, what is "dump" and "pass"?
 
Old 07-31-2004, 03:46 PM   #2
zero79
Member
 
Registered: Nov 2003
Location: Ohio
Distribution: Debian Unstable
Posts: 460

Rep: Reputation: 30
add the options "rw,user,umask=0755" to the <options> column for the vfat entry in /etc/fstab

Last edited by zero79; 07-31-2004 at 03:47 PM.
 
Old 08-01-2004, 08:44 AM   #3
EcceVery
Member
 
Registered: Apr 2004
Location: Sweden
Distribution: Gentoo, Debian, CentOS
Posts: 61

Original Poster
Rep: Reputation: 15
nope, permission denied...
 
Old 08-01-2004, 08:54 AM   #4
k.van.hagen
Member
 
Registered: Aug 2003
Location: Castricum, The Netherlands
Distribution: Debian
Posts: 49

Rep: Reputation: 15
Wink

Try adding the options uid=<your username>,gid=<your group name>,umask=0027
remount the volume, and try again .
 
Old 08-01-2004, 08:55 AM   #5
k.van.hagen
Member
 
Registered: Aug 2003
Location: Castricum, The Netherlands
Distribution: Debian
Posts: 49

Rep: Reputation: 15
ps. The umask option is in octal, so therefore the permissions have to be reversed: 7=0 etc.
 
Old 08-01-2004, 08:56 AM   #6
k.van.hagen
Member
 
Registered: Aug 2003
Location: Castricum, The Netherlands
Distribution: Debian
Posts: 49

Rep: Reputation: 15
This is my fstab, and works fine.

[CODE]
arrakis:~# cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
/dev/hda5 / ext3 defaults,errors=remount-ro 0 1
/dev/hda1 /boot ext3 defaults 0 2
/dev/hda9 /home ext3 defaults 0 2
/dev/hda7 /tmp ext3 defaults 0 2
/dev/hda8 /usr ext3 defaults 0 2
/dev/hda6 /var ext3 defaults 0 2
/dev/hda10 /data vfat rw,uid=1000,gid=100,umask=0007 0 0
/dev/hda2 /win ntfs ro,uid=1000,gid=100,umask=0007 0 0

/dev/hda3 none swap sw 0 0
proc /proc proc defaults 0 0

#/dev/hdb /media/dvd iso9660 ro,user,noauto 0 0
/dev/hdc /media/dvdrw iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy auto rw,user,noauto 0 0
[\CODE]
 
Old 08-01-2004, 09:31 AM   #7
EcceVery
Member
 
Registered: Apr 2004
Location: Sweden
Distribution: Gentoo, Debian, CentOS
Posts: 61

Original Poster
Rep: Reputation: 15
Just made it readable...

Code:
arrakis:~# cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
/dev/hda5 / ext3 defaults,errors=remount-ro 0 1
/dev/hda1 /boot ext3 defaults 0 2
/dev/hda9 /home ext3 defaults 0 2
/dev/hda7 /tmp ext3 defaults 0 2
/dev/hda8 /usr ext3 defaults 0 2
/dev/hda6 /var ext3 defaults 0 2
/dev/hda10 /data vfat rw,uid=1000,gid=100,umask=0007 0 0
/dev/hda2 /win ntfs ro,uid=1000,gid=100,umask=0007 0 0

/dev/hda3 none swap sw 0 0
proc /proc proc defaults 0 0

#/dev/hdb /media/dvd iso9660 ro,user,noauto 0 0
/dev/hdc /media/dvdrw iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy auto rw,user,noauto 0 0
 
Old 08-01-2004, 09:45 AM   #8
EcceVery
Member
 
Registered: Apr 2004
Location: Sweden
Distribution: Gentoo, Debian, CentOS
Posts: 61

Original Poster
Rep: Reputation: 15
yepp, works fine now. thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting CD Volume name of mounted images Darkvater Linux - Software 3 03-16-2005 12:58 PM
Webserver can only be accessed from network until SSH'd into as root Davus Linux - Software 1 08-04-2004 03:58 PM
mounted hard drive can only be accessed by root Flutterby Linux - Hardware 3 07-17-2004 04:52 AM
Volume labels in Debian cause everything to be mounted read-only? racoontje Debian 0 07-09-2004 04:40 PM
Slack 9: mounted FAT32 partitions cannot be accessed by normal user Obi-Wan_Kenobi Slackware 6 07-13-2003 12:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 05:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration