LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-15-2017, 12:29 PM   #1
pedropt
Member
 
Registered: Aug 2014
Distribution: Devuan
Posts: 200

Rep: Reputation: Disabled
Mount Volumes ignoring fstab


I saw a similar issue in here , but it was not related to my issue , i i created this thread .

Sometimes the little things are the ones that give more trouble to solve .

My linux is not mounting all volumes in fstab , however i can mount them manually by hand on terminal .
Also , i believe that swap that should not be accessible of file browser , is popping up there .

So , here it is my fstab

Quote:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sdc5 during installation
UUID=4735a80a-fb87-489f-927a-45666dbcc96e / ext4 errors=remount-ro 0 1
# swap was on /dev/sdc6 during installation
UUID=d2fa17a4-afca-4bac-8c55-dc25365692bd none swap sw 0 0
/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/sda1 /media/XP auto rw,user,noauto 0 0
/dev/sdb5 /media/F auto rw,user,noauto 0 0
/dev/sdb1 /media/W7 auto rw,user,noauto 0 0
/dev/sdc1 /media/I auto rw,user,noauto 0 0
/dev/sdd1 /media/J auto rw,user,noauto 0 0
Here it is my file explorer opened :
https://s18.postimg.org/ul73yg9e1/filebrowser.png

as you all can see , i have folders that should not appear in file browser on the left side , like : pts , proc , binfmt_misc , etc...

Code:
mount -a
is not mounting that fstab file , but if i mount individually it works .

https://s28.postimg.org/71uq1cq4d/mount.png

Anyone have an idea how to solve this , or where is the problem ?
 
Old 08-15-2017, 12:39 PM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 10,056

Rep: Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104Reputation: 1104
Your system seems to be behaving as you set it up.

If you want all the drives to mount, remove every 'noauto' option in sight. That prevents mount -a from mounting them.
 
Old 08-15-2017, 01:57 PM   #3
pedropt
Member
 
Registered: Aug 2014
Distribution: Devuan
Posts: 200

Original Poster
Rep: Reputation: Disabled
Like i told , the things more easy to solve are the most complicated .
I looked at fstab file more than 20 times , i missed the "noauto" instead "auto" .
I have to test it out , but that is probably the case .
 
Old 08-15-2017, 02:32 PM   #4
pedropt
Member
 
Registered: Aug 2014
Distribution: Devuan
Posts: 200

Original Poster
Rep: Reputation: Disabled
Well , in fact that was one of the problems that was solved , however i had to make some changes so o could access those drives :

Quote:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sdc5 during installation
UUID=4735a80a-fb87-489f-927a-45666dbcc96e / ext4 errors=remount-ro 0 1
# swap was on /dev/sdc6 during installation
#UUID=d2fa17a4-afca-4bac-8c55-dc25365692bd none swap sw 0 0
/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/sda1 /media/XP auto defaults 0 2
/dev/sdb5 /media/F auto defaults 0 2
/dev/sdb1 /media/W7 auto defaults 0 2
/dev/sdc1 /media/I auto defaults 0 2
/dev/sdd1 /media/J auto defaults 0 2
But the most interesting thing is that i can access those drives on some file browsers , but not in all .
Dolphin file browser does not show the volumes mounted like it is on next image .
Thunar on the left and dolphin on the right

https://s22.postimg.org/ysqg2e7rl/desktop.png

Last edited by pedropt; 08-15-2017 at 03:22 PM.
 
Old 08-16-2017, 07:45 AM   #5
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,622

Rep: Reputation: 105Reputation: 105
Quote:
Originally Posted by pedropt View Post
Well , in fact that was one of the problems that was solved , however i had to make some changes so o could access those drives :



But the most interesting thing is that i can access those drives on some file browsers , but not in all .
Dolphin file browser does not show the volumes mounted like it is on next image .
Thunar on the left and dolphin on the right

https://s22.postimg.org/ysqg2e7rl/desktop.png
Try using ls -l /dev/disk/by-uuid or blkid /dev/sd?? to get the proper UUID for each partition putting that in the fstab and see if that helps.
 
Old 08-16-2017, 05:21 PM   #6
pedropt
Member
 
Registered: Aug 2014
Distribution: Devuan
Posts: 200

Original Poster
Rep: Reputation: Disabled
Well , i was able to fix it manually .
I had to set each partition filesystem manually on fstab
install ntfs-3g .
Now the volumes are mounted at boot , but dolphin was not showing them .
To solve dolphin issue i added new entrys to dolphin pointing out to where those drives are mounted .

https://s17.postimg.org/yekr4u5y7/golphinok.png

By default i never had to do this , because normally file browsers go check to media folder and checkout if there are any volumes mounted automatically and add them directly , but in my case i had to do it manually to solve this issue .

My new fstab config :

Quote:
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>

#Entry for /dev/sdc5 :
UUID=4735a80a-fb87-489f-927a-45666dbcc96e / ext4 errors=remount-ro 0 1
#Entry for /dev/sdb5 :
UUID=01CC65C911FFCB30 /media/F ntfs-3g defaults,locale=en_US.UTF-8 0 0
#Entry for /dev/sdc1 :
UUID=2AC0D377C0D34829 /media/I ntfs-3g defaults,locale=en_US.UTF-8 0 0
#Entry for /dev/sdd1 :
UUID=3CC4F50FC4F4CBE0 /media/J ntfs-3g defaults,locale=en_US.UTF-8 0 0
#Entry for /dev/sdb1 :
UUID=58749E4B749E2BAE /media/W7 ntfs-3g defaults,locale=en_US.UTF-8 0 0
#Entry for /dev/sda1 :
UUID=E6305DB3305D8C05 /media/XP ntfs-3g defaults,locale=en_US.UTF-8 0 0
#Entry for /dev/sda2 :
UUID=111EBF7B296B0631 /media/sda2 ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/sr0 /media/cdrom0 auto user,noauto 0 0

#UUID=d2fa17a4-afca-4bac-8c55-dc25365692bd none swap sw 0 0

Last edited by pedropt; 08-16-2017 at 05:24 PM.
 
Old 08-17-2017, 12:31 AM   #7
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 11,450
Blog Entries: 8

Rep: Reputation: 2990Reputation: 2990Reputation: 2990Reputation: 2990Reputation: 2990Reputation: 2990Reputation: 2990Reputation: 2990Reputation: 2990Reputation: 2990Reputation: 2990
Quote:
Originally Posted by pedropt View Post
Now the volumes are mounted at boot , but dolphin was not showing them .
try adding "comment=x-gvfs-show" to the fstab options.
example:
Code:
UUID=58749E4B749E2BAE	/media/W7	ntfs-3g	defaults,locale=en_US.UTF-8,comment=x-gvfs-show	0 0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounts ignoring /etc/fstab Tadaen Debian 3 05-11-2014 11:07 AM
questions on df, fstab and mounting volumes rsleventhal Linux - Server 1 04-05-2008 06:31 AM
mount refusing to mount lvm volumes linuxmandrake Fedora 2 07-20-2005 06:06 PM
boot ignoring my fstab? Feminista Slackware 1 02-11-2005 12:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 07:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration