LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   More library problems (https://www.linuxquestions.org/questions/debian-26/more-library-problems-167388/)

Outabux 04-07-2004 03:08 PM

More library problems
 
Trying to get xine-ui up and running encountered errors and installation woooos with apt-get and assorted plugins:

trying to install libxine0_0.9.8-2_i386.deb from Debian Stable into Sid / unstable as the package is not there in unstable...

here's the scoop:

i8250d:~# dpkg -i libxine0_0.9.8-2_i386.deb
Selecting previously deselected package libxine0.
(Reading database ... 67031 files and directories currently installed.)
Unpacking libxine0 (from libxine0_0.9.8-2_i386.deb) ...
dpkg: dependency problems prevent configuration of libxine0:
libxine0 depends on libvorbis0 (>= 1.0rc3-1); however:
Package libvorbis0 is not installed.
dpkg: error processing libxine0 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libxine0
i8250d:~# apt-get install libvorbis0
Reading Package Lists... Done
Building Dependency Tree... Done
Package libvorbis0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
libvorbisfile3 libvorbisenc2 libvorbis0a
E: Package libvorbis0 has no installation candidate
i8250d:~# apt-get install libvorbisfile3 libvorbisenc2 libvorbis0a
Reading Package Lists... Done
Building Dependency Tree... Done
libvorbisfile3 is already the newest version.
libvorbisenc2 is already the newest version.
libvorbis0a is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
libxine0: Depends: libvorbis0 (>= 1.0rc3-1) but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


SHOULD I DOWNGRADE BY GRABBING ALL PACKAGES AND PLUGINS FOR XINE (XINE-UI) AFTER APT-GET REMOVE XINE-UI AND REINSTALL USING THE OLDER PACKAGES THAT I SUPPOSE ARE FOUND IN STABLE or TESTING?

OR IS THERE A WORK AROUND OR A WAY TO INSTALL libxine0 by some sort of force switch that I have been very much unable to decipher?

trying to install d5d-plugin d4d-plugin that require libxine0, but as above chronicles; i cannot with the apt-get and modified sources list as we got a circular arrangement in dependencies.

I kinda believe forcing libxine0 to install will fix the problem with the dependencies...however, I dunno! Still a newbie on cuttin' edge of debian and wanting stuff to work.

PLEASE HELP!:newbie: :cry: :scratch:

Thanking yall in advance. Outabux and OutaIdeas

sims 04-07-2004 05:03 PM

xine-ui exists in unstable... the lib you need is libxine1.
http://packages.debian.org/unstable/graphics/xine-ui

Outabux 04-07-2004 07:34 PM

Got that already, but thanx, need more help
 
Already know that xine-ui, including libxine1, exists in unstable: thats how I got it: through apt-get. However, i cannot add any of the plugins I desire. They do not exist in unstable or anywhere else in the debian distro I believe.

I believe that i can download all the necessary debs (the stable branch) and use dpkg -i 'all those files' along with the plugin debs after apt-get removing xine-ui.

But im curious, will and apt-get upgrade screw all that up?

Is there a simple way just to force the plugins as my first post in the thread suggests that everything is up to date except for that name change to libxine1 from libxine0.

I would think the compatability is still there. Just a way to keep the meek from using the d5d and d4d plugins.

:newbie: :scratch: :mad:

geekzen 04-07-2004 07:44 PM

There is such a thing called apt pinning, which allows you to use multiple releases (Unstable KDE, stable Xine, testing WINE etc.)

Here is a good info source. http://jaqque.sbih.org/kplug/apt-pinning.html

Outabux 04-07-2004 09:33 PM

will try that, looks pretty good and the answer to a bunch of questions including kde 3.2 that doesnt get menus after apt-get even though threads out there and bug reports

Great


All times are GMT -5. The time now is 07:26 AM.