-   Debian (
-   -   Modem Intel 537 driver? (

linx win 10-20-2005 08:53 AM

Modem Intel 537 driver?
Does any body know from where I can get the driver for Intel 537 modem?

I tried all the drivers in Intel site for Intel 537EP
but all failed to get my modem to work. I keep getting the following:
Intel 537 card found
This Intel(R) 537EP Modem driver won't install on Intel 537 card, please download the right driver

Emmanuel_uk 10-21-2005 06:52 AM

see for example

Search the archive there

I had a 536EP once, such a pain...

linx win 10-21-2005 09:03 AM

Thanks for reply. I downloaded intel-537- and tried to compile it but this is what I got:

knoppix@box:~/trying/intel-537-$ make 537
Module precompile check
Current running kernel is: 2.6.11-kanotix-11
/lib/modules... autoconf.h exists
diff: /boot/vmlinuz.autoconf.h: No such file or directory
autoconf.h matches running kernel
diff: /boot/vmlinuz.version.h: No such file or directory
version.h matches running kernel
make[1]: Entering directory `/home/knoppix/trying/intel-537-'
make -C /lib/modules/2.6.11-kanotix-11/build SUBDIRS=/home/knoppix/trying/intel-537- modules
make[2]: Entering directory `/usr/src/linux-2.6.11-kanotix-11'
CC [M] /home/knoppix/trying/intel-537-
/home/knoppix/trying/intel-537- warning: type defaults to `int' in declaration of `EXPORT_SYMBOL_NOVERS'
/home/knoppix/trying/intel-537- warning: parameter names (without types) in function declaration
/home/knoppix/trying/intel-537- warning: data definition has no type or storage class
/home/knoppix/trying/intel-537- In function `power_callback':
/home/knoppix/trying/intel-537- error: `PM_SAVE_STATE' undeclared (first use in this function)
/home/knoppix/trying/intel-537- error: (Each undeclared identifier is reported only once
/home/knoppix/trying/intel-537- error: for each function it appears in.)
/home/knoppix/trying/intel-537- In function `open':
/home/knoppix/trying/intel-537- warning: `pm_register' is deprecated (declared at include/linux/pm.h:106)
/home/knoppix/trying/intel-537- In function `close':
/home/knoppix/trying/intel-537- warning: `pm_unregister' is deprecated (declared at include/linux/pm.h:111)
/home/knoppix/trying/intel-537- At top level:
/home/knoppix/trying/intel-537- warning: initialization from incompatible pointer type
/home/knoppix/trying/intel-537- warning: initialization from incompatible pointer type
/home/knoppix/trying/intel-537- In function `kScheduleDPC':
/home/knoppix/trying/intel-537- warning: implicit declaration of function `pm_access'
/home/knoppix/trying/intel-537- In function `dspdrv_CommRamISR':
/home/knoppix/trying/intel-537- warning: function declaration isn't a prototype
make[3]: *** [/home/knoppix/trying/intel-537-] Error 1
make[2]: *** [_module_/home/knoppix/trying/intel-537-] Error 2
make[2]: Leaving directory `/usr/src/linux-2.6.11-kanotix-11'
make[1]: *** [537core_26] Error 2
make[1]: Leaving directory `/home/knoppix/trying/intel-537-'
Failed to build driver

Any other suggestion?

Emmanuel_uk 10-24-2005 01:24 AM

Have you got your kernel source installed?

If yes check archive to see if the driver is compatible with
the kernel version you have

If this fails you can
1) Complain to Intel (not about this driver, I mean the one you tried before)
2) Download scanmodem from and run it;
the output is quite informative and it might suggest another driver
3) failing all that, register with and ask for some
help. They are great there.
4) Post solution here

Sorry I cannot help more than that

All times are GMT -5. The time now is 03:34 PM.