LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 03-30-2009, 08:31 AM   #1
grana
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Rep: Reputation: 0
Question missing accented letters and symbols


Hi, I'm a semi-noob using Debian Etch.

I messed with the sources, and now my system, while working well in remote connections using XMing or similars, doesn't take accented letters or symbols like "{" "}" and many others, from the keyboard.

I've been told this could be a fonts problem, what seems strange to me is that if I cat some file containing those chars, those are output fine.

Can you please help me?

thanks

grana
 
Old 03-30-2009, 09:47 AM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615
Try:
Code:
dpkg-reconfigure xserver-xorg
and selecting your correct keyboard layout, then restarting X.
 
Old 04-01-2009, 06:28 AM   #3
grana
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Original Poster
Rep: Reputation: 0
thanks, but it doesn't work.

svn is printing a warning that I never saw, maybe can be related:
Code:
svn: warning: cannot set LC_CTYPE locale
svn: warning: environment variable LANG is it
svn: warning: please check that your locale name is correct
 
Old 04-01-2009, 10:15 AM   #4
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615
Try:
Code:
sudo dpkg-reconfigure locales
and generating en_US.ISO-8859-1 , en_US.utf8, and any other languages you use.
 
Old 04-03-2009, 02:54 AM   #5
grana
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Original Poster
Rep: Reputation: 0
still not working, but thanks for your advices.
another strange thing is that in the keyboard settings the preview is shown when remote connected, but not if working locally.
 
Old 04-03-2009, 06:54 AM   #6
grana
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Original Poster
Rep: Reputation: 0
I attach my Xorg.0.log: I think it may be useful though I can't understand how
Attached Files
File Type: txt Xorg.0.log.txt (64.0 KB, 5 views)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with apache and accented letters h725 Linux - Server 3 01-05-2009 03:52 AM
How to get accented letters ? PaulFXH Linux - Hardware 1 06-25-2008 12:30 PM
LKMs, missing symbols, etc. xoi Linux - General 1 06-18-2006 03:03 AM
Accented letters displayed incorrectly in amsn on Ubuntu eBopBob Linux - Newbie 1 02-04-2006 05:16 PM
accented letters in OpenOffice kermit Linux - Newbie 5 12-16-2004 08:37 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 04:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration