LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 11-17-2003, 01:37 PM   #1
scarr3d
Member
 
Registered: Oct 2003
Posts: 48

Rep: Reputation: 15
-- MARK -- : Why is this repeated in my log file?


hello,

i'm currently running Debian 3.01 on a PIII 750 server, mainly used for Samba file-sharing. i've been looking through /var/log/messages (trying to find info about the IRQ kernel panics) and I see this message repeated numerous times:

Nov 16 21:09:23 BENT00 -- MARK --

i can't find anything on google, i guess they ignore the -- characters. anyone else have any insight?

BENT00:/var/log# uname -a
Linux BENT00 2.4.18-bf2.4 #1 Son Apr 14 09:53:28 CEST 2002 i686 unknown

BENT00:/var/log# cat /etc/debian_version
3.0
 
Old 11-17-2003, 01:59 PM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395
syslogd is causing this.

From man syslogd:

-m interval
The syslogd logs a mark timestamp regularly. The default interval between two -- MARK --
lines is 20 minutes. This can be changed with this option. Setting the interval to zero
turns it off entirely.

Starting syslogd with the -m 0 option will disable this behavior (check your init scripts).
 
Old 11-17-2003, 03:53 PM   #3
scarr3d
Member
 
Registered: Oct 2003
Posts: 48

Original Poster
Rep: Reputation: 15


why didn't i RTFM? that is the real question.

i've modified all the lines in /etc/init.d/sysklogd that start with "start-stop-daemon" and added the "-m 0" switch. but it errored out. where exactly do i put this?

example:

start-stop-daemon --stop --quiet -m 0 --signal 1 --exec $binpath --pidfile $pidfile

error:

BENT00:/etc/init.d# ./sysklogd restart
Stopping system log daemon: syslogd.
Starting system log daemon: syslogdstart-stop-daemon: --make-pidfile is only relevant with --pidfile
Try `start-stop-daemon --help' for more information.
.


thanks for the help.

Last edited by scarr3d; 11-17-2003 at 04:10 PM.
 
Old 11-17-2003, 04:23 PM   #4
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395
I don't think that's the correct line.

It should be something like this (syslogd being the most important part):

startproc /sbin/syslogd <parameters>

and it's in the start and/or restart section of the script.
 
Old 11-17-2003, 09:07 PM   #5
scarr3d
Member
 
Registered: Oct 2003
Posts: 48

Original Poster
Rep: Reputation: 15
here's the script in its entirety:

#! /bin/sh
# /etc/init.d/sysklogd: start the system log daemon.

PATH=/bin:/usr/bin:/sbin:/usr/sbin

pidfile=/var/run/syslogd.pid
binpath=/sbin/syslogd

test -x $binpath || exit 0

# Options for start/restart the daemons
# For remote UDP logging use SYSLOGD="-r"
#
SYSLOGD=""

create_xconsole()
{
if [ ! -e /dev/xconsole ]; then
mknod -m 640 /dev/xconsole p
else
chmod 0640 /dev/xconsole
fi
chown root.adm /dev/xconsole
}

running()
{
# No pidfile, probably no daemon present
#
if [ ! -f $pidfile ]
then
return 1
fi

pid=`cat $pidfile`

# No pid, probably no daemon present
#
if [ -z "$pid" ]
then
return 1
fi

cmd=`cat /proc/$pid/cmdline | tr "\000" "\n"|head -1`

# No syslogd?
#
if [ "$cmd" != "$binpath" ]
then
return 1
fi
cmd=`cat /proc/$pid/cmdline | tr "\000" "\n"|head -1`

# No syslogd?
#
if [ "$cmd" != "$binpath" ]
then
return 1
fi

return 0
}

case "$1" in
start)
echo -n "Starting system log daemon: syslogd"
create_xconsole
start-stop-daemon --start --quiet --exec $binpath -- $SYSLOGD
echo "."
;;
stop)
echo -n "Stopping system log daemon: syslogd"
start-stop-daemon --stop --quiet --exec $binpath --pidfile $pidfile
echo "."
;;
reload|force-reload)
start-stop-daemon --stop --quiet --signal 1 --exec $binpath --pidfile $pidfile
;;
restart)
echo -n "Stopping system log daemon: syslogd"
start-stop-daemon --stop --quiet --exec $binpath --pidfile $pidfile
echo "."
sleep 1
echo -n "Starting system log daemon: syslogd"
start-stop-daemon --start --quiet --exec $binpath -- $SYSLOGD
echo "."
;;
reload-or-restart)
if running
then
start-stop-daemon --stop --quiet --signal 1 --exec $binpath --pidfile $pidfile
else
start-stop-daemon --start --quiet --exec $binpath -- $SYSLOGD
fi
;;
*)
echo "Usage: /etc/init.d/sysklogd {start|stop|reload|restart|force-reload|reload-or-restart}"
exit 1
esac

exit 0
 
Old 11-17-2003, 11:51 PM   #6
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395Reputation: 2395
Quote:
Originally posted by scarr3d

# Options for start/restart the daemons
# For remote UDP logging use SYSLOGD="-r"
#
SYSLOGD=""
Your script looks entrirely different then mine.

This (SYSLOGD="") is where you enter your options for syslogd in your script.

SYSLOGD="-m"

After you edited the script. Stop and then start syslogd (you can also use restart):

sh syslogd stop
sh syslogd start

or

sh syslogd restart
 
1 members found this post helpful.
Old 11-19-2003, 04:33 PM   #7
scarr3d
Member
 
Registered: Oct 2003
Posts: 48

Original Poster
Rep: Reputation: 15
cool, it worked. much thanks.

maybe the difference has something to do with mine being sys"K"logd. not sure what it is...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Repeated Log Entry: sshd: authentication failure; logname= uid=0 360 Linux - Security 1 10-07-2005 12:23 PM
Repeated crashes - here's my log message jeffreybluml Linux - Newbie 2 05-21-2004 09:19 AM
Emergency - need to manually mark a file executable davidbalt Linux - Software 3 02-24-2004 09:15 PM
How to control log file size in /var/log? yan Linux - General 2 10-13-2003 05:00 PM
iptables, changing log file from /var/log/messages acid2000 Linux - Networking 3 03-11-2003 08:38 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 02:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration