-   Debian (
-   -   lpr & lpr-cups commands not working with CUPS (

trinbellwoods 01-07-2004 04:16 PM

lpr & lpr-cups commands not working with CUPS
I have an HP Deskjet 3420 and used the hpijs driver to set it up using the CUPS web interface. I installed the driver from source, and installed the CUPS package, which I believe also installed some foomatic packages with it. The setup worked fine, and I tweaked the settings so that my test page printed out all pretty, but when I go to print out a pdf document or a webpage I am a little stumped as to what to do. But supposedly the lpr command works with cups, so I try it, and nothing happens. I also read someone's post who said that the lpr-cups command works, but that does nothing either. Is it possible that this is a permissions problem? Also, I don't *believe* that lpr needs to be installed separately...but maybe I am wrong?

Thanks for the help!


also, in the printing options in mozilla two things are available: "xp_ps_spooldir_tmp_Xprintjobs@:64" and another entry which is almost identical except it is for pdf. What are these?

I am sorry if i missed something in the docs or if this question has been posted earlier...I tried my best to look! :)


eaglegst 01-07-2004 11:41 PM

If you are on KDE, installing package kdelibs3-cups followed by configuring the printer using preference->system->printer manager will enable you print any document from Kxxx The package may not be called that in sid, I am on Woody...

For mozilla, however, you need to tell the browser the printing command.
Use lp instead of lpr.
The command would be: lp -d printername
where printername is the one you configured in cups

trinbellwoods 01-08-2004 08:25 AM

Thanks for the suggestion, however I am not using KDE, I'm using Enlightenment without a desktop environment.

Also, I tried using the command "lp -d hp_deskjet_3420" and it didn't seem to work. I am a little stumped :scratch:


All times are GMT -5. The time now is 05:39 AM.