LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 01-14-2009, 09:26 PM   #1
Ted Lin
LQ Newbie
 
Registered: Jan 2009
Posts: 10

Rep: Reputation: 0
Login user cannot browser web, but root work well.


Dear Sir,

I use the debian(lenny), I cannot browse web.
But I can use a root terminal to run "firefox www.google.com" command.
The browser will work well. I can connect to web.

It seems to my normal user cannot use the network, but the root can.

Could anybody help me how to check this problem?
I am the newbie in Linux.

Thanks.

Best regards,
Ted Lin
 
Old 01-14-2009, 09:43 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Linux Mint 17, Debian 8
Posts: 7,865

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
You might be able to get a meaningful error message by running firefox on the command line as user. Log in as the normal user and open a terminal. At the command line type in:

firefox www.google.com

and see if there is a decent error message.

-----------------------
Steve Stites
 
Old 01-15-2009, 12:52 AM   #3
Ted Lin
LQ Newbie
 
Registered: Jan 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jailbait View Post
You might be able to get a meaningful error message by running firefox on the command line as user. Log in as the normal user and open a terminal. At the command line type in:

firefox www.google.com

and see if there is a decent error message.

-----------------------
Steve Stites
Hello! Steve,

I have tried the user and root to run firefox www.google.com.

root:
#firefox www.google.com

(firefox-bin:2775): GnomeUI-WARNING **: While connecting to session manager: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-base authentication failed.

Then the browser work well.

normal user:
$firefox www.google.com
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)

Then the browser show "page load error" in the title.

Could you lead me to find what wrong?
Thanks.

Best regards,
Ted Lin
 
Old 01-15-2009, 06:43 AM   #4
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 675
Blog Entries: 11

Rep: Reputation: 36
Hi,

You might check out the permissions that your user has. Root user has all permissions, but the average user doesn't. Are you using Gnome? If so go to "System -> Administration -> Users and Groups". Then find your user in the list and click on "Properties" on the right side of the window. At this point a second window pops up that shows "Account Properties". There are three tabs on this window. Go to the "User Privileges" tab and see what's available. You want to make sure things like "Connect to Internet using a modem" are enabled. On my system there are three likely choices: "Connect to internet using modem", "Connect to wireless and ethernet networks", and "Use modems". I have all three checked off. Then click the "OK" button at the bottom of the frame, and the "close" button at the bottom of the other one. Then log out and log in, and check firefox again. MAKE SURE TO LOG OUT AND LOG IN. Anyway, I hope this helps.
 
Old 01-15-2009, 07:04 AM   #5
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,686

Rep: Reputation: 124Reputation: 124
I had a similar problem mid-December. Using strace I found it had something to do with a missing lock file and after that the real problem turned out to be some prefs.js file gone south... I ended up installing Etch from scratch, as Lenny gives me too much issues (Gnome related). In your case, I suggest the following:

1) rename the .mozilla directory, you can find it in /home/<username>
2) reboot the computer
3) log in as normal user
4) open your browser

If 4) works you can copy the contents of the renamed .mozilla directory back into the new .mozilla dir. Do this 1 file at a time, and check after each one if FF still opens. Make sure the directory structure inside the .mozilla dir stays intact! Files you can copy w/o any issues are bookmarks.html and abook.mab (these are your bookmarks and email addressbook respectively)
 
Old 01-16-2009, 12:49 AM   #6
Ted Lin
LQ Newbie
 
Registered: Jan 2009
Posts: 10

Original Poster
Rep: Reputation: 0
socket: Permission denied

Quote:
Originally Posted by radiodee1 View Post
Hi,

You might check out the permissions that your user has. Root user has all permissions, but the average user doesn't. Are you using Gnome? If so go to "System -> Administration -> Users and Groups". Then find your user in the list and click on "Properties" on the right side of the window. At this point a second window pops up that shows "Account Properties". There are three tabs on this window. Go to the "User Privileges" tab and see what's available. You want to make sure things like "Connect to Internet using a modem" are enabled. On my system there are three likely choices: "Connect to internet using modem", "Connect to wireless and ethernet networks", and "Use modems". I have all three checked off. Then click the "OK" button at the bottom of the frame, and the "close" button at the bottom of the other one. Then log out and log in, and check firefox again. MAKE SURE TO LOG OUT AND LOG IN. Anyway, I hope this helps.

Hi! sir,

Thanks for your help.
I try to check off all the privilieges and log out and log in.
But I still cannot browse web.
I find I cannot ping out.
I write command in terminal, "ping 209.85.175.147". (www.google.com)
I get the below error.
socket: Permission denied.

I think this is the keypoint. Why the normal user cannot use the network? Even I add a new user, it still cannot ping outside.
But the root can do it.

How can I solve the permission denied?
Thanks.

Best regard,
Ted Lin
 
Old 01-16-2009, 12:53 AM   #7
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 379Reputation: 379Reputation: 379Reputation: 379
Quote:
Originally Posted by Ted Lin View Post
I find I cannot ping out.
I write command in terminal, "ping 209.85.175.147". (www.google.com)
I get the below error.
socket: Permission denied.
That sounds like your ping binary isn't SUID.

Post the output of:
Code:
ls -l /bin/ping
 
Old 01-16-2009, 01:50 AM   #8
Ted Lin
LQ Newbie
 
Registered: Jan 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by win32sux View Post
That sounds like your ping binary isn't SUID.

Post the output of:
Code:
ls -l /bin/ping

Dear sir,

ls -l /bin/ping
-rwxr-xr-x 1 ted ted 34852 2007-12-10 12:48 /bin/ping

Thanks.

Best regards,
Ted Lin
 
Old 01-16-2009, 02:48 AM   #9
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 379Reputation: 379Reputation: 379Reputation: 379
Quote:
Originally Posted by Ted Lin View Post
ls -l /bin/ping
-rwxr-xr-x 1 ted ted 34852 2007-12-10 12:48 /bin/ping
Okay that confirms my suspicions (the file is not SUID). But it's worse than that, as the ownership itself is wrong (should be root, not ted). Are you sure you haven't inadvertently executed a chown command as root in the recent past? Like, right before you started having these problems? That's what it's starting to sound like.

At this point, we might as well have a look and see all the files which are SUID root on your system.

Please post the output of this command (make sure you execute it as root):
Code:
find / -user root -perm -4000

PS: Executing the following two commands (as root) should make ping work okay again, but it's looking like your problems go much deeper. We'll know more when you post the output of the above command.
Code:
chown root:root /bin/ping
chmod 4755 /bin/ping

Last edited by win32sux; 01-16-2009 at 03:01 AM.
 
Old 01-19-2009, 12:52 AM   #10
Ted Lin
LQ Newbie
 
Registered: Jan 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by win32sux View Post
Okay that confirms my suspicions (the file is not SUID). But it's worse than that, as the ownership itself is wrong (should be root, not ted). Are you sure you haven't inadvertently executed a chown command as root in the recent past? Like, right before you started having these problems? That's what it's starting to sound like.

At this point, we might as well have a look and see all the files which are SUID root on your system.

Please post the output of this command (make sure you execute it as root):
Code:
find / -user root -perm -4000

PS: Executing the following two commands (as root) should make ping work okay again, but it's looking like your problems go much deeper. We'll know more when you post the output of the above command.
Code:
chown root:root /bin/ping
chmod 4755 /bin/ping

Dear sir,

I have used the chown for the ping. So you find the owner and group is ted.
I have changed back to root.

I post the result of your suggestion.
Code:
ted# find / -user root -perm -4000
/bin/su
/bin/mount
/bin/umount
/bin/ping6
/bin/ping
find: `/proc/2599/task/2599/fd/5': No such file or directory
find: `/proc/2599/task/2599/fdinfo/5': No such file or directory
find: `/proc/2599/fd/5': No such file or directory
find: `/proc/2599/fdinfo/5': No such file or directory
/sbin/mount.nfs
/usr/lib/pt_chown
/usr/lib/openssh/ssh-keysign
/usr/lib/dbus-1.0/dbus-daemon-launch-helper
/usr/lib/eject/dmcrypt-get-device
/usr/sbin/exim4
/usr/bin/newgrp
/usr/bin/chfn
/usr/bin/passwd
/usr/bin/chsh
/usr/bin/gpasswd
/usr/bin/mtr
/usr/bin/procmail
/usr/bin/lppasswd
/usr/bin/sudo
/usr/bin/sudoedit
/usr/bin/X
/usr/src/xserver-xorg-core/xorg-server-1.4.2/debian/tmp/usr/bin/Xorg
Thanks.

Best regards,
Ted Lin
 
Old 01-19-2009, 09:09 AM   #11
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 379Reputation: 379Reputation: 379Reputation: 379
I figured that since your ping binary had wacky permissions, the same might be the case for other binaries meant to be SUID root. From what you posted, it doesn't seem to be the case. If you create a new non-root account and log into it, does Firefox also have the same problem on it?
 
Old 01-19-2009, 11:12 PM   #12
Ted Lin
LQ Newbie
 
Registered: Jan 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by win32sux View Post
I figured that since your ping binary had wacky permissions, the same might be the case for other binaries meant to be SUID root. From what you posted, it doesn't seem to be the case. If you create a new non-root account and log into it, does Firefox also have the same problem on it?
Dear Sir,

Yes,a new non-root account have the same situation.

Thanks.

Best regards,
Ted Lin
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can only start web browser as root tzonga1 Linux - Newbie 2 11-04-2007 05:16 PM
Scripts with root privileges launched from a web browser unforkable Programming 6 03-15-2007 09:12 AM
Gnome: Cannot login as default user, sends back to login, works as root Danny-T Linux - Newbie 2 05-27-2006 03:44 AM
Mozilla Web Browser cannot login into some sites rahulnsoni Linux - Newbie 3 02-08-2004 01:10 PM
can only login as root? user login doesnt work..? anyone? hacking_4_b33r Linux - General 1 02-05-2004 11:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 07:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration