LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 02-16-2019, 11:50 AM   #1
spenced
LQ Newbie
 
Registered: Oct 2017
Posts: 29

Rep: Reputation: Disabled
locginctl show-session tells me type=tty, unable to run Plank says X11 required.


Just like the title says, Plank dock stopped working and I'm receiving this message:
Code:
[CRITICAL 09:46:35.592187] [AbstractMain:257] Only X11 environments are supported.
googling and trying to solve this I was told to run this command:

Code:
loginctl show-session $(loginctl | grep $(whoami) | awk '{print $1}') -p Type
which outputs:

Code:
Type=tty
shouldn't it display X11? Im running kde/plasma/debian buster/sid.I've already reinstalled Xorg, Xorg-server, X11 and kde.

thanks
 
Old 02-16-2019, 12:14 PM   #2
Corvette
Member
 
Registered: Jul 2017
Location: Missouri, United States
Distribution: Debian 9
Posts: 93

Rep: Reputation: 23
How did you login? Specifically, did you switch users, or run sudo -i by chance? Also, what is the full output of

Code:
loginctl show-session $(loginctl | grep $(whoami) | awk '{print $1}')
You could try running 'startx'; the following is a fine resource on the topic: https://www.computerhope.com/unix/startx.htm
 
Old 02-16-2019, 12:53 PM   #3
spenced
LQ Newbie
 
Registered: Oct 2017
Posts: 29

Original Poster
Rep: Reputation: Disabled
I boot to runlevel3 and manually start my desktop session with 'startx' everytime.

Here is the full output:

Code:
Id=1
User=1000
Name=adev
Timestamp=Sat 2019-02-16 09:21:35 PST
TimestampMonotonic=185633415
VTNr=1
Seat=seat0
TTY=tty1
Remote=no
Service=login
Scope=session-1.scope
Leader=1259
Audit=1
Type=tty
Class=user
Active=yes
State=active
IdleHint=yes
IdleSinceHint=1550337698807214
IdleSinceHintMonotonic=189115874
LockedHint=no
and my xinitrc:

Code:
#!/bin/sh

# /etc/X11/xinit/xinitrc
#
# global xinitrc file, used by all X sessions started by xinit (startx)

# invoke global X session script
. /etc/X11/Xsession
xhost +localhost &
startkde
thanks
 
Old 02-16-2019, 04:38 PM   #4
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 11,062
Blog Entries: 7

Rep: Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793
i also use startx, and mine also says Type=tty.
plank shows the same error, but everything else works just fine.
 
Old 02-16-2019, 05:24 PM   #5
Corvette
Member
 
Registered: Jul 2017
Location: Missouri, United States
Distribution: Debian 9
Posts: 93

Rep: Reputation: 23
Hmm, my xinitrc file does not have the last two lines that are in your file:
Code:
xhost +localhost &
startkde
.

I would be cautious about modifying any config files, but if you are unsure why they are there, you could try removing them.

Are you booting into runlevel3 for any specific reason? If not, you could try seeing what types of runlevles are available:

Code:
systemctl list-units --type=target
Look for 'graphical.target' or similar and then run:

Code:
 systemctl set-default graphical.target
See here for more information: https://www.itzgeek.com/how-tos/linu...-debian-9.html
 
Old 02-17-2019, 01:18 AM   #6
spenced
LQ Newbie
 
Registered: Oct 2017
Posts: 29

Original Poster
Rep: Reputation: Disabled
I boot to runlevel 3 because a lot of times I'm just playing around in the console, I have quiet boot turned off, and it seems to be easier because I'm always playing around and breaking things.

I modified my xinit first with the line
Code:
startkde
when I first install my X and my desktop because that's the only way I could get X to start. I did a super minimal install and built up from there, because I am just try to learn everything I can. I can tell you it did not go smoothly, but it all worked out. Plank did run fine a couple days ago.

I added the
Code:
"xhost localhost:"
because I like using
Code:
gksu gnome-terminal
when I install a lot of packages as its the easiest to configure shortcuts and what not. I used Konsole for a long time but it was buggy for me in that regard. Probably my fault.

That startx link was informative, thankyou, I got sucked into the rabbit hole of links and now have a million more questions. I'm telling myself it seems because I'm so new it might be appropriate to try and ditch X and start learning Wayland because I feel like the X11 mishmash is soon going to be obsolete even though so many things still depend on it. But I can never get it to run properly. Anyway I'm going to try your suggestions, revert to my original xinit and keep playing around.

Plank requires the bamfdaemon which has a service file, but I have limited knowledge in how user-session service files work, and the man page wasn't super helpful. I tried:

Code:
systemctl enable bamfdaemon.service
and it said not found, even though its located in /usr/lib/systemd/user/bamfdaemon.service

thanks for the help.

Last edited by spenced; 02-17-2019 at 01:38 AM.
 
Old 02-17-2019, 01:37 AM   #7
spenced
LQ Newbie
 
Registered: Oct 2017
Posts: 29

Original Poster
Rep: Reputation: Disabled
quick update:

reverted to an empty xinitrc file. and ran
Code:
startx
which spun up kde/plasma without a hitch which is encouraging and confusing on an unrelated matter because I spent so much time fiddling with it in the past! But unfortunately, Plank still shows the same error, even in a graphical target. Is there a way to looks at the calls plank is trying to make to verify it has an X11 environment? I've tried syslog, dmesg, kern.log, user.log and strace (way over my head and couldn't grep anything related that I understood)

executing plank with the debug option gives me this:

Code:
 [INFO 23:34:31.429437] [AbstractMain:229] Plank version: 0.11.4
[INFO 23:34:31.429496] [AbstractMain:230] Kernel version: 4.19.0-2-amd64
[INFO 23:34:31.429540] [AbstractMain:231] GLib version: 2.58.3 (2.56.1)
[INFO 23:34:31.429585] [AbstractMain:234] GTK+ version: 3.24.5 (3.22.30)
[INFO 23:34:31.429625] [AbstractMain:237] Wnck version: 3.24.1
[INFO 23:34:31.429673] [AbstractMain:238] Cairo version: 1.16.0
[INFO 23:34:31.429723] [AbstractMain:239] Pango version: 1.42.3
[INFO 23:34:31.429765] [AbstractMain:241] + Cairo/Gtk+ HiDPI support enabled
[INFO 23:34:31.429807] [AbstractMain:244] + Dynamic Quicklists support enabled
[INFO 23:34:31.429849] [AbstractMain:247] + XInput Barriers support enabled
[CRITICAL 23:34:31.429913] [AbstractMain:257] Only X11 environments are supported.
plank is pretty trivial for me but these kinds of things always turn into good ways to learn new things. thanks for the help.
 
Old 02-17-2019, 03:10 AM   #8
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 11,062
Blog Entries: 7

Rep: Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793
as ever so often, if OPs did more research, linux help forums would become empty and boring places...
This led me straight to this.
Problem SOLVED.
 
Old 02-17-2019, 12:19 PM   #9
spenced
LQ Newbie
 
Registered: Oct 2017
Posts: 29

Original Poster
Rep: Reputation: Disabled
I always die a little inside when someone tells me I didn't search enough because I feel like I spend HOURS searching for fear of that exact reply. This time, I screwed the pooched.

Code:
export XDG_SESSION_TYPE=X11
problem solved.

Two lessons learned. If at first your search don't succeed, search again. And, Linux wizards are amazing and helpful. Don't abuse them.

Thanks to all for the replies.

(now wondering what changed changed the env variable to cause the break)

Last edited by spenced; 02-17-2019 at 12:52 PM.
 
Old 02-18-2019, 01:11 AM   #10
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 11,062
Blog Entries: 7

Rep: Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793Reputation: 2793
glad it's SOLVED now!

Quote:
Originally Posted by spenced View Post
I always die a little inside when someone tells me I didn't search enough because I feel like I spend HOURS searching for fear of that exact reply.
that's why i usually include the search terms (and engine, nota bene) that led me to the solution.
and don't beat yourself up, it took me 8 posts into the thread, too.
Quote:
(now wondering what changed changed the env variable to cause the break)
i believe that was covered in some of the other results from that search.

Last edited by ondoho; 02-18-2019 at 01:12 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] I am using Plank as a taskbar substitute - is there a way to get the network connection applet to display on my Plank taskbar? benjaminthomas Linux - Newbie 9 10-17-2017 09:45 PM
[SOLVED] /usr/bin/X11/X11/....... 10 X11 subsets & counting walter74 Linux - General 2 06-07-2015 12:36 AM
tty in chroot env says "not a tty" pattbert Linux - Software 1 11-19-2011 10:06 PM
being a plank jesta1865 Linux - Newbie 7 04-21-2006 02:40 AM
xorg-x11-libs required by xorg-x11-devel darknails Fedora 1 01-13-2005 02:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 07:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration