LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Locales - Polish Fonts (https://www.linuxquestions.org/questions/debian-26/locales-polish-fonts-299920/)

zoharPL 03-10-2005 05:13 AM

Locales - Polish Fonts
 
Hi,
I'd like to ask about localization of Debian, where are the config files i need to change, for my wmaker work with polish fonts (I have polish fonts under console, but no in X). Whenever it is ISO-8859-2 or UTF-8 I just would like to have possibility to use polish fonts in different applications such as OOo, or Opera/Firefox... I wont put here config files for not to flood with data, but ask for cat files and I will put them here.
If anyone know, what to do, please help...

Dead Parrot 04-16-2005 12:32 AM

Have you tried (as root) "dpkg-reconfigure locales"?

zoharPL 04-16-2005 03:36 AM

Yes, but well... as I've written before, I HAVE polish keyboard/fonts in console, it just doesn't work under X's :S

Dead Parrot 04-16-2005 04:05 AM

Hmm... yes, in general you can set console keymap with "dpkg-reconfigure console-data", while "dpkg-reconfigure locales" defines what locale your apps under X server use. But come to think of it, OOo and Firefox do have their own locale packages that you need to install if you want to localize them. Sorry, I was a bit absent-minded. You should install these packages:

mozilla-firefox-locale-pl-pl
openoffice.org-l10n-pl

EDIT:
Oh, and the keymap under X is set in /etc/X11/XF86Config-4. You can probably change this keymap with "dpkg-reconfigure xserver-xfree86".

If you decide to edit /etc/X11/XF86Config-4 manually, there is a special section for keyboard that should look something like this:

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "pl"
EndSection

zoharPL 04-19-2005 03:48 AM

Generated by dpkg reconfigure:
Code:

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "keyboard"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xfree86"
        Option          "XkbModel"      "pc104"
        Option          "XkbLayout"    "pl"
        Option          "XkbVariant"    "pl1"
        Option          "XkbOptions"    "pl"
EndSection

About the packages, I have both...
I'm not sure if it isn't about WMaker configuration, because alt is used for some combinations there, and I can't see right/left alt to choose, just alt, when right alt should be used for diactrics (if it does matter of course).

Dead Parrot 04-19-2005 05:34 AM

Your settings seem OK to me, although I thought pc104 was for U.S.-style keyboards and pc105 for European. But, then again, I'm no expert in localization and I'm running out of suggestions.

/usr/share/doc seems to have such directories as /locales and /localization-config but I don't know if there's anything useful. Also Debian has an extensive X Window System FAQ in /usr/share/doc/xfree86-common .

Sometimes also man pages can be useful. You can try "man -k locale" to search matching man pages for "locale". Man pages are sorted under different sections, for example locale(5) means that the locale page can be found from section 5 and you can view it with the "man 5 locale" command, or you can use the xman utility.

I'm sorry that I cannot help more but, as I said, I lack expertise in this area. :(


All times are GMT -5. The time now is 12:24 AM.