LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 09-29-2004, 10:23 AM   #16
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46

Quote:
ok, but where i set all language and locales?
I think that the "dpkg-reconfigure locales" command modifies the /etc/locale.gen file. "dpkg-reconfigure locales" seems to work with most login methods, but not all. When I installed Login.app (it's a very simple GUI login screen), I noticed that my locales were not read. I fixed this by adding my locales to the beginning of my ~/.xsession file.

Note: you can easily check your current POSIX locale settings with the "locale" command.

I guess there's no harm in specifying locales in several resource files (as long as you don't set one locale in one file and a different locale in another file ). So, in principle, it would be possible to set locales in ~/.bash_profile (I think this is the standard place to set locales), ~/.bashrc, ~/.xinitrc, and in ~/.xsession. Try something like this in different resource files until you find the one that your login method reads:

export LANG=pt_PT@euro
export LC_ALL=pt_PT@euro

Have fun exploring!
 
Old 09-29-2004, 10:25 AM   #17
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
dpkg-reconfigure locales
will allow you to generate these languages for your system.
however it won't fix your (harmless) "perl: warning" message (if it isn't fixed by now). you have to give LANGUAGE, LC_ALL,.. into your environment by using on of the earlier mentioned files.
have you solved anything about your font-size problem yet?

sl mritch.
 
Old 09-29-2004, 10:48 AM   #18
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
If you use ISO 8859-2, ISO 8859-3, ISO 8859-4, ISO 8859-5, ISO 8859-7, ISO 8859-8, ISO 8859-9, ISO 8859-10, ISO 8859-13, ISO 8859-14, ISO 8859-15, or KOI8-R encodings, you should make sure that you have installed "xfonts-base-transcoded", "xfonts-75dpi-transcoded", and "xfonts-100dpi-transcoded" font packages.
 
Old 09-29-2004, 02:20 PM   #19
j.vilon
Member
 
Registered: Sep 2004
Posts: 168

Original Poster
Rep: Reputation: 30
yes i do that.. i download 3
"xfonts-base-transcoded", "xfonts-75dpi-transcoded", and "xfonts-100dpi-transcoded"

but i have littles icons.. :| it's dont work.
or where i config that of fonts?
tks
 
Old 09-29-2004, 02:53 PM   #20
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
XF86Config -file something like this (order does matter):

Section "Files"
FontPath "tcp/192.168.1.30:7100" <-- for you rather localhost; or leave it out if no fontserver's active
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/misc/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

sl mritch.

Last edited by mritch; 09-29-2004 at 02:56 PM.
 
Old 09-29-2004, 03:19 PM   #21
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Maybe you should experiment with changing the default font size.

1) First you could check what macondo says in "Debian Post-Install Configuration" about font sizes. http://www.linuxquestions.org/questions/answers/259

2) If that doesn't help, you can experiment with settings like "Xft.dpi: 100" and "Xft.dpi: 120" in .Xresources.

3) Check that anti-aliasing is turned on in fluxbox (that may affect how fonts look).

4) If that doesn't help, you can look for the fluxbox config files in your home directory and see if they have some option to change font size.
 
Old 09-29-2004, 09:18 PM   #22
j.vilon
Member
 
Registered: Sep 2004
Posts: 168

Original Poster
Rep: Reputation: 30
yes i have this

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"

what i change or modify for configure stay good?
tks guys
 
Old 09-30-2004, 08:04 PM   #23
j.vilon
Member
 
Registered: Sep 2004
Posts: 168

Original Poster
Rep: Reputation: 30
no one know?
 
Old 09-30-2004, 08:22 PM   #24
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Honestly, I'm confused about your problem with small icons. This has never happened to me. I can only assume that it has something to do with the default font size. And yet you say that your icons became small when you re-configured your locales. I'm puzzled.

The only suggestion that comes to my mind at this point is that maybe you should install another window manager and see if your apps & their icons show differently in another WM. Here are some good window managers you could try: Blackbox, Openbox, IceWM, Window Maker, Afterstep.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
once again locales mib_ths Ubuntu 1 07-26-2005 05:23 PM
KXDOCKER config questions, it works but how to i activate icons? Whiskers Linux - Software 0 06-06-2005 09:17 PM
locales? trendkiller Linux - Newbie 1 03-05-2004 09:53 AM
locales raven Linux - Software 18 11-03-2002 02:34 PM
locales-en jimjamz Linux - General 2 06-07-2001 09:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration