LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 09-22-2004, 01:58 PM   #1
j.vilon
Member
 
Registered: Sep 2004
Posts: 168

Rep: Reputation: 30
littles icons after config locales


hy

i config my locales but now i have another problem, my icon's are so littles, ex: i open my lmule and the " program " is soo little i cant read words
anyone help me pls?
tks
 
Old 09-22-2004, 07:17 PM   #2
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,017

Rep: Reputation: 52
are you using kde or gnome?

if so you are going to have to play with them, Debian is fine.
 
Old 09-23-2004, 02:18 PM   #3
j.vilon
Member
 
Registered: Sep 2004
Posts: 168

Original Poster
Rep: Reputation: 30
i use fluxbox..

but what is the problem?
tks
 
Old 09-23-2004, 03:17 PM   #4
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,017

Rep: Reputation: 52
go to the .fluxboxrc, and see if there are lines for the fonts and sizes.
 
Old 09-25-2004, 12:50 PM   #5
j.vilon
Member
 
Registered: Sep 2004
Posts: 168

Original Poster
Rep: Reputation: 30
hy, i dont have this..

nano .fluxbox/
backgrounds/ fluxbox-menu keys menudefs.hook startup
bsetbg init menu slitlist styles/


$ cat .fluxboxrc
cat: .fluxboxrc: No such file or directory

anykne helpme?
 
Old 09-25-2004, 02:06 PM   #6
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,017

Rep: Reputation: 52
#updatedb

#locate fluxboxrc

check with the boys at #fluxbox on the IRC, use the Freenode server.
 
Old 09-25-2004, 03:30 PM   #7
j.vilon
Member
 
Registered: Sep 2004
Posts: 168

Original Poster
Rep: Reputation: 30
on locate fluxboxrc
he found nothing, but.. what is the problem?
tks
 
Old 09-27-2004, 08:08 PM   #8
j.vilon
Member
 
Registered: Sep 2004
Posts: 168

Original Poster
Rep: Reputation: 30
anyone?
 
Old 09-27-2004, 09:01 PM   #9
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
"cat /var/log/XFree.0.log | grep DPI"

& what locales have you changed? anything else? i can't think 'bout a connection with your font"size".

sl mritch.
 
Old 09-28-2004, 06:57 PM   #10
j.vilon
Member
 
Registered: Sep 2004
Posts: 168

Original Poster
Rep: Reputation: 30
cat /var/log/XFree86.0.log | grep DPI
(++) NVIDIA(0): DPI set to (100, 100)

i dont now.. :S perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
(Reading database ... 101277 files and directories currently installed.)
Removing mozilla-firefox ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = "pt_PT",
LANG = "pt_PT@euro"
are supported and installed on your system.


help me please, tks
and now always this error:
 
Old 09-28-2004, 08:57 PM   #11
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Well, I don't really know what's causing your problem, but if you've got some extra time to kill and energy to spend, you can create an .Xresources file into your home directory ("nano .Xresources") and see if that helps. You should type "Xft.dpi: 96" (without quotation marks) into this .Xresources file. This "Xft.dpi: 96" should determine the font size for your X session, and if the icon size is somehow connected to the font size, then this should have some effect also on the icon size. Log out and log in again for the .Xresources settings to take effect.
 
Old 09-28-2004, 09:49 PM   #12
j.vilon
Member
 
Registered: Sep 2004
Posts: 168

Original Poster
Rep: Reputation: 30
(++) NVIDIA(0): DPI set to (100, 100)
dont work :|
but where i can configure this? you know?
tks
 
Old 09-28-2004, 10:29 PM   #13
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
to get your locales working add something like these to your /etc/profile or /etc/bash.bashrc or home../.bashrc, home/bash_profile or...

LANG=de_AT@euro <-- your language here
export LANG
do the same thing for LANGUAGE,LC_ALL,.. (everything unset)

i believe setting DPI won't help in your case. to try it, edit /etc/xinit/xserverrc and change accordingly.
well, /etc/init/xserverrc may be debian specific. if the file's not there try
egrep -ir "dpi" *
in your /etc/X11 directory

if this doesn't work i must tell you that i've no idea what's on with your fonts. check your XF86Config's font entries.

ls mritch
 
Old 09-29-2004, 08:43 AM   #14
j.vilon
Member
 
Registered: Sep 2004
Posts: 168

Original Poster
Rep: Reputation: 30
ok, but where i set all language and locales?
tks
 
Old 09-29-2004, 09:32 AM   #15
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,017

Rep: Reputation: 52
"ok, but where i set all language and locales?"

For fonts see the thread: "Debian Configuration Post-Install", at the top of this page.

For locales, do a:

#dpkg-reconfigure locales

select all the instances of en_US and if you use another language, select them, too, then in the next page select the locales you want for your environment, IOW, if you want your system in French, and you have selected them in the previous page, it will be so (i usually select one with the utf-8), this will take effect when you reboot.



Last edited by macondo; 09-29-2004 at 10:12 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
once again locales mib_ths Ubuntu 1 07-26-2005 05:23 PM
KXDOCKER config questions, it works but how to i activate icons? Whiskers Linux - Software 0 06-06-2005 09:17 PM
locales? trendkiller Linux - Newbie 1 03-05-2004 09:53 AM
locales raven Linux - Software 18 11-03-2002 02:34 PM
locales-en jimjamz Linux - General 2 06-07-2001 09:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration