-   Debian (
-   -   lirc doesn't compile using m-a a-i (

mad4linux 07-06-2009 11:46 AM

lirc doesn't compile using m-a a-i
Hello everybody.

I've installed lirc and lirc-modules-source on lenny

I followed the instructions in the readme.debian file.
But sadly, lirc-modules don't compile against kernel 2.6.26-2-686!

I did a fuul update today before trying to install lirc and have kernel 2.6.26+17+lenny1 installed.

Here is what i tried on the command line:

cd /usr/src
tar -xjf lirc-modules.tar.bz2
dpkg-reconfigure lirc-modules-source
m-a update
m-a prepare
m-a a-i lirc

I've configured lirc-modules-source to just build the i2c package, which is the one i need.

m-a a-i lirc fails after this message

Entering directory '/usr/src/linux-headers-2.6.26-2-686'
ERROR: Kernel configuration is invalid.
include/linux/autoconf.h or include/config/auto.conf are missing
Run 'make oldconfig && make prepare' on kernel src to fix it.

But both files do exist. The make oldconfig stuff doesn't help either.
I've also tried to

export CC=gcc-4.1
before invoking m-a. Didn't help nothing as well.
Any hint is appreciated!

vharishankar 07-06-2009 11:55 AM

Looking at lirc-modules-source description: It says the full kernel sources need to be installed to compile this package. Did you install the kernel source package? (headers alone might not be enough)



Entering directory '/usr/src/linux-headers-2.6.26-2-686'

mad4linux 07-06-2009 12:57 PM

thank you for the fast reply harishanker . I've installed the kernel-sources and un packed them as well before trying as described above.
When trying to invoke m-a like this:

m-a -k /usr/src/linux-source-2.6.26/ -l 2.6.26-2-686 a-i lirc
i get the same error message again.

All times are GMT -5. The time now is 07:21 AM.