LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 09-24-2004, 04:47 PM   #1
pjpeter
Member
 
Registered: Sep 2004
Distribution: Debian Sarge RC1 Kernel 2.6.7.1
Posts: 46

Rep: Reputation: 15
Limited to 60hz Refresh Rate


I have Debian Sarge and I have this in my XF86Free Config FIle:

SubSection "Display"
Depth 24
Modes "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection

It works fine, but I have no way to edit the Hz ratings, should I?

In WIndows I can set it to 1280x1024 @ 160 Hz and it looks great.

At 60 Hz my eyes tire very quickly and I have to leave the computer for a long time before I can go back. If you can help me then that would be great.

In Debian 'Sreen Resolution' program there is only the option of 60Hz, even if I am at 800x640.

Thanks,
Peter
 
Old 09-24-2004, 04:54 PM   #2
superbondbond
Member
 
Registered: Nov 2002
Posts: 668

Rep: Reputation: 30
Did you try manually setting it in your XF86Config file? for example.
Code:
Section "Monitor"

    Identifier  "My Monitor"

# HorizSync is in kHz unless units are specified.
# HorizSync may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.

    HorizSync   31.5 - 80.0

#    HorizSync  30-64         # multisync
#    HorizSync  31.5, 35.2    # multiple fixed sync frequencies
#    HorizSync  15-25, 30-50  # multiple ranges of sync frequencies

# VertRefresh is in Hz unless units are specified.
# VertRefresh may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.

    VertRefresh 55-85

EndSection
 
Old 09-24-2004, 05:09 PM   #3
pjpeter
Member
 
Registered: Sep 2004
Distribution: Debian Sarge RC1 Kernel 2.6.7.1
Posts: 46

Original Poster
Rep: Reputation: 15
Hmm, here is what I have in the file that seems to relate to monitors (if 1 part of it related to monitor/screen I posted the whole section) - here it is.

Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
Load "synaptics"
EndSection
Section "Device"
Identifier "Generic Video Card"
Driver "ati"
EndSection
Section "Monitor"
Identifier "Generic Monitor"
HorizSync 30-92
VertRefresh 50-85
Option "DPMS"
EndSection
Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Mouse" "AlwaysCore"
EndSection

---------------------------------------------------------------------------
It seems that those values are there, like the ones you had in yours. Certainly not ones that limit it to 60 Hz, I think.

Also want to mention I ran dpkg-reconfigure xserver-xfree86 and selected 1280x960 85hz again as I did the first time. I don't think it saved this time, but I am pretty sure thats what I selected the first time.

Thanks,
Peter

Last edited by pjpeter; 09-24-2004 at 05:19 PM.
 
Old 09-24-2004, 05:46 PM   #4
pjpeter
Member
 
Registered: Sep 2004
Distribution: Debian Sarge RC1 Kernel 2.6.7.1
Posts: 46

Original Poster
Rep: Reputation: 15
I editted the Gconf key in /desktop/gnome/screen/default/0 to 'rate 85'

But I don't think it actually did anything, and I'm not sure how to check . At 1280x960 on the Screen Resolutions setting it has the option of only 60hz still, with no mention of the 85 Hz that I changed it to.

So I really think I didn't do anything... : (

Please help,
Peter
 
Old 09-24-2004, 06:07 PM   #5
zuralin
Member
 
Registered: Sep 2003
Distribution: Debian testing/unstable
Posts: 225

Rep: Reputation: 30
You need to find the correct v/h refresh rates of your monitor. If you can't find them then post your monitor model and maybe someone else will be able to find them.
 
Old 09-24-2004, 06:58 PM   #6
pjpeter
Member
 
Registered: Sep 2004
Distribution: Debian Sarge RC1 Kernel 2.6.7.1
Posts: 46

Original Poster
Rep: Reputation: 15
Its a laptop. SXGA Video Screen - G732. Its Native Resolution I believe is 1400x(Something)

Peter
 
Old 09-24-2004, 06:59 PM   #7
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,017

Rep: Reputation: 52
1. google for your horiz and vertical frequencies, just type your monitor's brand and model in google.com/linux. Once you got them do a

#dpkg-reconfigure xserver-xfree86

do an 'Advanced' configuration, enter the correct vert and horiz frequencies,
when you are thru, proceed to the gnome instructions.

2. if you can't find them (i can't see why not), install these autodetection programs:

#apt-get install read-edid discover

reboot, and hope it's autodetected

3. once you are in gnome, go to:

Applications > Desktop Preferences > Screen Resolution

and you will find a dialog box where you can choose your resolution and refresh rates.

Play with gnome, open everything, so you know where to look in future times.

Last edited by macondo; 09-24-2004 at 07:11 PM.
 
Old 09-24-2004, 08:38 PM   #8
pjpeter
Member
 
Registered: Sep 2004
Distribution: Debian Sarge RC1 Kernel 2.6.7.1
Posts: 46

Original Poster
Rep: Reputation: 15
Thats how I started this, I went to the Gnome Screen Resolutions option and it would not let me select anything but 60 Hz on any Resolution.

I'll look into your other suggestions though.

Thanks,
Peter

Edit:

I tried google,com/linux - I have a Laptop, and I can't find those settings listed anywhere. I ran dpkg reconfigure as I said earlier and I Know when I first installed it I set it to above 60 hz, but it had no effect on solving my problem.

My laptop is an ECS G732, Other brands of the same laptop are Gericom Masterpeice and WInbook J4. You are welcome to try looking for it yourself though if you want, but I can't find anything at all about its horizizontal or vertical refresh rates there - I know its an SXGA Screen though, with a 1400x1050 capability.

Going to reboot one more time and then try your autoconfig suggestion and hope for the best.

Last edited by pjpeter; 09-24-2004 at 08:46 PM.
 
Old 09-24-2004, 11:45 PM   #9
pjpeter
Member
 
Registered: Sep 2004
Distribution: Debian Sarge RC1 Kernel 2.6.7.1
Posts: 46

Original Poster
Rep: Reputation: 15
Tried that autoconfig app, no success for video. But it fixed my audio, lol thanks for that . But my video is still screwed unfortunately (60hz is still the max selectable in the Screen Resolution control section) , any other suggestions?

Thanks and please help,
Peter
 
Old 09-25-2004, 07:45 AM   #10
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
CRT monitors start to flicker and strain eyes when refresh rate decreases, but this doesn't happen with LCD monitors. So you can have 60Hz refresh rate in your laptop and your eyes still don't get tired.

If you DO experience that in using Gnome desktop your eyes get tired faster than in using Windows desktop, the most likely reason is the way that Gnome renders anti-aliased fonts. (It sucks.) There are a couple of ways you can try to fix this. Enable freetype autohinting by running (as root) "dpkg-reconfigure fontconfig". Also install "msttcorefonts" and experiment with different fonts (bold font type may be easier on eyes than narrow font type). Also check what font rendering properties you can tweak in Gnome (LCD, RGB).

If nothing seems to help, you should try another window manager. You can perfectly well run all your Gnome apps from Fluxbox, Window Maker, or Afterstep. (In XFCE4 font rendering sucks, just like in Gnome.)
 
Old 09-25-2004, 02:57 PM   #11
JaakRandmets
LQ Newbie
 
Registered: Sep 2004
Location: estonia
Distribution: debian
Posts: 21

Rep: Reputation: 15
I'm having similar problem with my CRT display (correctly configured btw).
Under win i can run 1024x768 fine at 100hz but with debian im limited to 85 and higher resolutions will limit hz more:
1280x1024 at 6x in linux while 85 is okay under windows and reccomended in samsungs site.
go figure o_O

Last edited by JaakRandmets; 09-25-2004 at 02:59 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Refresh rate problem 60Hz @ 1200x1024 Tonki Linux - Hardware 1 11-15-2005 01:24 PM
Changing screen resolution to 1024x768..refresh rate cannot change too stays 60hz Niceman2005 Linux - General 4 11-03-2005 11:00 AM
Vertical refresh rate, horizontal sync rate. NomDeGuerre Linux - Newbie 7 10-07-2005 03:36 AM
problems with refresh rate on a dell! (stuck to 60hz) Falafel Linux - Hardware 2 03-02-2004 04:40 PM
Force Linux to run at 60hz refresh rate gfx Linux - Hardware 1 10-26-2003 09:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 11:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration