LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Libranet Debian apt question (https://www.linuxquestions.org/questions/debian-26/libranet-debian-apt-question-126680/)

craigdolson 12-17-2003 12:42 PM

Libranet Debian apt question
 
OK, i am using libranet (debian). I have Gnome 2.2 installed by default. I want Gnome 2.4 Where do i go to get it with apt??.

Next question..

i have tried to install several packages but i keep getting the same deal..

"root@Debian:/etc/apt# apt-get install totem
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

Sorry, but the following packages have unmet dependencies:
totem: Depends: libbonoboui2-0 (>= 2.2.2) but 2.0.1-2 is to be installed
Depends: libgconf2-4 (>= 2.2.1) but 1.2.1-3 is to be installed
Depends: libgnome-desktop-2 (>= 2.1.90) but it is not going to be installed
Depends: libgnome2-0 (>= 2.1.90) but 2.0.2-2 is to be installed
Depends: libgnomecanvas2-0 (>= 2.1.90) but 2.0.2-1 is to be installed
Depends: libgnomeui-0 (>= 2.1.90) but 2.0.3-1 is to be installed
Depends: libgnomevfs2-0 (>= 2.2.5) but 2.0.2-7.1 is to be installed
Depends: libgnomevfs2-common (>= 2.2.5) but 1.9.11-1 is to be installed
Depends: libgtk2.0-0 (>= 2.2.1) but it is not going to be installed
Depends: libpango1.0-0 (>= 1.2.1) but 1.0.4-1 is to be installed
E: Sorry, broken packages
root@Debian:/etc/apt#

Here is what i got when i tried to install GAIM

root@Debian:/etc/apt# apt-get install gaim
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

Sorry, but the following packages have unmet dependencies:
gaim: Depends: libaspell15 (>= 0.50.3-1) but it is not installable
Depends: libatk1.0-0 (>= 1.2.4) but 1.0.3-1 is to be installed
Depends: libc6 (>= 2.3.1-1) but 2.2.5-14 is to be installed
Depends: libglib2.0-0 (>= 2.2.2) but 2.0.6-1 is to be installed
Depends: libgtk2.0-0 (>= 2.2.1) but it is not going to be installed
Depends: libgtkspell0 but it is not installable
Depends: libpango1.0-0 (>= 1.2.1) but 1.0.4-1 is to be installed
Depends: libperl5.8 (>= 5.8.0) but it is not installable
Depends: libssl0.9.7 but it is not installable
E: Sorry, broken packages
root@Debian:/etc/apt#

i have gone to the unofficial apt site and done a search for a specific package. when the results come up, i take the link, with the apt components and copy them to the /etc/apt/sources.list file and run
apt-get update, then apt-get install whatever package.

I have gotten the same message on several packages i would like to install. Is it something that i am overlooking??? Will upgrading Gnome to 2.4 fix this issue??

mi6 12-17-2003 03:42 PM

well, from your errors generated it looks like you are trying to install a program whose dependencies downgrade packages. Have you been mixing stable, testing, unstable in your sources.list?

What version Libranet?

craigdolson 12-17-2003 06:27 PM

i have not done that. I have been just using stable releases. I am using Libranet 2.7x classic. This is the free version, not the $60.00 version.

mi6 12-17-2003 08:19 PM

okay, that is what I am running...

have you tried an #apt-get clean or --fix-missing ?

here is my sources.list just for reference:

Code:


#Debian
deb ftp://ftp.debian.org/debian woody main contrib non-free
#deb-src ftp://ftp.debian.org/debian woody main contrib non-free

#Debian Non-US
deb http://non-us.debian.org/ woody/non-US main contrib non-free
#deb-src http://non-us.debian.org/ woody/non-US main contrib non-free

#Debian security updates
deb ftp://security.debian.org/debian-security stable/updates main contrib non-free
#deb-src ftp://security.debian.org/debian-security stable/updates main contrib non-free



All times are GMT -5. The time now is 09:53 AM.