LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 07-11-2007, 02:49 PM   #1
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 675
Blog Entries: 11

Rep: Reputation: 36
libc6 update question - disaster?


This is the latest in a long line of attempts to do something that might really -- in the long run -- be ill advised.

I use etch. I've come across a package in lenny that requires ONLY the ugrade of libc6 in order to be installed (I think). My question is, should I upgrade libc6 to version 2.5-9 and install the package or not. Will this break my system? The package I am ultimately interested in from lenny is 'usplash-theme-debian'.

Any advice would be appreciated.
 
Old 07-11-2007, 03:06 PM   #2
war1025
Member
 
Registered: Jul 2006
Distribution: Debian: Squeeze AMD64
Posts: 318

Rep: Reputation: 32
assuming that you could still boot your machine, which i'm sure you could...

you could always just apt-get remove libc6, change the sources.list back to etch and apt-get install libc6

that would take it back to the old version... err... i think.
 
Old 07-11-2007, 04:15 PM   #3
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 675

Original Poster
Blog Entries: 11

Rep: Reputation: 36
apt does depend on libc6. Which makes me ask: What exactly would break if everything that depended on libc6 broke? What would be left working? Would apps work partially? Would apt-get work or would I need to re-install?

Last edited by radiodee1; 07-11-2007 at 04:16 PM.
 
Old 07-11-2007, 04:27 PM   #4
utanja
Member
 
Registered: Apr 2004
Location: Europe:Salzburg Austria USA:Orlando,Florida;
Distribution: Debian
Posts: 643

Rep: Reputation: 32
Question

Quote:
Originally Posted by radiodee1
apt does depend on libc6. Which makes me ask: What exactly would break if everything that depended on libc6 broke? What would be left working? Would apps work partially? Would apt-get work or would I need to re-install?
what do you mean by work partially???
 
Old 07-11-2007, 04:34 PM   #5
Telemachos
Member
 
Registered: May 2007
Distribution: Debian
Posts: 754

Rep: Reputation: 59
Please consider this before you do that:
Code:
$ aptitude remove libc6 -s
<snip>
The following packages are BROKEN:
  abook acpid alsa-tools alsa-utils apt apt-utils aptitude at base-passwd 
  bash bc bind9-host binutils bsdmainutils bsdutils bug-buddy busybox 
  cdrdao console-tools coreutils cpio cpp-4.1 cron cups-pdf cupsys dbus 
  dbus-x11 dc debianutils deborphan desktop-file-utils dhcp3-client 
  dhcp3-common dialog diff dmidecode dnsutils dpkg dselect dvd+rw-tools 
  e2fslibs e2fsprogs ed eject eog evince fakeroot fetchmail file 
  file-roller findutils finger flashplayer-mozilla fontconfig ftp g++-4.1 
  gawk gcalctool gcc-4.1 gconf-editor gconf2 gdb gdm gedit genisoimage 
  gettext gettext-base gimp gksu gnome-about gnome-applets 
  gnome-control-center gnome-cups-manager gnome-keyring gnome-media 
  gnome-menus gnome-mount gnome-panel gnome-power-manager gnome-screensaver 
  gnome-session gnome-system-monitor gnome-system-tools gnome-terminal 
  gnome-volume-manager gnomebaker gnupg gpgv grep groff-base grub gs-esp 
  gstreamer0.10-alsa gstreamer0.10-ffmpeg gstreamer0.10-gnomevfs 
  gstreamer0.10-plugins-base gstreamer0.10-plugins-good 
  gstreamer0.10-plugins-ugly gtk2-engines gtk2-engines-pixbuf gzip hal 
  hostname icedax iceweasel ifupdown imagemagick info initscripts iptables 
  iputils-ping ispell klogd less liba52-0.7.4 libaa1 libacl1 libamrnb2 
  libamrwb2 libao2 libapm1 libart-2.0-2 libartsc0 libasound2 libaspell15 
  libasyncns0 libatk1.0-0 libattr1 libaudio2 libaudiofile0 libavahi-client3 
  libavahi-common3 libavahi-glib1 libavc1394-0 libavcodeccvs51 
  libavformatcvs51 libavutilcvs49 libbind9-30 libblkid1 libbonobo2-0 
  libbonobo2-common libbonoboui2-0 libbz2-1.0 libc6-dev libc6-i686 libcaca0 
  libcairo2 libcamel1.2-10 libcap1 libcdio6 libcdparanoia0 libcomerr2 
  libcompress-zlib-perl libconsole libcpufreq0 libcroco3 libcucul0 
  libcupsimage2 libcupsys2 libcurl3 libdatrie0 libdb4.2 libdb4.3 libdb4.4 
  libdbus-1-3 libdbus-glib-1-2 libdevmapper1.02 libdigest-sha1-perl 
  libdirectfb-0.9-25 libdjvulibre15 libdmx1 libdns22 libdns32 libdrm2 
  libdv4 libdvdnav4 libdvdread3 libebook1.2-9 libecal1.2-7 
  libedataserver1.2-9 libedataserverui1.2-8 libedit2 libeel2-2.18 
  libenchant1c2a libesd0 libevent1 libexif12 libexpat1 libfaac0 libfaad0 
  libfam0 libflac8 libfontconfig1 libfontenc1 libfreebob0 libfreetype6 
  libfribidi0 libfs6 libgail-common libgail18 libgc1c2 libgcc1 libgconf2-4 
  libgcrypt11 libgdbm3 libggi2 libgii1 libgimp2.0 libgksu2-0 
  libgl1-mesa-glx libglade2-0 libglib2.0-0 libglu1-mesa libgnome-desktop-2 
  libgnome-keyring0 libgnome-menu2 libgnome-window-settings1 libgnome2-0 
  libgnomecanvas2-0 libgnomecups1.0-1 libgnomecupsui1.0-1c2a libgnomekbd1 
  libgnomekbdui1 libgnomeprint2.2-0 libgnomeprintui2.2-0 libgnomeui-0 
  libgnomevfs2-0 libgnutls13 libgpg-error0 libgpmg1 libgsasl7 libgsf-1-114 
  libgsm1 libgssapi2 libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 
  libgtk2.0-0 libgtksourceview1.0-0 libgtop2-7 libgucharmap6 
  libhal-storage1 libhal1 libhtml-parser-perl libhunspell-1.1-0 libice6 
  libid3tag0 libidl0 libidn11 libiec61883-0 libisc11 libisc32 libisccc30 
  libisccfg30 libjack0 libjasper1 libjpeg62 libkeyutils1 libkpathsea4 
  libkrb53 liblame0 liblcms1 libldap2 liblircclient0 liblocale-gettext-perl 
  liblockfile1 libltdl3 liblwres30 liblzo2-2 libmad0 libmagic1 libmagick9 
  libmetacity0 libmikmod2 libmng1 libmozjs0d libmpcdec3 libmpeg2-4 
  libmusicbrainz4c2a libmyspell3c2 libnautilus-burn4 libnautilus-extension1 
  libncurses5 libncursesw5 libnet-dns-perl libnewt0.52 libnfsidmap2 
  libnotify1 libnspr4-0d libnss3-0d libogg0 liboil0.3 libopenal0a 
  libopencdk8 liborbit2 libpam-modules libpam0g libpanel-applet2-0 
  libpango1.0-0 libpaper1 libpci2 libpng12-0 libpoppler-glib1 libpoppler1 
  libpopt0 libpostproccvs51 libpulse0 libraw1394-8 libreadline5 
  librpcsecgss3 librsvg2-2 librsvg2-common libsasl2-2 libscrollkeeper0 
  libsdl1.2debian-alsa libselinux1 libsemanage1 libsepol1 libsexy2 
  libshout3 libsidplay1 libsigc++-2.0-0c2a libslab0 libslang2 libslp1 
  libsm6 libsmbclient libsmbios1 libsocket6-perl libsoup2.2-8 libspeex1 
  libssl0.9.8 libstartup-notification0 libstdc++5 libstdc++6 libsvga1 
  libsysfs2 libtag1c2a libtasn1-3 libterm-readkey-perl 
  libtext-charwidth-perl libtext-iconv-perl libthai0 libtheora0 libtiff4 
  libtorrent10 libtotem-plparser1 libungif4g libusb-0.1-4 libuuid1 
  libvisual-0.4-0 libvolume-id0 libvorbis0a libvorbisenc2 libvorbisfile3 
  libvte9 libwavpack1 libwmf0.2-7 libwnck18 libwrap0 libx11-6 libx264-54 
  libx264-55 libxau6 libxaw7 libxcursor1 libxdamage1 libxdmcp6 libxext6 
  libxfixes3 libxfont1 libxft2 libxi6 libxinerama1 libxkbfile1 
  libxklavier11 libxml2 libxml2-utils libxmu6 libxmuu1 libxp6 libxpm4 
  libxrandr2 libxrender1 libxres1 libxslt1.1 libxss1 libxt6 libxtrap6 
  libxtst6 libxul0d libxv1 libxvidcore4 libxvmc1 libxxf86dga1 libxxf86misc1 
  libxxf86vm1 links linux-headers-2.6.21.5-rt18-odysseus 
  linux-kbuild-2.6.18 locales login logrotate lsof m4 mailx make man-db 
  mawk mesa-utils metacity mktemp module-init-tools moreutils most mount 
  mozilla-mplayer mpack mpc mpd mplayer msmtp mtools mtr-tiny mutt nano 
  nautilus nautilus-gksu ncurses-bin net-tools netcat nfs-common 
  notification-daemon odbcinst1debian1 openbsd-inetd openssh-client 
  openssh-server partimage passwd patch pciutils perl perl-base pidentd 
  policycoreutils poppler-utils portmap powermgmt-base procmail procps 
  psmisc python-cairo python-glade2 python-gmenu python-gnome2 
  python-gnome2-desktop python-gobject python-gtk2 python-libxml2 
  python-numeric python-pyorbit python-selinux python-semanage python2.4 
  python2.4-minimal reiserfsprogs rtorrent scrollkeeper sed 
  shared-mime-info sharutils slocate sound-juicer spamc strace sudo 
  sun-java6-bin sysklogd sysvinit sysvinit-utils tar tcpd tcsh telnet 
  texinfo time traceroute udev unixodbc unrar unzip urlview usbutils 
  util-linux vim vim-common vim-tiny w32codecs w3m wget whiptail whois 
  wodim x11-common xbase-clients xfonts-utils xserver-xorg-core 
  xserver-xorg-input-evdev xserver-xorg-input-kbd xserver-xorg-input-mouse 
  xserver-xorg-input-synaptics xserver-xorg-video-apm 
  xserver-xorg-video-ark xserver-xorg-video-ati xserver-xorg-video-chips 
  xserver-xorg-video-cirrus xserver-xorg-video-cyrix 
  xserver-xorg-video-dummy xserver-xorg-video-fbdev 
  xserver-xorg-video-glint xserver-xorg-video-i128 xserver-xorg-video-i740 
  xserver-xorg-video-imstt xserver-xorg-video-intel xserver-xorg-video-mga 
  xserver-xorg-video-neomagic xserver-xorg-video-newport 
  xserver-xorg-video-nsc xserver-xorg-video-nv xserver-xorg-video-rendition 
  xserver-xorg-video-s3 xserver-xorg-video-s3virge 
  xserver-xorg-video-savage xserver-xorg-video-siliconmotion 
  xserver-xorg-video-sis xserver-xorg-video-sisusb xserver-xorg-video-tdfx 
  xserver-xorg-video-tga xserver-xorg-video-trident 
  xserver-xorg-video-tseng xserver-xorg-video-v4l xserver-xorg-video-vesa 
  xserver-xorg-video-vga xserver-xorg-video-via xserver-xorg-video-vmware 
  xserver-xorg-video-voodoo xsltproc xterm xutils xutils-dev yelp zip 
  zlib1g 
The following packages will be REMOVED:
  libc6{p} 
0 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 10.9MB will be freed.
The following packages have unmet dependencies:
  gnome-keyring: Depends: libc6 (>= 2.5) but it is not installable
  libkeyutils1: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libpci2: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libgnomecupsui1.0-1c2a: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libedit2: Depends: libc6 (>= 2.3.6-6) but it is not installable
  gstreamer0.10-alsa: Depends: libc6 (>= 2.5-5) but it is not installable
  mesa-utils: Depends: libc6 (>= 2.5-5) but it is not installable
  libfreebob0: Depends: libc6 (>= 2.5-5) but it is not installable
  xserver-xorg-video-rendition: Depends: libc6 (>= 2.5) but it is not installable
  libgnomekbd1: Depends: libc6 (>= 2.5-5) but it is not installable
  libatk1.0-0: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libsdl1.2debian-alsa: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libpam0g: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libpopt0: Depends: libc6 (>= 2.3.6-6) but it is not installable
  nano: Depends: libc6 (>= 2.3.6-6) but it is not installable
  ispell: Depends: libc6 (>= 2.5-5) but it is not installable
  libstdc++5: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libstdc++6: Depends: libc6 (>= 2.5-5) but it is not installable
  libusb-0.1-4: Depends: libc6 (>= 2.5) but it is not installable
  libxfixes3: Depends: libc6 (>= 2.3.6-6) but it is not installable
  alsa-tools: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libartsc0: Depends: libc6 (>= 2.5-5) but it is not installable
  shared-mime-info: Depends: libc6 (>= 2.5-5) but it is not installable
  libncurses5: Depends: libc6 (>= 2.5-5) but it is not installable
  libmagick9: Depends: libc6 (>= 2.5) but it is not installable
  xsltproc: Depends: libc6 (>= 2.5-5) but it is not installable
  libenchant1c2a: Depends: libc6 (>= 2.5) but it is not installable
  notification-daemon: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libgnomevfs2-0: Depends: libc6 (>= 2.5-5) but it is not installable
  gcalctool: Depends: libc6 (>= 2.5) but it is not installable
  libopenal0a: Depends: libc6 (>= 2.5-5) but it is not installable
  sharutils: Depends: libc6 (>= 2.5-5) but it is not installable
  vim-common: Depends: libc6 (>= 2.5-5) but it is not installable
  xserver-xorg-input-evdev: Depends: libc6 (>= 2.5-5) but it is not installable
  traceroute: Depends: libc6 (>= 2.3.6-6) but it is not installable
  xserver-xorg-video-newport: Depends: libc6 (>= 2.5) but it is not installable
  libgail18: Depends: libc6 (>= 2.5) but it is not installable
  gs-esp: Depends: libc6 (>= 2.3.6-6) but it is not installable
  python-gnome2: Depends: libc6 (>= 2.5) but it is not installable
  fakeroot: Depends: libc6 (>= 2.5-5) but it is not installable
  gnome-media: Depends: libc6 (>= 2.5) but it is not installable
  liblcms1: Depends: libc6 (>= 2.3.5-1) but it is not installable
  xserver-xorg-video-s3virge: Depends: libc6 (>= 2.3.6-6) but it is not installable
  metacity: Depends: libc6 (>= 2.3.6-6) but it is not installable
  nautilus: Depends: libc6 (>= 2.5-5) but it is not installable
  links: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libgnome2-0: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libnfsidmap2: Depends: libc6 (>= 2.5-5) but it is not installable
  unrar: Depends: libc6 (>= 2.3.6-6) but it is not installable
  bind9-host: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libblkid1: Depends: libc6 (>= 2.3.6-6) but it is not installable
  procps: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libidn11: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libgstreamer0.10-0: Depends: libc6 (>= 2.5-5) but it is not installable
  dhcp3-client: Depends: libc6 (>= 2.5-5) but it is not installable
  libwrap0: Depends: libc6 (>= 2.3.6-6) but it is not installable
  gstreamer0.10-plugins-ugly: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libpam-modules: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libraw1394-8: Depends: libc6 (>= 2.3.6-6) but it is not installable
  telnet: Depends: libc6 (>= 2.3.6-6) but it is not installable
  xserver-xorg-video-apm: Depends: libc6 (>= 2.5) but it is not installable
  libcaca0: Depends: libc6 (>= 2.3.6-6) but it is not installable
  linux-headers-2.6.21.5-rt18-odysseus: Depends: libc6 (>= 2.5-5) but it is not installable
  xserver-xorg-video-ark: Depends: libc6 (>= 2.5) but it is not installable
  libacl1: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libcomerr2: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libiec61883-0: Depends: libc6 (>= 2.3.6-6) but it is not installable
  moreutils: Depends: libc6 (>= 2.3.6-6) but it is not installable
  genisoimage: Depends: libc6 (>= 2.5-5) but it is not installable
  xserver-xorg-video-ati: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libdjvulibre15: Depends: libc6 (>= 2.5) but it is not installable
  lsof: Depends: libc6 (>= 2.5-5) but it is not installable
  libwmf0.2-7: Depends: libc6 (>= 2.5) but it is not installable
  libcompress-zlib-perl: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libselinux1: Depends: libc6 (>= 2.5-5) but it is not installable
  libxvidcore4: Depends: libc6 (>= 2.3.6-6) but it is not installable
  whiptail: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libvorbisfile3: Depends: libc6 (>= 2.5-5) but it is not installable
  xserver-xorg-video-tdfx: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libtorrent10: Depends: libc6 (>= 2.5) but it is not installable
  most: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libgail-common: Depends: libc6 (>= 2.5) but it is not installable
  xserver-xorg-video-trident: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libgnome-keyring0: Depends: libc6 (>= 2.5) but it is not installable
  xserver-xorg-video-glint: Depends: libc6 (>= 2.3.6-6) but it is not installable
  liblocale-gettext-perl: Depends: libc6 (>= 2.3.2.ds1-21) but it is not installable
  dnsutils: Depends: libc6 (>= 2.3.6-6) but it is not installable
  xbase-clients: Depends: libc6 (>= 2.5) but it is not installable
  libgsasl7: Depends: libc6 (>= 2.3.6-6) but it is not installable
  xserver-xorg-video-fbdev: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libsvga1: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libart-2.0-2: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libbz2-1.0: Depends: libc6 (>= 2.3.6-6) but it is not installable
  gnome-power-manager: Depends: libc6 (>= 2.5-5) but it is not installable
  libdbus-1-3: Depends: libc6 (>= 2.5-5) but it is not installable
  g++-4.1: Depends: libc6 (>= 2.5-5) but it is not installable
  libopencdk8: Depends: libc6 (>= 2.3.6-6) but it is not installable
  util-linux: PreDepends: libc6 (>= 2.3.6-6) but it is not installable
  unzip: Depends: libc6 (>= 2.3.6-6) but it is not installable
  perl: Depends: libc6 (>= 2.3.6-6) but it is not installable
  iputils-ping: Depends: libc6 (>= 2.5) but it is not installable
  libdbus-glib-1-2: Depends: libc6 (>= 2.3.6-6) but it is not installable
  gnome-screensaver: Depends: libc6 (>= 2.5-5) but it is not installable
  libgtksourceview1.0-0: Depends: libc6 (>= 2.3.6-6) but it is not installable
  xserver-xorg-video-v4l: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libxxf86vm1: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libcap1: Depends: libc6 (>= 2.3.2.ds1-4) but it is not installable
  mutt: Depends: libc6 (>= 2.5-5) but it is not installable
  libjack0: Depends: libc6 (>= 2.5-5) but it is not installable
  xterm: Depends: libc6 (>= 2.5-5) but it is not installable
  libconsole: Depends: libc6 (>= 2.3.6-6) but it is not installable
  xserver-xorg-video-mga: Depends: libc6 (>= 2.3.6-6) but it is not installable
  gedit: Depends: libc6 (>= 2.5) but it is not installable
  python-libxml2: Depends: libc6 (>= 2.5-5) but it is not installable
  gnome-menus: Depends: libc6 (>= 2.5-5) but it is not installable
  liblircclient0: Depends: libc6 (>= 2.5-5) but it is not installable
  gtk2-engines-pixbuf: Depends: libc6 (>= 2.5-5) but it is not installable
  scrollkeeper: Depends: libc6 (>= 2.3.6-6) but it is not installable
  dvd+rw-tools: Depends: libc6 (>= 2.3.6-6) but it is not installable
  python-numeric: Depends: libc6 (>= 2.5-5) but it is not installable
  libglu1-mesa: Depends: libc6 (>= 2.5-5) but it is not installable
  xserver-xorg-input-mouse: Depends: libc6 (>= 2.5-5) but it is not installable
  logrotate: Depends: libc6 (>= 2.3.5-1) but it is not installable
  libsocket6-perl: Depends: libc6 (>= 2.3.5-1) but it is not installable
  libdns22: Depends: libc6 (>= 2.3.6-6) but it is not installable
  mplayer: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libdns32: Depends: libc6 (>= 2.3.6-6) but it is not installable
  xserver-xorg-video-nsc: Depends: libc6 (>= 2.5) but it is not installable
  gnome-control-center: Depends: libc6 (>= 2.5) but it is not installable
  libhtml-parser-perl: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libspeex1: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libapm1: Depends: libc6 (>= 2.3.6-6) but it is not installable
  bc: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libcamel1.2-10: Depends: libc6 (>= 2.5-5) but it is not installable
  xutils: Depends: libc6 (>= 2.3.6-6) but it is not installable
  m4: Depends: libc6 (>= 2.5-5) but it is not installable
  dc: Depends: libc6 (>= 2.3.6-6) but it is not installable
  gconf2: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libbonoboui2-0: Depends: libc6 (>= 2.5) but it is not installable
  at: Depends: libc6 (>= 2.3.5-1) but it is not installable
  strace: Depends: libc6 (>= 2.3.6-6) but it is not installable
  ed: Depends: libc6 (>= 2.3.1-1) but it is not installable
  libevent1: Depends: libc6 (>= 2.5-5) but it is not installable
  libxslt1.1: Depends: libc6 (>= 2.5-5) but it is not installable
  xserver-xorg-video-vesa: Depends: libc6 (>= 2.3.6-6) but it is not installable
  python-semanage: Depends: libc6 (>= 2.5-5) but it is not installable
  perl-base: PreDepends: libc6 (>= 2.3.6-6) but it is not installable
  aptitude: Depends: libc6 (>= 2.5-5) but it is not installable
  libterm-readkey-perl: Depends: libc6 (>= 2.3.5-1) but it is not installable
  libsemanage1: Depends: libc6 (>= 2.5-5) but it is not installable
  libnspr4-0d: Depends: libc6 (>= 2.3.6-6) but it is not installable
  xserver-xorg-video-siliconmotion: Depends: libc6 (>= 2.5) but it is not installable
  libcpufreq0: Depends: libc6 (>= 2.5-5) but it is not installable
  libslp1: Depends: libc6 (>= 2.3.6-6) but it is not installable
  groff-base: Depends: libc6 (>= 2.3.6-6) but it is not installable
  whois: Depends: libc6 (>= 2.3.6-6) but it is not installable
  xserver-xorg-video-tga: Depends: libc6 (>= 2.3.6-6) but it is not installable
  xserver-xorg-video-sis: Depends: libc6 (>= 2.5) but it is not installable
  python-pyorbit: Depends: libc6 (>= 2.5-5) but it is not installable
  libnotify1: Depends: libc6 (>= 2.5) but it is not installable
  libcairo2: Depends: libc6 (>= 2.5-5) but it is not installable
  libfontconfig1: Depends: libc6 (>= 2.3.6-6) but it is not installable
  bash: PreDepends: libc6 (>= 2.3.6-6) but it is not installable
  libgnutls13: Depends: libc6 (>= 2.5-5) but it is not installable
  dhcp3-common: Depends: libc6 (>= 2.5-5) but it is not installable
  module-init-tools: Depends: libc6 (>= 2.5-5) but it is not installable
  libgpmg1: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libsmbios1: Depends: libc6 (>= 2.5) but it is not installable
  xserver-xorg-video-vga: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libdevmapper1.02: Depends: libc6 (>= 2.3.6-6) but it is not installable
  xserver-xorg-video-via: Depends: libc6 (>= 2.5) but it is not installable
  libvorbisenc2: Depends: libc6 (>= 2.5-5) but it is not installable
  fetchmail: Depends: libc6 (>= 2.5-5) but it is not installable
  libsoup2.2-8: Depends: libc6 (>= 2.3.6-6) but it is not installable
  xserver-xorg-video-s3: Depends: libc6 (>= 2.5) but it is not installable
  psmisc: Depends: libc6 (>= 2.5) but it is not installable
  python2.4-minimal: Depends: libc6 (>= 2.5) but it is not installable
  login: PreDepends: libc6 (>= 2.5-5) but it is not installable
  mtools: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libxmuu1: Depends: libc6 (>= 2.5) but it is not installable
  libtext-charwidth-perl: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libgnome-menu2: Depends: libc6 (>= 2.5-5) but it is not installable
  python2.4: Depends: libc6 (>= 2.5) but it is not installable
  libtasn1-3: Depends: libc6 (>= 2.3.6-6) but it is not installable
  gstreamer0.10-plugins-good: Depends: libc6 (>= 2.5-5) but it is not installable
  xserver-xorg-video-nv: Depends: libc6 (>= 2.5-5) but it is not installable
  gnome-terminal: Depends: libc6 (>= 2.5-5) but it is not installable
  gnomebaker: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libamrnb2: Depends: libc6 (>= 2.5-5) but it is not installable
  xserver-xorg-core: Depends: libc6 (>= 2.5-5) but it is not installable
  e2fsprogs: PreDepends: libc6 (>= 2.3.6-6) but it is not installable
  libwavpack1: Depends: libc6 (>= 2.5-5) but it is not installable
  libisccc30: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libsmbclient: Depends: libc6 (>= 2.5-5) but it is not installable
  libfribidi0: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libexpat1: Depends: libc6 (>= 2.3.6-6) but it is not installable
  gcc-4.1: Depends: libc6 (>= 2.5-5) but it is not installable
  libfam0: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libkrb53: Depends: libc6 (>= 2.5-5) but it is not installable
  xserver-xorg-video-tseng: Depends: libc6 (>= 2.5) but it is not installable
  libcdio6: Depends: libc6 (>= 2.3.5-1) but it is not installable
  abook: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libgssapi2: Depends: libc6 (>= 2.5) but it is not installable
  apt-utils: Depends: libc6 (>= 2.5-5) but it is not installable
  sun-java6-bin: Depends: libc6 but it is not installable
  tcpd: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libxxf86misc1: Depends: libc6 (>= 2.3.6-6) but it is not installable
  libavformatcvs51: Depends: libc6 (>= 2.5-5) but it is not installable
  <snip> etc etc etc
Resolving dependencies...
Unable to resolve dependencies!  Giving up...
Abort.
 
Old 07-11-2007, 04:42 PM   #6
Telemachos
Member
 
Registered: May 2007
Distribution: Debian
Posts: 754

Rep: Reputation: 59
Let me try again, a bit more seriously. Here's the description of libc6 from aptitude:
Quote:
Description: GNU C Library: Shared libraries
Contains the standard libraries that are used by nearly all programs on the
system. This package includes shared versions of the standard C library and the
standard math library, as well as many others.
If you upgrade it, you will need to upgrade your whole system to Lenny. That's not necessarily a bad thing. I've been using Debian testing every day since December (when testing was still Etch) without a hitch. Still it is less stable than stable, so if it's a production computer, you should think seriously about it.
 
Old 07-11-2007, 05:10 PM   #7
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 675

Original Poster
Blog Entries: 11

Rep: Reputation: 36
Can I get away with not upgrading the whole system to lenny? Can I download the new libc6 and install it with dpkg? Everything depends on it, it depends on almost nothing. I won't be removing it, I'll be upgrading it. I suppose that won't work?

EDIT: There are two questions here. 1) Will dpkg allow me to do it? and 2) Will my system need to be re-installed ... will it work?

Last edited by radiodee1; 07-11-2007 at 05:19 PM.
 
Old 07-11-2007, 07:19 PM   #8
Telemachos
Member
 
Registered: May 2007
Distribution: Debian
Posts: 754

Rep: Reputation: 59
As I understand it, you would break your system doing that. If you really want it that badly, check out the apt manual on how to keep a mixed system and try that. Here's a link APT manual
 
Old 07-12-2007, 12:17 AM   #9
war1025
Member
 
Registered: Jul 2006
Distribution: Debian: Squeeze AMD64
Posts: 318

Rep: Reputation: 32
yea... now that I think about it, libc6 is probably a bad package to mess up.

The app I did that with was compiz, which isn't nearly as important.
 
Old 07-12-2007, 12:28 AM   #10
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
Why not look for a backported version instead of borking up the system. Try installing this for instance: http://live.debian.net/debian/pool/m...ebian/?C=N;O=A
Or build it from source.
 
Old 07-12-2007, 05:00 AM   #11
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 675

Original Poster
Blog Entries: 11

Rep: Reputation: 36
war1025, utanja, Telemachos: Thank you for your advice. makuyl: I will probably try out the backports suggestion. I will post my progress later if I have any success. Thanks again.
 
Old 07-12-2007, 05:20 PM   #12
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 675

Original Poster
Blog Entries: 11

Rep: Reputation: 36
makuyl:

The Debian Live backport of usplash-theme-debian works great. Thanks for the info.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
libc6 phantom_cyph Linux - Software 1 06-01-2007 05:37 AM
Update libc6 zsolt_tuser Debian 3 03-23-2007 07:39 AM
libc6-dev version conflicts with libc6 in Dapper peppill Ubuntu 2 12-04-2006 01:13 PM
Woody ALPHA gcc and/or libc6.1 question jkmccarthy Debian 1 10-21-2004 07:19 PM
Update 10.0 to 10.1 RC1: disaster enryfox Mandriva 4 09-08-2004 07:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 05:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration