-   Debian (
-   -   libc6 trying to overwrite lib64 apt-get error (

xymian 12-18-2004 08:41 AM

libc6 trying to overwrite lib64 apt-get error
I have a problem with apt-get and libc6.

Today I finally got some free time to try to get my new-ish Debian box set up. I was trying to install the nvidia driver and ran into lots of set-backs. The directions on the nvidia site didn't work (for me) so I tried to apt-get install all of the nvidia .deb files. Along the way I updated and upgraded the whole system with apt-get. I am not sure where things went wrong in all of that, but now apt-get won't do anything but complain about libc6.

Here is the relevant part that describes the problem from apt-get:

Preparing to replace libc6 2.3.2.ds1-18 (using libc6 2.3.2.ds1- ...
Unpacking replacemtn libc6 ...
dpkg: error processing /var/cache/apt/archives/libc6 2.3.2.ds1- (--unpack):
trying to overwrite '/usr/lib64', which is also in package base-files
Errors were encountered while processing:
/var/cache/apt/archives/libc6 2.3.2.ds1-
E: Sub-process /usr/bin/dpkg returned an error code (1)

I am running Debian sid AMD64 port (on an AMD 3500+). I have searched the web for information or help but found nothing. I have tried
apt-get -f install
apt-get -u dselect-upgrade

I have tried to upgrade base-files. I have tried to downgrade libc6 (I know it isn't a good idea). And I have even tried to remove either libc6 or base-utils (probably a stupid move if it had worked). I have tried dozens of things for the past few hours and still get the same error messages. Can anyone give me some help in getting things back to normal?

xymian 12-19-2004 09:56 PM

I am responding to myself here.... I have managed to solve my problem (detailed above) so I thought I should write explain in case others have the same problem.

libc6 and base-files are very imporant packages so even if I could have removed either of them it would totally screw up my box and make it unworkable. The problem in my case is a bug where both of these packages are trying to update lib64. I found some information plus a solution at this link, along with the responses:

Since I have a pure64 system it is safe to do a force-overwrite like this:

dpkg --force-overwrite -i /var/cache/apt/archives/libc6_2.3.2.ds1-

(Actually the first time I typed this it didn't work - clumsy fingers perhaps. But the second time with tab-completion on the file name it worked.)

Hope this is clear enough.

Oxyacetylene 12-20-2004 01:05 PM

I had the same problem on my machine a few days ago. The packages must have been recently updated, cause I did another apt-get dist-upgrade and it upgraded everything without the error.

All times are GMT -5. The time now is 10:24 PM.