LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-12-2009, 11:23 AM   #1
The PIT
Member
 
Registered: Nov 2005
Posts: 99

Rep: Reputation: 16
Lenny Just upgraded to latest x.org


Running Lenny and everything was fine until it came along and said hey there's a new xorg. So I let it update it and I can no longer ctrl alt f1 to shut down X Windows.

ctrl alt backspace works but this is useless when the machine is running in it's kiosk mode as it just restarts the kiosk scripts.

The staff that use these machines in kiosk mode use the ctrl alt f1 to shut the machine down properly.

So how do I re-enable it??
 
Old 08-12-2009, 11:42 AM   #2
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 272Reputation: 272Reputation: 272
I think you need to add this section to xorg.conf
Code:
Section "ServerFlags"
   Option   "DontZap"      "on"
   Option   "DontVTSwitch"   "on"
EndSection
DontZap prohibits CTRL+ALT+Backspace from restarting X, DontVTSwitch prohibits CTRL+ALT+F1-F8.
 
Old 08-12-2009, 12:07 PM   #3
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Quote:
Originally Posted by The PIT View Post
Running Lenny and everything was fine until it came along and said hey there's a new xorg. So I let it update it and I can no longer ctrl alt f1 to shut down X Windows.
ctl-alt-f1 doesn't shut down the X server. It switches you to a virtual terminal called tty1. ctl-alt-f7 gets you back to your X-session.

I'm not familar with "kiosk mode" so I can't help you with the rest. Normally you would just logout from your x-session using the "End current session" item.
jdk
 
Old 08-12-2009, 12:10 PM   #4
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
Does ctrl alt del still work? Heck if I even open xterm and hit ctrl alt del it still reboots, could try that.
 
Old 08-12-2009, 12:25 PM   #5
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Quote:
Originally Posted by mushroomboy View Post
Does ctrl alt del still work? Heck if I even open xterm and hit ctrl alt del it still reboots, could try that.
Does the OP want to reboot? or just stop the X-server? I don't think I'd want to do ctl-alt-del to reboot anyway. Isn't that the equivalent of hitting the reset button? You'd run the risk of damaging your file system.

jdk

Last edited by jdkaye; 08-12-2009 at 12:27 PM.
 
Old 08-12-2009, 12:35 PM   #6
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,333

Rep: Reputation: 126Reputation: 126
CTL-ALT-DEL is an orderly reboot.
 
Old 08-12-2009, 12:52 PM   #7
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
Yeah ctrl-alt-del is different from linux/windows, they don't have hard reset in linux unless your kernel panics or you hit the reset button on the computer itself. Though even the reset button can be changed to soft reboot I believe... I had them both disabled at one time, now they just work as shutdown/reset. But ctrl-alt-del works 100% fine... I'm running xfce and hate getting the reboot option to work with regular users, so I just logout and hit ctrl-alt-del to reboot whenever I need to.
 
Old 08-12-2009, 03:03 PM   #8
The PIT
Member
 
Registered: Nov 2005
Posts: 99

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by jdkaye View Post
ctl-alt-f1 doesn't shut down the X server. It switches you to a virtual terminal called tty1. ctl-alt-f7 gets you back to your X-session.

I'm not familar with "kiosk mode" so I can't help you with the rest. Normally you would just logout from your x-session using the "End current session" item.
jdk
Yup you're right. One of the reasons why I go init 3 then pkill X to make sure it's dead.

Anyway I'll try the suggestions tomorrow and let you know what happens.
 
Old 08-13-2009, 02:48 AM   #9
The PIT
Member
 
Registered: Nov 2005
Posts: 99

Original Poster
Rep: Reputation: 16
Actually it turned out too be an invalid keyboard symbol. So thats solved.
 
Old 08-13-2009, 04:49 AM   #10
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Hi Pit,
If you're happy we're happy. Can you please click on Thread Tools button (at the top of this thread) and click on "Mark as solved".
thanks
jdk
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
no xorg.conf on latest release (lenny 5.02) abd_bela Debian 9 08-20-2009 02:51 AM
LXer: How-To: Compile and Install Latest VLC in Debian Lenny LXer Syndicated Linux News 0 08-12-2009 05:41 AM
LXer: How-To: Install the Latest Wine Release in Debian Lenny LXer Syndicated Linux News 0 03-24-2009 10:30 AM
Lenny on latest iBook trouble UltimateDom Debian 5 01-23-2009 01:53 PM
How I've dist-upgraded etch->lenny->sid without problems aleTT Debian 15 08-20-2008 04:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 08:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration