LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 10-12-2004, 10:55 AM   #1
sebas_turu
LQ Newbie
 
Registered: Oct 2003
Location: Argentina
Distribution: Debian
Posts: 7

Rep: Reputation: 0
Smile kernel panic: VFS: Unable to mount root fs in 08:02


Hi everybody.
I need some help with kernel compiling, Iam installed a Debian Woody Stable in my box.
There is something I doing wrong or something Its missing me up.
Tried to compile the kernel 2.4.26 thousands times but I know the problem is the support of SCSI Module.
my fstab is:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
/dev/sda2 / ext3 errors=remount-ro 0 1
/dev/sda1 none swap sw 0 0
proc /proc proc defaults 0 0
/dev/fd0 /floppy auto user,noauto 0 0
/dev/cdrom /cdrom iso9660 ro,user,noauto 0 0
/dev/sda3 /home ext3 defaults 0 2

look at my root mount point and my type ext3 in /dev/sda2!!



I do make menuconfig in /usr/src/linux and set the SCSI Support as <M> also the SCSI disk support <M>.
then the SCSI low level Drivers Im using a BusLogic SCSI Card so I set <M> in the BusLogic support Card.
Then I go to the Fil Systems and I set staticly the next:
* "Virtual memory file support"
* "Ext3 Journalling file system support"
* "Second extended fs Support (etx2)"
and nothing else with de file systems

in the "Block device" put the flag * in RAM disk support - initial ram disk (initrd) support with 4096 size.

When I finish this I do:

make dep;make clean;make bzImabe;cp System.map /boot/System.map-2.4.26; cp arch/i386/boot/bzImage /boot/vmlinuz-2.4.26;make modules;make modules_install; mkinitrd -o /boot/initrd-2.4.26.img /lib/modules/2.4.26

Then
I create the symblinks in my / (root)
ln -s /boot/vmlinuz-2.4.26 /vmlinuz
ln -s /boot/initrd-2.4.26.img /initrd.img

and my lilo.conf file is:

lba32
boot=/dev/sda
root=/dev/sda2
install=/boot/boot-menu.b
map=/boot/map
delay=20
prompt
timeout=100
vga=normal
default=Linux

image=/vmlinuz
label=Linux
initrd=/initrd.img
read-only

image=/vmlinuz.old
label=LinuxOLD
read-only
optional

I do the lilo command when I modify anything in my lilo.conf file.
And even do rdev for looking my root partition, to be sure at all.
And when the Debian it needs to look in the /etc/modules.conf so I create a file in /etc/modutils/scsi and add the line alias scsi_hostadapter BusLogic.
Then I run the update-modules command to add the line in the modules.conf file.

so after all that...!!!
I still get the same error...!!!
kernel panic: VFS: Unable to mount root fs in 08:02
 
Old 10-12-2004, 11:12 AM   #2
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
quick check: make sure you have devfs in pseudo file systems enabled (not needed to boot automatically if you use udev, but without devfs, though it's obsolete, my kernel will fail to boot even if I do use udev), and that you have support for your fs type (like ext3) and so on...and that your machine architecture is correct (either i386 or, if you have pentium, use pentium, if athlon, then athlon, and so on...)
 
Old 10-12-2004, 12:05 PM   #3
sebas_turu
LQ Newbie
 
Registered: Oct 2003
Location: Argentina
Distribution: Debian
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by b0uncer
quick check: make sure you have devfs in pseudo file systems enabled (not needed to boot automatically if you use udev, but without devfs, though it's obsolete, my kernel will fail to boot even if I do use udev), and that you have support for your fs type (like ext3) and so on...and that your machine architecture is correct (either i386 or, if you have pentium, use pentium, if athlon, then athlon, and so on...)
Well I checked that and its not enabled, then my arquitecture is fine, and Ive enabled the Compressed ROM file support (I think that is the cramfs support but for better compression initrd)
Now I get a diffrent error, when load a kernel enter in a loop with the line kmod: failed to exec /sbint/modprobe -s -k binfmt-0000, errno = 8.

all this when check staticly the Compressed ROM file Support
 
Old 10-12-2004, 02:17 PM   #4
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
i suggest compiling in scsi support and not building a initrd kernel. if you need initrd read the krenel-related docs in /usr/share/doc.
i suggest *not* using /usr/src/linux use /usr/src/kernel-source-2.4.26 (the origional tar -jxf output):
patch as needed
make menuconfig (or whatever)
make-kpkg clean
make-kpkg --revision=mypc.001 kernel_image
move old modules in /lib/modules away
dpkg -i kernel-image-2.4.26_mypc.001_i386.deb

sl mritch.
 
Old 10-13-2004, 05:18 AM   #5
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
to edit my previous post a bit:

it seems like I have a bug or something in this distro..don't know yet. I understand that devfs, as it's obsolete now, should not be needed if using udev. however, I can't boot my kernels if I don't include devfs, though I don't use it but udev..so it's a checkpoint at least. I am not quite sure what causes this behaviour on my kernels, but I guess the problem disappears at least when updates come...meantime, I try to study this.
 
Old 10-14-2004, 10:28 AM   #6
sebas_turu
LQ Newbie
 
Registered: Oct 2003
Location: Argentina
Distribution: Debian
Posts: 7

Original Poster
Rep: Reputation: 0
Well then I am going to try it, check the devfs but really dont know whats the problem, if I compile with static SCSI support I havent got any trouble. But Im interisting to try anothers methods of compiling.

Thanks a lot!

Sebastian
 
Old 10-14-2004, 06:26 PM   #7
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
just an idea...

i once had troubles booting from scsi with devfs. but it was a cd-distribution made with bootcdwrite and the mobo didn't support the scsi-bios. since devfs uses the /dev/scsi/host1/bus0/target2/lun0/part1 thing you may try giving this for root= instead of /dev/sdx.

sl mritch.
 
Old 10-15-2004, 02:35 AM   #8
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Re: kernel panic: VFS: Unable to mount root fs in 08:02

Quote:
Originally posted by sebas_turu
Hi everybody.
I need some help with kernel compiling, Iam installed a Debian Woody Stable in my box.
There is something I doing wrong or something Its missing me up.
Tried to compile the kernel 2.4.26 thousands times but I know the problem is the support of SCSI Module.


I do make menuconfig in /usr/src/linux and set the SCSI Support as <M> also the SCSI disk support <M>.
then the SCSI low level Drivers Im using a BusLogic SCSI Card so I set <M> in the BusLogic support Card.
I think you should be including these drivers with the option Y. Using M means that you have to load the drivers after boot with modconf. Since you cannot boot without them you won't get to the stage of being able to insert them.

Quote:
When I finish this I do:

make dep;make clean;make bzImabe;cp System.map /boot/System.map-2.4.26; cp arch/i386/boot/bzImage /boot/vmlinuz-2.4.26;make modules;make modules_install; mkinitrd -o /boot/initrd-2.4.26.img /lib/modules/2.4.26

Then
I create the symblinks in my / (root)
ln -s /boot/vmlinuz-2.4.26 /vmlinuz
ln -s /boot/initrd-2.4.26.img /initrd.img

and my lilo.conf file is:

lba32
boot=/dev/sda
root=/dev/sda2
install=/boot/boot-menu.b
map=/boot/map
delay=20
prompt
timeout=100
vga=normal
default=Linux

image=/vmlinuz
label=Linux
initrd=/initrd.img
read-only

image=/vmlinuz.old
label=LinuxOLD
read-only
optional
Instead of doing a symlink to the initrd.img just use the instruction in LILO;
initrd=/boot/initrd-2.4.26.img
I found grub much better at handling new kernels.
Hope this helps

Last edited by TigerOC; 10-15-2004 at 02:36 AM.
 
Old 11-08-2004, 10:13 PM   #9
raiceanne
LQ Newbie
 
Registered: Nov 2004
Posts: 1

Rep: Reputation: 0
Unhappy kernel panic

i got the following error message:


EXT3-fs: ide0(3,3): couldn't mount because of unsupported optional features (8000800).
mount: wrong fs type, bad option, bad superblock on /dev/hda3. or too many mounted file systems
pivot_root: Device or resource busy
umount: /.initrd/proc: not found
umount: /.initrd: not found
rmdir: not found
EXT2-fs: ide0(3,3):couldn't mount because of unsupported optional features (8000804)
EXT3-fs: ide0(3,3):couldn't mount because of unsupported optional features (8000800)
Kernel panic: VFS: Unable to mount root fs on 03:03


kindly help me.. please..

Last edited by raiceanne; 11-09-2004 at 12:08 AM.
 
Old 11-09-2004, 05:45 AM   #10
sebas_turu
LQ Newbie
 
Registered: Oct 2003
Location: Argentina
Distribution: Debian
Posts: 7

Original Poster
Rep: Reputation: 0
Re: kernel panic

Quote:
Originally posted by raiceanne
i got the following error message:




EXT3-fs: ide0(3,3): couldn't mount because of unsupported optional features (8000800).
mount: wrong fs type, bad option, bad superblock on /dev/hda3. or too many mounted file systems
pivot_root: Device or resource busy
umount: /.initrd/proc: not found
umount: /.initrd: not found
rmdir: not found
EXT2-fs: ide0(3,3):couldn't mount because of unsupported optional features (8000804)
EXT3-fs: ide0(3,3):couldn't mount because of unsupported optional features (8000800)
Kernel panic: VFS: Unable to mount root fs on 03:03


kindly help me.. please..
Can you post me your fstab, It seems this kind of error due to maybe you forgot to compile the right fs for your linux, perhaps the fs that youre using is ext3 and forgot to compile ext2 fs, I dont Know exactly.
I need more details about your linux box. fstab and what items do you selected in the block part of the kernel configuration


C-ya
 
Old 01-21-2008, 01:04 AM   #11
blanchae
LQ Newbie
 
Registered: Jan 2008
Posts: 1

Rep: Reputation: 0
Cart before the horse?

I had a similar problem where I tried to mount my ide drive using module support.

Kernel Panic vfs: unable to mount root fs on 03:03

I could boot to Linux (previous kernel) no problem using the ide as part of the kernel (y in config kernel) but when I selected it as a module and recompiled the kernel, it choked (m in config kernel).

I figure it had to do with trying to load a module on a root fs that wasn't mounted yet because the module wasn't loaded - hence the subject line.

An alternative is to run initrd (initial ram disk) using your boot loader or at the boot command line. Which seems too complicated for me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Panic: VFS: Unable to mount root fs on 09:02 verbali Linux - Hardware 8 02-24-2004 06:11 PM
Kernel panic: VFS: Unable to mount root cmlo Linux - Software 4 05-20-2003 02:25 AM
Kernel panic: VFS: Unable to mount root cmlo Linux - Newbie 3 05-17-2003 07:55 PM
Kernel panic : VFS : Unable to Mount root FS abinash_y Linux - Newbie 6 09-05-2002 02:58 AM
Kernel Panic: VFS: Unable to mount root fs on 09:02 verbali Linux - General 6 05-26-2002 02:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 05:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration