-   Debian (
-   -   Kernel panic - ReiserFs (

nogetfx 05-21-2008 10:06 AM

Kernel panic - ReiserFs
I'm running Debian testing on my laptop, which also have a periodic HW error. The error have frozen the system, forcing me to kill the power. I believe that have messed up my filesystem and when I boot get a kernel panic, even in single mode. The system is setup with a separate /boot partiion and then a LVM partition, split into root, home and misc partition.
I would prefer to recover the whole system, but I would settle gain access to the /home on the lvm partition.
I've tried:
*) to boot on a Debian CD in rescue mode and hoped to run shell in the root partition. In other cases I'd luck with rescuing a system, but it fails.
*) to boot up on the newest Knopppix Cd, running pvscan and vgimport. But because the Volume Group isn't exported and fails. The vgimport command doesn't support --force as suggested elsewhere. I've tried with a Ubuntu 8.x, but it didn't supported lvm.

My next ideas is to try with live-cd, where the vgimport supports --force, if anyone can confirm that it works. Otherwise try some sort of filesystem tool-cd and check the filesystem. But I'm afraid to make a even bigger mess.

Panic Error:
ReiserFs: warning: is_leaf: item location seems wrong (second one): *3.6* [197 1226 0x1 IND], item_len 156, item_location 1388, free_space(entry_count) 0
ReiserFs: dm-1: warning: vs-5150: search_by_key: invalid format found in block 520574. Fsck?
ReiserFs: dm-1: warning: vs-13070: reiser_read_locked_inside: i/o failure occurred trying to find stat data of [197 532 0x0 SD]
run-init: /sbin/init: Permission denied
Kernel paninc - not syncing: Attempted to kill init!

oskar 05-22-2008 08:01 AM

Boot with a live-cd and do an fsck
I believe it's 'reiserfsck [device/partition]' for reiserfs.

Just make sure you've got the right partition and that it's not mounted:
fdisk -l
To see which one it is.
- Between distributions an ide disk might show up as hdx, on others as sdx - so check again from the live cd!
cat /etc/mtab
to make sure it's not mounted.

nogetfx 05-22-2008 04:59 PM


Originally Posted by oskar (Post 3161302)
Boot with a live-cd and do an fsck
I believe it's 'reiserfsck [device/partition]' for reiserfs.

Thanks for your reply. Before I can scan, I need to import the LVM volume group. Which I can't cause the volume group isn't exported, so I bit stuck there.

All times are GMT -5. The time now is 05:10 AM.