LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-17-2005, 12:05 AM   #1
BrianHenderson
Member
 
Registered: Aug 2004
Location: Oregon, USA
Distribution: Ubuntu 6.06; Debian Testing
Posts: 40

Rep: Reputation: 15
Kernel Panic - init - arith: syntax error


I just installed the .deb packages on http://home.comcast.net/~canez/d610/ (linked to on linux-laptop.net) for kernel 2.6.12 and the network .deb's and now none of my kernels will boot because of this error:

Code:
/sbin/init: 399: arith: syntax error: "0xv/sda4"
I booted a live cd and looked at /boot/grub/menu.lst and /etc/fstab to see if either of those had changed to this odd "0xv/sda4", but they were as before (root=/dev/sda3)

I am at a loss as to where I should be looking for a fix, as google does not seem to turn up anything, and searching here gave nothing related. Any suggestions?
 
Old 08-17-2005, 12:47 AM   #2
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
I don't have much in the way of suggestions, but I can tell you that it is not a grub problem. Your error specifically says that init started (or couldn't start) and exited with an error. This means that the kernel has been loaded into memory and run. I looked for similar errors on the web, and some of them are caused by bad initrd (though I can by no means tell you that yours is).

More likely, it really is a "syntax error" (or at least a misspelling). I can't find any reference online to "0xv"; I'm certain that this should be "dev". I'd check other files in /etc for the phrase "0xv/sda4". You may find this lurking in a file such as inittab or fstab.

You may also want to try to remove the offending package. From your live CD (knoppix for example), you can try a chroot. From the command prompt, it goes something like:
# mount /mnt/sda1 (or whatever)
# mount --bind /proc /mnt/sda1/proc
# mount --bind /dev /mnt/sda1/dev (you usually don't need this. In your case it's possible, but still unlikley. But it can't hurt)
#chroot /mnt/sda1

At this point, the terminal that you are on is pretending that the root partition is /mnt/sda. This allows you to do just about anything you want or need to do or run. It is very useful in uninstalling programs for example (because the path to everything is correct).

If you don't bind /proc, you may get a lot of harmless errors. The reason I suggest you bind /dev is that your error is device related. There is a very low, but possible chance that the uninstaller will need to see the devices.

As far as uninstalling packages from the command line is concerned, don't ask me. I'm not real strong on my debian. I do know that this is how you can do it though.
 
Old 08-17-2005, 05:16 PM   #3
BrianHenderson
Member
 
Registered: Aug 2004
Location: Oregon, USA
Distribution: Ubuntu 6.06; Debian Testing
Posts: 40

Original Poster
Rep: Reputation: 15
I'm not sure what was wrong, but I figured that installing a kernel .deb broke it, so maybe installing one of debian's kernels would fix it and it did.

So, I did the mounting (replacing with my device names) and running
Code:
chroot /mnt/hda3 /bin/bash
because it whined about not finding zsh, and after editing /etc/fstab back to hda for the 2.4 kernel (under 2.6 my SATA hard drive becomes sda), I was able to install the debian 2.4 kernel and now am booted into the 2.6.12 kernel I was trying to get into in the first place.

This all was done on the gentoo-based System Rescue CD x86 0.2.15 which is 2.4 based.

Thanks.

Last edited by BrianHenderson; 08-17-2005 at 05:21 PM.
 
Old 08-18-2005, 03:47 AM   #4
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
Your welcome. Thanks for posting your results!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Panic: No Init Found Try Passing Init=option To Kernel Bakame Mandriva 7 03-14-2004 02:37 PM
kernel panic: no init found. Try passing init= option to kernel rroorroo Red Hat 7 03-07-2004 04:19 PM
init relocation error & kernel panic Nico Linux - General 1 12-05-2003 05:54 PM
error "Kernel panic: No init found. Try passing init= option Anauj0101 Linux - Newbie 3 05-06-2003 10:18 PM
Compiled own kernel and got: Kernel panic: No init found. Try passing init= option to fbl Linux - General 12 01-14-2003 03:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 04:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration