LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   kernel doesnt recognize all RAM (https://www.linuxquestions.org/questions/debian-26/kernel-doesnt-recognize-all-ram-754615/)

j1alu 09-12-2009 06:47 AM

kernel doesnt recognize all RAM
 
i compiled a stock debian-kernel, changed it a bit and removed some stuff. As its the first time i followed a howto and needed some help. But finally it did work.

Yesterday i ran htop and instead of recognizing all RAM it does only recognize 1/4 % .

One of you has got an idea? Its high above me.
(99% of whats getting asked is babel to me. I hit ? read it and follow the advice: say N if...say Y if)

thank you

ps: i changed an entry where i was asked if i would have got 64GB of Ram. I guess somewhere in that region i needa search for the culprit?

atom 09-12-2009 09:25 AM

How much RAM do you have, and what processor? What architecture (32 or 64-bit) debian did you install?

j1alu 09-12-2009 09:39 AM

model name : Intel (R) Celeron(R) CPU 420 @1.60GHz
32 bit
4GB Ram

i ran another build and in menuconfig:
Processor types and features
High Memory support
i found the 64GB option. i set it to no, but theres also an option to set it to 4GB. this time i choose that. the build is running and i hope/guess that was my fault.

on the why i didnt choose the 4GB? i dont know. i read a lot bout 64bit-system the last days and that might have confused me.

i`ll report back if that was the problem, but only edit this post.

greetings and thanks

j1alu 09-12-2009 09:39 AM

yep, that was the problem. all fine now.
thanks again


All times are GMT -5. The time now is 09:07 PM.