-   Debian (
-   -   Kernel 2.6.5 -> no modules loaded (

Spheerke 04-07-2004 02:58 AM

Kernel 2.6.5 -> no modules loaded
Hello all,

i have this very annoying problem, and am going crazy for spending hours of trial and error on this the last 2 days...

I had a debian 3.0rc2 woody install, did
apt-get update
apt-get dist-upgrade
to upgrade dist to sarge

Then downloaded kernel 2.6.5 source, meeting all software requirements, performed
apt-get install module-init-tools
make mrproper
make menuconfig
make bzImage
make modules
make modules_install
cp arch/... blah to /boot, same for and ln -s ...
/sbin/generate-modprobe.conf /etc/modprobe.conf
edit /etc/lilo.conf

and reboot.

But when i boot into the newly added kernel 2.6.5, no modules are loaded. When i perform a lsmod it just gives me the header with module name etc, but none is in there.

Also during boot errors are reported about eth1 being nonexistent device, same for the aliases for the terminals etc (therefore really pointing to the modprobe.conf/modconfig.conf as being the cause?)

I've found info on the net about the same problem combined with "QM_MODULES" not implemented, and this is solved by installing module-init-tools. But for those other persons installing that fixed their empty modules list, apparently for me it just fixed the error report but i still remain with the empty list...

Anyone with the same problem or can help me out?


sims 04-07-2004 07:34 AM

Try doing it "the debian way".

This howto may be helpful:

ykhov 04-07-2004 10:34 AM

I followed the instructions last night. Everything worked perfect. This one is better because it uses apt-get.

Spheerke 04-07-2004 12:05 PM

Gonna try those later on tonight. Already upgraded to sid and then put kernel 2.6.4-1 into place and with that one is do have my modules loaded but still no network interface... gonna look up the error later

Thx in advance

tsitras 04-07-2004 09:05 PM

the answer is simpler than that. you have to install module-init-tools.
apt-get install module-init-tools.
if you can not find them:

All times are GMT -5. The time now is 06:39 PM.