-   Debian (
-   -   kernel + cifs = Send error in read (

elfoozo 04-08-2006 12:09 AM

kernel + cifs = Send error in read
I upgraded kernels earlier this week by using's full src of 2.6.16-1 and my .config file from my old kernel. I'm not using modules and I compile all my known hardware staticly.

My previous kernel was 2.6.13-1. I've verified CIFS support was still set "on" in my .config file and tonight I recompiled again just to be sure.

I can still mount -t cifs //Server01/my_share /mnt/data -o user=me and I've been mounting/reading/writing fine in earlier kernels. I can see files listed but when I try to access the data I now get:

CIFS VFS: Send error in read = -13

I see these errors in dmesg and syslog. Any tips on how you would troubleshoot this?

gmcmaster 04-09-2006 08:52 AM

try -t smbfs

elfoozo 04-09-2006 10:26 PM

Unfortunately smbfs mounting has never worked for me in any 2.6 kernel due to the

cli_negprot: SMB signing is mandatory and we have disabled it.
1391: protocol negotiation failed

type errors. I've seen this particular signing error in this forum alot but never a solid resolution when I had tried smbfs mounting. CIFS was the recommended fix and CIFS still works in 2.6.13 for me when I boot back to it.

When I went from 2.6.13 to 2.6.16 I copied my 2.6.13 .config into 2.6.16's tree and went at make menuconfig. Should that procedure work fine or did I maybe hose something in the config process?

All times are GMT -5. The time now is 09:34 AM.