LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-07-2004, 02:31 PM   #1
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,241

Rep: Reputation: 77
kdm doesn't load in Sarge


I just installed Debian Sarge and selected KDE and KDM. During boot up, it says KDM is being loaded. The screen goes blank for a couple of seconds and then I am left with a text prompt. If I log in as root and type "kdm", then KDM will open, but it won't open automatically during boot up. If I install GDM, it loads automatically with no problem, but when I switch back to KDM, it fails. Is there a problem with the KDM package currently, or am I missing something?

Last edited by m_yates; 08-09-2004 at 07:16 AM.
 
Old 08-07-2004, 03:29 PM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,617

Rep: Reputation: 103Reputation: 103
Re: kdm doesn't load in Sarge

Quote:
Originally posted by m_yates
I just installed Debian Sarge and selected KDE and KDM. During boot up, it says KDM is neing loaded. The screen goes blank for a couple of seconds and then I am left with a text prompt. If I log in as root and type "kdm", then KDM will open, but it won't open automatically during boot up. If I install GDM, it loads automatically with no problem, but when I switch back to KDM, it fails. Is there a problem with the KDM package currently, or am I missing something?
That almost sounds like the video card is not getting initialized properly or you are missing kde3 in your .wmrc. And you may want to make sure when you enter KDE from the KDM login screen that you have selected kde3 from the session types menu not just used the default that is preselected.
 
Old 08-09-2004, 07:15 AM   #3
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,241

Original Poster
Rep: Reputation: 77
After searching, I found that this is Bug #240027 "KDM does not start correctly on boot" To quote from the bug page:
Quote:
The problem is that kdm_config blocks when reading /dev/random.

AFAIK, the kernel entropy pool is fed with random events coming from
disk seeks, keyboard input and mouse motions. When the entropy pool is
empty, read accesses to /dev/random will block. Therefore, on a diskless
workstation, kdm_config (and kdm which is waiting for its child to
complete) will block until someone types something on the keyboard.

/dev/urandom is considered less secure than /dev/random (man 4 random),
but never blocks.

As a fix for this kind of situation, in the [General] part of
/etc/kde3/kdm/kdmrc, put :
RandomDevice=/dev/urandom
I don't fully understand the above quote, but after putting "RandomDevice=/dev/urandom" in /etc/kde3/kdm/kdmrc, KDM loads up as it is supposed to. I don't know why that line is not included in the kdmrc file by default.

Last edited by m_yates; 08-09-2004 at 02:22 PM.
 
Old 08-09-2004, 09:49 PM   #4
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,241

Original Poster
Rep: Reputation: 77
Well, I spoke too soon. It appeared that making the change fixed KDM, but it did not. The problem appears intermittent. Anyone have any ideas? GDM loads up fine, so I don't think it is an X windows problem.
 
Old 08-09-2004, 09:58 PM   #5
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,241

Original Poster
Rep: Reputation: 77
After checking kdm.log, it revealed some errors about the mouse. I added "psmouse" and "mousedev" to /etc/modules and this fixed the problem. It is strange that it is not an issue with GDM and the mouse was actually working fine without these drivers. Anyhow, it appears to be fixed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE and KDM won't load scheidel21 Debian 7 09-25-2005 02:16 AM
KNOPPIX to load or not to load, quite the enigma... wolfster306 Linux - General 4 09-16-2005 05:16 AM
Adding kdm to init.d so LFS boots to kdm StevePhM Linux From Scratch 4 08-08-2005 09:49 PM
Where Sarge Needs Work (some questions too) + Where Sarge Rocks out loud too. ilyanep Debian 6 09-13-2004 05:36 PM
Need help configuring KDM on MDK10C so that it is like KDM on 9.2 bhtooefr Mandriva 0 05-06-2004 01:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 05:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration