-   Debian (
-   -   KDE Kio slave (

powadha 03-22-2006 06:57 PM

KDE Kio slave
I'm trying to get my bluetooth dongle working and am almost there. I can receive files from the other pc but I'm still working on one thing I can't solve.

Whenever I want to open bluetooth:/ or sdp://device/ I get an error that the url is not correct. Browsing the kdebluetooth site I have the idea that this has to do with somw kio slave. I have about everything in apt related to kio installed but to no reveil.
Any clue on what to install to get this working in KDE?


dracae 03-23-2006 12:39 AM

kio slave is a switch given to one of the other binaries included with kde. e.g. kde -kio_slave..etc
I don't know which one it is as I don't have kde installed anywhere.
ps aux | grep kio

nx5000 03-23-2006 04:46 AM

you need to install kdebluetooth

powadha 03-23-2006 11:41 AM

Well, when actually I have kdebluetooth installed and most parts are working except for the kio parts...I'll keep looking


rothchild 03-28-2006 04:47 PM

I'm having this 'malformed url' problem too, bluetooth still works in that I can push files from my phone and they are received but when I try 'bluetooth:/' or 'sdp:/' I get a malformed url message.

I have purged and re-installed all relevant bluetooth / affix files and Konqueror but it's still doing the same thing - does anyone have any tips as to where I should be looking for a clue as to what has gone wrong?


rothchild 03-29-2006 03:28 AM

Oh yeah I should probably add that this is on Sid with a Broadcom USB Bluetooth dongle.

Powadha, did you by any chance try to use one of the debianised 'automatix' scripts that are knocking about? It's the only thing I can think of that might have done it.

It all still works properly under Etch on my laptop.

powadha 03-29-2006 10:53 AM

Haven't tried those. I have seen a post in the mailarchives on kdebluetooth stating the same problem (recent mail). No replies were made though...

rothchild 04-07-2006 08:53 AM


Have you had any luck with this? It is still not working for me even through the recent upgrade to KDE 3.5.2

If anyone could point me towards what I need to to to even just find out what is wrong I'd be eternally grateful it's a pain in the proverb to send all my photos from my phone rather than just browsing to them and copying them in.


rothchild 04-13-2006 07:22 AM

Not a solution as yet but a step in the right direction:

Glad I'm not the only one and it appears it might not be just a debian problem:


powadha 04-24-2006 04:53 PM

Source: kdebluetooth
Source-Version: 0.99+1.0beta1-8

We believe that the bug you reported is fixed in the latest version of
kdebluetooth, which is due to be installed in the Debian FTP archive:

to pool/main/k/kdebluetooth/kdebluetooth-irmcsync_0.99+1.0beta1-8_i386.deb
to pool/main/k/kdebluetooth/kdebluetooth_0.99+1.0beta1-8.diff.gz
to pool/main/k/kdebluetooth/kdebluetooth_0.99+1.0beta1-8.dsc
to pool/main/k/kdebluetooth/kdebluetooth_0.99+1.0beta1-8_i386.deb
to pool/main/k/kdebluetooth/qobex_0.99+1.0beta1-8_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software

Well, sounds promising, now we have to wait till this version gets in Sid!

rothchild 04-25-2006 04:43 AM

Yeah I saw that go up yesterday - Roughly how long does it take for the package to float around all the servers etc? I can still only find the 1-7 version (yes I'm impatient!)


rothchild 04-25-2006 11:23 AM

It's 4.30 BST, the goods are in the repository and I can confirm that KDEBluetooth is now functional in Sid again hooorah!


powadha 04-27-2006 02:04 AM

Same here!

All times are GMT -5. The time now is 01:46 PM.