LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 01-03-2015, 12:49 AM   #1
newinubuntu
Member
 
Registered: Jan 2015
Location: India
Distribution: Ubuntu, RHEL
Posts: 37

Rep: Reputation: Disabled
Installing lower version of GCC in ubuntu


I have ubuntu 12.04..due to my project work, i need to install lower version of gcc-4.3. please help me..
 
Old 01-03-2015, 02:07 AM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 17
Posts: 9,005
Blog Entries: 14

Rep: Reputation: 1107Reputation: 1107Reputation: 1107Reputation: 1107Reputation: 1107Reputation: 1107Reputation: 1107Reputation: 1107Reputation: 1107
Hi: & Welcome to Linux Questions.

I checked on my sytem on the version of gcc.
Code:
gcc --version
gcc (Ubuntu 4.8.2-19ubuntu1) 4.8.2
Copyright (C) 2013 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
You should first check and see what version you do have by running gcc --version in your terminal.
http://www.linuxquestions.org/questi...ackage-237772/

I looked in my Synaptic Package Manager and the earliest version of gcc that I found was 4.6. I didn't see 4.3 listed.
I looked in the Ubuntu Package Search and gcc 4.3 is only available for Ubuntu 10.04 which is not supported anymore.
http://packages.ubuntu.com/search?keywords=gcc-4.3

You can look here also.
http://packages.ubuntu.com/precise/

Installing older packages could cause conflict or may not be available.
Because of the libraries involved installing an older version may not be the best idea.
http://earthwithsun.com/questions/59...-using-apt-get

Are you sure you want to install an older version?

Last edited by Ztcoracat; 01-03-2015 at 02:16 AM.
 
Old 01-03-2015, 03:45 AM   #3
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
If prebuilt packages are not available it's easy to build gcc from source. Just grab the latest source of gcc-4.3.x from http://gcc.gnu.org and build it.

1) Untar the sources

2) ./configure --prefix=/opt/gcc-4.3

3) make

4) make install

Remember you need a complete gcc toolchain for building.

Usually gcc itself and binutils.
 
1 members found this post helpful.
Old 01-03-2015, 02:13 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,400

Rep: Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584
why not just hack your code .
---- you are writing it what not just edit it to make it in compliance with the OLD 4.3 standard ----


or
bring it up to gcc 4.9 standards seeing as you are writing the code

https://gcc.gnu.org/onlinedocs/
 
1 members found this post helpful.
Old 01-03-2015, 04:28 PM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2018 CentOS6.10 CentOS7.5 + 50+ other Linux OS, for test only.
Posts: 17,126

Rep: Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491Reputation: 3491
@newinubuntu : Welcome to LQ.

? Which application is it that you think will require gcc-4.3 ?
 
Old 01-13-2015, 01:14 AM   #6
newinubuntu
Member
 
Registered: Jan 2015
Location: India
Distribution: Ubuntu, RHEL
Posts: 37

Original Poster
Rep: Reputation: Disabled
@knudfl

I required older version for running ns-bgp in my machine...i solved my problem..thank you all for your co-operation..
 
Old 01-13-2015, 08:06 PM   #7
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,628

Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
If you have solved the problem, state how you did so.

After that mark the thread solved in the Thread Tools menu on the bar above your first post.

That way someone using forum search tools can find this thread and see that it is solved, and how it was solved if they have a similar need.
 
1 members found this post helpful.
Old 01-16-2015, 12:49 AM   #8
newinubuntu
Member
 
Registered: Jan 2015
Location: India
Distribution: Ubuntu, RHEL
Posts: 37

Original Poster
Rep: Reputation: Disabled
@widget
I am really very sorry,i m new in this forum so please apologize me..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
hi..i need gcc 4.3 version..currently m having gcc 4.6 on ubuntu 12.04 plz help vishakha singhal Linux - Newbie 3 05-16-2014 01:03 PM
Downgrade GCC to lower version Freelander Red Hat 1 10-02-2007 11:40 PM
Replacing GCC to lower version sjcoder Linux - Software 3 08-16-2007 03:49 PM
installing another version of gcc kulmis Linux - Newbie 3 06-21-2005 02:24 PM
Compling on a higher version and executing on a lower version aditya_shah Programming 0 10-01-2003 12:48 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 08:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration