-   Debian (
-   -   Installing Google Earth on Sid 64 bit. (

273 07-20-2012 08:08 PM

Installing Google Earth on Sid 64 bit.
I cannot install Google Earth under Sid at the moment because ia32-libs-gtk depends upon ia32-libs-gtk-i386, which does not exist.
Does anyone know a workaround for this until multilib is finished?
Could I grab the old ia32-libs-gtk files from somewhere and use them somehow, for example?
I have since learned that the 32 bit .deb file is the one to install (since Sid is now multilib), but there is a problem with lsb-core:i386 dependency. It would be good to hear from anyone who has managed to get google earth running under 64 bit Sid.

tux9656 09-24-2012 05:08 PM

I know this thread is a couple of months old, but if you are still having this issue, try installing the ia32-libs-gtk package from testing/wheezy. I am currently running sid and have testing/wheezy's ia32-libs-gtk installed and everything is working just fine. Also, most of the time when a package cannot be installed in sid due to broken dependencies, you can install the version from testing and it will work. To be able to use apt to install packages from testing, just add a line to /etc/apt/sources.list for testing and then to install the package from testing type, "apt-get install -t testing package" minus the quotation marks of course.

273 09-24-2012 05:32 PM

Thanks, that's worked though it has left me with the system complaining about:

# apt-get upgrade
Reading package lists... Done
Building dependency tree     
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 google-earth-stable:i386 : Depends: lsb-core:i386 (>= 3.2) but it is not installed
E: Unmet dependencies. Try using -f.

and running a -f install wants to remove a load of packages including Google Earth.

tux9656 09-24-2012 06:37 PM

You should install the google earth amd64 package, not google-earth-stable:i386. Debian may now be multilib, but it's multilib support is still a little flaky and the google earth packages are meant for debian 6, which is not multilib.

273 09-24-2012 06:49 PM

Thanks, that works perfectly.
Now I have to work out why my Space Navigator doesn't seem to be recognised by Google Earth...

tux9656 09-24-2012 06:55 PM

You're welcome. What's space navigator?

273 09-24-2012 07:02 PM


Originally Posted by tux9656 (Post 4788416)
You're welcome. What's space navigator?

It looks like a large knob but is actually a six degrees of freedom (up/down, left/right, forwards/backwards, pitch, yaw and roll) joystick used to navigate in 3D applications.
I bought it originally when I used Second Life but Google Earth gained support for them under Linux. Oddly though while it works with virtualised Fedora or Ubuntu it doesn't work with real Debian.
It's probably me misspelling a simlink or something though.

273 09-25-2012 05:13 PM

Space Navigator is working now too, not sure whether I did something in the wrong order or followed the wrong instructions the first time.
Either way it's great to have Google Earth without having to fire up a virtual machine.

Hungry ghost 10-22-2012 08:31 PM

Hi guys, I know this is solved, but I thought I'd ask here since I'm having issues with Google Earth on Sid 64 bit too. I installed ia32-libs and ia32-libs-gtk, as well as libgl1-nvidia-glx:i386 since at first the program didn't launch and complained that was missing (I'm using a nVidia card with the proprietary driver). Well, the problem is that when I launch the program, it doesn't display the Earth in the part of the screen where it's supposed to; everything it displays there is a black area. If I launch it from the terminal, there's no error or any message at all, so I feel like blinded.

For reference, I made a thread some days ago about this issue here, but I haven't found a solution yet.

Any ideas? :)

273 10-23-2012 12:33 AM

You could try uninstalling the nvidia-glx package from Sid and using the one from Wheezy instead, if you haven't tried that already. I think that's what I did, but I'll not be able to look for 12 hours or so.

Hungry ghost 10-23-2012 12:16 PM

Thanks 273, I'll try it when I have some time and let you know how it went.

273 10-23-2012 12:42 PM

Just to be clear I mean by adding the repository and "apt-get install -t testing" to install them rather than using .deb files.
(apologies if it's obvious from above but wanted to make sure)

Hungry ghost 10-23-2012 01:02 PM

Yes, I thought that's how it would be done. Thanks for the clarification. I'll post my results later, when I try it.

Hungry ghost 10-26-2012 07:51 AM

Well, tried installing the nvidia-glx package from Testing, but didn't work. If I manage to solve this I'll post back.

Thanks for your help!

273 10-26-2012 01:58 PM

Sorry, I re-read and I realised I didn't make it clear it's the nvidia-glx-ia32 package from testing. It's the multilib support that's broken in Sid at the moment so some things for i386 need to be from testing.

All times are GMT -5. The time now is 05:29 AM.