-   Debian (
-   -   Installing Debian on Laptop - No Wired Connection Available (

Diomedes 10-15-2009 01:14 AM

Installing Debian on Laptop - No Wired Connection Available
Hey everybody!

So I'm making the leap from Fedora to Debian. I like Fedora. It's just been a little disappointing lately. I used the Debian LiveCD for a while, and I really like it.
Trouble is, I have a laptop. The wireless card is an Intel 3945 Pro (or something along those lines -- given me so much trouble you'd think I would remember by now). I'm trying to install Debian from the first install CD and install the rest via internet (if it doesn't work quite like that, stop me here, please). When I get to that point in the installer, it tells me it needs "iwlwifi-3945-1.ucode". I have iwlwifi-3945-2.ucode on a flash drive, and I select the option to probe removable media for this file. It tells me it can't find anything useful, continue with offline installation.
Could anyone be so kind as to walk me through a way to install this wireless driver during the install, or something of that nature? Thank you! Sorry, this is my first non-wired installation.


ddaemonunics 10-15-2009 02:52 AM

change iwlwifi-3945-2.ucode to iwlwifi-3945-1.ucode and then try again

Diomedes 10-15-2009 10:31 AM

Heh... honestly I never thought of that. Thanks! I'll give it a try.

Diomedes 10-15-2009 11:49 PM

Well, that didn't work. But I installed with a wired connection, and it worked. I can't figure out how to get wireless working, though. I was very disappointed with the Debian install. Even with an internet connection, it gave me no option to install development libraries/apps. I had to manually install gcc and make, and neither of them are working properly. It always needs one more thing, then one more thing, and so on. I don't really know where to start.
I guess my question is, how do I get this working in Debian? I can't find a single guide that doesn't involve either building something requiring a dependency I can't find at all, or recompiling the kernel, which I don't know how to do, and can't do anyway because make isn't working.
Can anyone help me out from a fresh Debian install?
Sorry, mods... I'm sure this is in the wrong place. I've honestly lost a lot of sleep over this. I'm going Windows-free finally, and this is hardly an encouraging first step...

Thanks very much

AlucardZero 10-16-2009 10:44 AM


it gave me no option to install development libraries/apps. I had to manually install gcc and make

Use Synaptic and install build-essential.

repo 10-16-2009 10:54 AM

This is the first I do after the netinstall:

#apt-get update
#apt-get upgrade


#apt-get install mplayer mplayer-skin-blue mozilla-mplayer w32codecs mplayer-doc acroread acroread-escript acroread-plugins mozilla-acroread flashplugin-nonfree sun-java6-jre sun-java6-fonts sun-java6-plugin audacious razor clamassassin clamav procmail fetchmail linux-headers-$(uname -r) fortune

#update-java-alternatives --set java-6-sun

repo 10-16-2009 10:56 AM

For the wireless

#apt-get install firmware-iwlwifi

Diomedes 10-16-2009 02:06 PM

Okay, it seems to be doing alright now. Make, that is. I installed fresh and update/upgraded. Thanks, I think I misunderstood the scope of apt. I'll try building the actual driver again when I get time.
Thanks for the help.

richhav1 11-08-2009 10:05 AM

same problem, missing firmware iwlwifi-3945-1.ucode
i had exactly the same problem, solved it last night (new Lenovo Thinkpad). Error message during installation stated "missing firmware iwlwifi-3945-1.ucode"

Go to System>Software Sources>Debian Software

click box to enable "non-free" software
Select Download from "main server"

i also selected the tab "Third-Party Software" and tried to add new repositories to the list. I tried adding:

deb lenny/volatile firmware-nonfree
after that type:


aptitude install firmware-iwlwifi
at this point, when you refresh the dialog box, you will connect to a repository and attempt to download and install the firmware. If you were unsuccessful it will tell you your package was not found. If you are successful, then type:


modprobe iwlwifi-3945
at this point, i was able to reboot and was able to connect to my network wirelessly.

I STILL DON'T KNOW whether it was just enabling the non-free software or the addition of an additional repository to the list that solved the problem, but hey, we'll take it!

richhav1 11-08-2009 10:09 AM

BTW, i should cite the Debian Wiki for my information:

This was an excellent resource!

All times are GMT -5. The time now is 05:37 PM.