-   Debian (
-   -   Installed LILO (from Slackware) in MBR, Debian no longer takes input (

Chemical Rascal 09-19-2011 02:03 PM

Installed LILO (from Slackware) in MBR, Debian no longer takes input
Short because nobody likes a life story:

I'm attempting to dual-boot Debian (Squeeze) and Slackware (13.37), so installed Slackware today, overwriting GRUB with LILO.

Long story short, booting into Debian now leaves me stranded at the (Gnome?) login GUI, without a responsive mouse or keyboard. Both devices work fine on Slackware (with XFCE).

I am able to mount the Debian partition in Slack, so that's that.

Obviously that's not going to be enough information, but I don't really know exactly what to provide - I'm well and truly up the creek here.

Thanks for any assistance,


knivel 09-19-2011 02:59 PM

Probably Debian included another configurations in the grub-config, such as kernel flags and modules.
I would suggest you to use grub instead of LILO for this case because of Debian. Slackware will
work fine with whatever you use.

Chemical Rascal 09-19-2011 03:58 PM

Boot arguments. Of course.

Upon closer inspection of the scrolling boot text, it seems to complain about a "uinput" module or something similar not being loaded. There might be something else, I'm not totally sure.

You've given me an idea, though, knivel - Unfortunatley it seems like it'll be more than a little bit difficult to restore GRUB from within Slackware, but given that all of GRUB's configuration data is still on Debian's partition, is there something I could tweak slightly to allow chainloading GRUB from LILO?

widget 09-19-2011 04:17 PM

I would chroot into Debian from Slackware and install Debians grub on the MBR with;

grub-install /dev/sdx
where x is your drive.

Chemical Rascal 09-19-2011 04:36 PM

And that'd be the end of it, but I'm getting an error:


root@pvtjoker:/# grub-install /dev/sda
/usr/sbin/grub-probe: error: cannot find a device for /boot/grub (is /dev mounted?).

I've little understanding of what is going on at this point.

EDIT: After a little more coffee and a little more Google, I stumbled upon this:


user@tacos# mount --bind /dev /mnt/new/dev
Which, when done before the chroot, helped fix things nicely.

Thanks for the help guys, at the very least it's been a rather educating experience.

odiseo77 09-19-2011 06:20 PM

The problem is that debian can't find /dev because it's only running in a chrooted environment. Have a look at this. I haven't tried it, so I'm not sure how it will work, but to make it a bit clearer, this is what I'd do (from Slackware):


mount /dev/your_debian_partition your_debian_mount_point
mount -t proc your_debian_mount_point/proc
mount -B /dev your_debian_mount_point/dev
chroot your_debian_mount_point /bin/bash
grub-install /dev/sda

In case Debian didn't add an entry for Slackware to the grub menu, then boot into debian, install os-prober (with apt-get/aptitude/synaptic), and run:


It should detect all other OS's in your system and make entries for them in /boot/grub/grub.cfg, so you can boot them.


EDIT: Didn't see your edit when I posted. Good you got it working.

widget 09-19-2011 07:33 PM

Os-prober is provided with the current grub which runs it as long as /etc/grub.d/30_os-prober is enabled.

I would be checking in your Debian installs /boot/grub/ Sounds like it may have a problem. If that is there and correct you should not get that error.

I run many installs per drive and am all the time switching from one to the other for my grub on the MBR. This is usually done in a chroot environment as I don't visit those installs except to experiment with whatever I have each of them designated for.

Grub I play with a lot, and like to know that each installs grub works in case I really "improve" one to the point it no longer works.

colorpurple21859 09-19-2011 10:34 PM

try this entry in your /etc/lilo.conf and rerun lilo

image = /vmlinuz
initrd = /initrd.img
root = /dev/sda?
label = debian
the ? will be the number of the partition that debian is installed on

svu 09-30-2011 02:27 PM

If you still want to try lilo ...

Do you have multiple hard disks ?

I have and I'm experiencing the fact that Slackware recognizes my disk with multiple Linux partitions as /dev/sda while the same disk in Debian or Arch will be /dev/sdb ...

I too experienced the problem where Debian would start + hang without a working mouse / keyboard / anything...
I was just stranded on the login screen.

After a while I figured out how Debian somehow booted while using the Slackware kernel. (things were getting mixed up because of the sda / sdb difference)

Maybe you're experiencing the same problem. If I remember correctly I solved this by using root = "UUID ........" instead of referring to the /dev/sda in lilo.conf
You can find the UUID by running this command :



All times are GMT -5. The time now is 01:11 AM.