-   Debian (
-   -   Input/Output error while copying from an external drive on a Debian machine (

skipperx 05-26-2009 07:15 AM

Input/Output error while copying from an external drive on a Debian machine

I am trying to copy data from an ext3 partition on a USB external drive on a newly installed Lenny machine. It consistently fails with a


kernel:[15743.080180] journal commit I/O error
The drive has only ext3 partition and some extra free space. Can someone please help me.

Thank you.

farslayer 05-26-2009 08:11 AM

Have you tried running a file system check on the external drive ? fsck

Make sure you unmount the drive before checking the file system...

skipperx 05-26-2009 11:36 AM

Thanks for getting back.

I ran fsck just after formatting and it was fine, I mean there were no error msges. Then I wrote to it with Kubuntu notebook. Kubuntu machine can read and write to it without any problem. I'll run fsck again this afternoon when I get back home and report back. If something is wrong there, what does it mean? Debian does not like somethings written the drive by Kubuntu? Or The drive is bad? There used to be an NTFS partition on it. I thought that was causing the problem. So, I repartitioned with only ext3 and left some room for NTFS stuff later. It' quite frustrating.

farslayer 05-26-2009 02:52 PM

Did you unplug the drive from a system without properly un-mounting it first ?

skipperx 05-26-2009 05:56 PM

Yes I usually unmount drive before removing physically.

I just ran fsck and here is the output.

fsck.ext3 -f /dev/sda1
e2fsck 1.41.3 (12-Oct-2008)
Linux: recovering journal
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Linux: 864/12181504 files (0.7% non-contiguous), 839462/48717104 blocks

I am finding numerous complaints about these FreeAgent drives on linux machines now. I wish I googled a bit more before buying. It seems there is a common problem of the drives powering down and not waking up. My problem may not be identical, but they don't seem to be linux-friendly. I also found a fix for ubuntu, but it's too compicated for noob like me. The interesting thing is that the drive seems to be running fine on my notebook with kubuntu.

JZL240I-U 05-27-2009 12:56 AM

Silly question: Are you sure your Debian installation has support for ext3? Because the complaint is a journal error...

skipperx 05-27-2009 11:24 AM

I don't know if the system has "ext3 support" :D How do I check?

The HD where the system resides is ext3 and I was able to format the external drive with ext3 by the same machine. So, I was assuming it supports ext3. May have been an oversight or ignorance.

JZL240I-U 05-27-2009 11:27 AM

No, my error. I surmised that it is only ext3 on the USB device and (possibly) ext2 on your debian box. Sorry.

All times are GMT -5. The time now is 11:24 PM.