LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 05-23-2009, 03:08 AM   #1
anthonydonelly
LQ Newbie
 
Registered: May 2009
Posts: 21

Rep: Reputation: 0
Iceweasel 3 with Etch kernel


Can Iceweasel 3 be installed on a system with the Etch kernel, or would I need to upgrade to the Lenny kernel? Thanks.
 
Old 05-23-2009, 03:25 AM   #2
war1025
Member
 
Registered: Jul 2006
Distribution: Debian: Squeeze AMD64
Posts: 318

Rep: Reputation: 32
Lenny is the new stable, if you are using the computer as a personal computer (not a server) you would probably be best off upgrading to at least Lenny, if not Squeeze, just for usability updates...

You might be able to find backports for iceweasel3 somewhere though if you looked...
 
Old 05-23-2009, 06:16 AM   #3
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 462Reputation: 462Reputation: 462Reputation: 462Reputation: 462
Short answer no, there are too many dependencies that would need to be upgrade. Easiest thing would be to upgrade to Lenny.
 
Old 05-23-2009, 05:21 PM   #4
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
You can put a lenny source in /etc/apt/sources.list, and apt-get update, and install the iceweasel that you want, and everything you need should upgrade.
 
Old 05-24-2009, 12:25 AM   #5
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 462Reputation: 462Reputation: 462Reputation: 462Reputation: 462
Iceweasel depends on libgtk and libc6 for starters. The versions in etch are too old to be able to upgrade to Iceweasel 3. I doubt you can just upgrade one or two packages in Lenny, chances are you would need to upgrade libc6 which would upgrade pretty much everything else.

Depends: fontconfig, psmisc, procps, debianutils (>= 1.16), libc6 (>= 2.3.6-6~), libgcc1 (>= 1:4.1.1), libglib2.0-0 (>= 2.12.0), libgtk2.0-0 (>= 2.8.0), libnspr4-0d (>= 1.8.0.10), libstdc++6 (>= 4.1.1), xulrunner-1.9 (>= 1.9.0.3-1)
Suggests: xulrunner-1.9-gnome-support, latex-xft-fonts, xfonts-mathml, ttf-mathematica4.1, xprint, mozplugger, libkrb53
 
Old 05-24-2009, 02:30 AM   #6
anthonydonelly
LQ Newbie
 
Registered: May 2009
Posts: 21

Original Poster
Rep: Reputation: 0
thanks for all of your answers

I'll continue for now to use Etch, which I installed in this machine, and another machine.
The main reason I wanted to try Iceweasel was because one bank's website balks at Opera, and Konqueror.
My only attempt to put Iceweasel 2 into this machine didn't work, but I think that was simply because I'd swapped the DVD reader out of this machine into the other machine!
I'm sure I indexed all 3 of Etch's DVDs with 'apt-cdrom add', because I can read them in /etc/apt/sources.list.
I was able to install Iceweasel 2 easily in the other machine, but then had trouble with KPPP(permission denised to open /etc/ppp/peers/kppp-options, until I saw in this machine that I needed to add my own username to the dip group, in /etc/group.
So, I'll swap the DVD player back into this box and try again.
I also tried to upgrade libgtk last night, from a local .deb file, but i kept getting "malformed line 2" in sources.list, from my line entered as

deb file:/root/debs

I'm only on dialup, believe it or not, so I'll have to get DVD sets of Lenny or Squeeze sometime soon.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot install flash player on iceweasel in debian etch parf Linux - Newbie 16 11-23-2008 11:43 PM
32 bit iceweasel/firefox on Debian Etch AMD64 jean-david hsu Debian 0 06-18-2008 06:36 PM
Managing plugins in Iceweasel 2.0 in Debian/etch cbjones50 Debian 8 02-09-2008 06:07 PM
Installing flashplayer 9 - Etch/Kde/Iceweasel r00ster Linux - Newbie 2 11-08-2007 06:39 PM
etch iceweasel high cpu usage mtb Debian 5 02-22-2007 05:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 01:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration