LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 10-31-2003, 11:53 AM   #1
ganninu
Member
 
Registered: Jul 2003
Distribution: RH 7.3/8.0/9.0, Debian Stable 3.0, FreeBSD 5.2, Solaris 8/9/10,HP-UX
Posts: 340

Rep: Reputation: 30
I just discovered that I cannot mount my CDROM on debian!


Very strange since with redhat all it took was:

mount /dev/cdrom /mnt/cdrom

Whenever i try that, i get this error:
debian:/home/ganni# mount -t iso9660 /dev/cdrom /cdrom/
mount: block device /dev/cdrom is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems


Moreover, i've checked out what dmesg produced:
hdb: command error: status=0x51 { DriveReady SeekComplete Error }
hdb: command error: error=0x54
end_request: I/O error, dev 03:40 (hdb), sector 64
isofs_read_super: bread failed, dev=03:40, iso_blknum=16, block=32

This is my fstab:
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
/dev/hda8 / ext2 errors=remount-ro 0 1
/dev/hda7 none swap sw 0 0
proc /proc proc defaults 0 0
/dev/fd0 /floppy auto user,noauto 0 0
/dev/cdrom /cdrom iso9660 ro,user,noauto 0 0
/dev/hda5 /mnt/pantera vfat auto,user 0 2


Strange thing is this:
When i do apt-get install <package> and is located on the DEBIAN CD, it will of course read from it..

Another thing:
My second CD ROM is not even detected!

What's up with my beloved new Debian?
 
Old 10-31-2003, 12:15 PM   #2
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
For your other cdrom, add an entry for it in fstab. The entry will be the similar to the first, with different devices & mount points. You cdrom device is determined by where it's connected; hdc=secondary master, hdd=secondary slave, hdb=primary slave. /dev/cdrom is just a link to one of them.
 
Old 10-31-2003, 01:04 PM   #3
ganninu
Member
 
Registered: Jul 2003
Distribution: RH 7.3/8.0/9.0, Debian Stable 3.0, FreeBSD 5.2, Solaris 8/9/10,HP-UX
Posts: 340

Original Poster
Rep: Reputation: 30
What explains the error for my first cdrom though?
 
Old 11-01-2003, 12:43 AM   #4
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Make sure the symlink /dev/cdrom points to the right place. Try mounting it by specifying the actual device. In other words, type something like mount -t iso9660 /dev/hdc /cdrom. I've italicised the important part. Once you have the right one make sure the link points there. Then all you'll have to type to mount the cdrom is mount /cdrom (ie just specify the mount point and mount reads your fstab for all the other info).
 
Old 11-01-2003, 01:35 AM   #5
ganninu
Member
 
Registered: Jul 2003
Distribution: RH 7.3/8.0/9.0, Debian Stable 3.0, FreeBSD 5.2, Solaris 8/9/10,HP-UX
Posts: 340

Original Poster
Rep: Reputation: 30
Yes I did that.. Mind you, I've used to mount and unmount successfully on redhat, and I've read it's man page zillion times. Another thing I've noticed - MUSIC CD's cannot be mounted, whereas data CD's are sucessfully mounted (although for the last case, the eject doesn't work, but anyways). I'm trying to find out whether music CDs have a different filetype..
 
Old 11-01-2003, 02:19 AM   #6
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
You can't mount music CDs. They're just played directly. Also, if you want to eject a CD you have to unmount (umount) it. If you want program to play a CD you just point the player to /dev/cdrom.
 
Old 11-06-2003, 02:21 PM   #7
ssaigol
LQ Newbie
 
Registered: Oct 2003
Distribution: Debian 3.0r1
Posts: 17

Rep: Reputation: 0
Re: I just discovered that I cannot mount my CDROM on debian!

Plese look again at your /etc/fstab. your cdrom is located at "/cdrom" not "/mnt/cdrom"

This is the default for Debian 3.0. Use the command "mount /cdrom"

Regards, S.S.


Quote:
Originally posted by ganninu
Very strange since with redhat all it took was:

mount /dev/cdrom /mnt/cdrom

Whenever i try that, i get this error:
debian:/home/ganni# mount -t iso9660 /dev/cdrom /cdrom/
mount: block device /dev/cdrom is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems


Moreover, i've checked out what dmesg produced:
hdb: command error: status=0x51 { DriveReady SeekComplete Error }
hdb: command error: error=0x54
end_request: I/O error, dev 03:40 (hdb), sector 64
isofs_read_super: bread failed, dev=03:40, iso_blknum=16, block=32

This is my fstab:
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
/dev/hda8 / ext2 errors=remount-ro 0 1
/dev/hda7 none swap sw 0 0
proc /proc proc defaults 0 0
/dev/fd0 /floppy auto user,noauto 0 0
/dev/cdrom /cdrom iso9660 ro,user,noauto 0 0
/dev/hda5 /mnt/pantera vfat auto,user 0 2


Strange thing is this:
When i do apt-get install <package> and is located on the DEBIAN CD, it will of course read from it..

Another thing:
My second CD ROM is not even detected!

What's up with my beloved new Debian?
 
Old 11-08-2003, 01:00 PM   #8
ganninu
Member
 
Registered: Jul 2003
Distribution: RH 7.3/8.0/9.0, Debian Stable 3.0, FreeBSD 5.2, Solaris 8/9/10,HP-UX
Posts: 340

Original Poster
Rep: Reputation: 30
root@tiger:~$ ls -l /dev/cdrom
lrwxrwxrwx 1 root root 3 Nov 8 09:37 /dev/cdrom -> hdb

is 'hdb' /dev/hdb or? How do I create a new link for my secondary cdrom? Do i only need to create a file /dev/cdrom2 and make it point to /dev/hdb2?
 
Old 11-08-2003, 01:47 PM   #9
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,594

Rep: Reputation: 97
Quote:
Originally posted by ganninu
root@tiger:~$ ls -l /dev/cdrom
lrwxrwxrwx 1 root root 3 Nov 8 09:37 /dev/cdrom -> hdb

is 'hdb' /dev/hdb or? How do I create a new link for my secondary cdrom? Do i only need to create a file /dev/cdrom2 and make it point to /dev/hdb2?
Your second CD would be /dev/hdc or /dev/hdd depending where it is on the second IDE channel. For your eject problem you may want to check and make sure that you have the eject program installed.
 
Old 11-08-2003, 01:59 PM   #10
ganninu
Member
 
Registered: Jul 2003
Distribution: RH 7.3/8.0/9.0, Debian Stable 3.0, FreeBSD 5.2, Solaris 8/9/10,HP-UX
Posts: 340

Original Poster
Rep: Reputation: 30
ok managed to do it... To find out which hd* it is, the trick is to check out the file size... If it is non-zero then that hd* contains the device - quite trivial anyways hehe... Then finding out which hd* reflects your cd rom (in my case hdd) create a symbolic link:

ln -s /dev/hdd /dev/cdrom2

Then create a mount point in the /etc/fstab file...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CDROM refuses to mount, /dev/cdrom does not exist shane25119 Linux - Hardware 10 08-02-2009 10:43 PM
newbie on debian trying to mount cdrom javier_ccs Linux - Hardware 18 09-08-2005 04:02 PM
Gnome has no sound as I just discovered! Slovak Slackware 4 11-21-2004 03:12 PM
Changed CDROM to CDRW, Debian can't mount it bcalder01 Linux - Laptop and Netbook 9 09-12-2004 03:33 PM
discovered galeon oddity neo77777 Linux - General 3 08-31-2002 02:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 07:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration