LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   I cant play VCD and CD-DA in my Debian box (https://www.linuxquestions.org/questions/debian-26/i-cant-play-vcd-and-cd-da-in-my-debian-box-141051/)

Claus 02-01-2004 12:33 PM

I cant play VCD and CD-DA in my Debian box
 
Hi

When i try to play a VCD using mplayer i get the next error:

Code:

Playing VCD track 1
CD-ROM Device '/dev/cdrom' not found.

But /dev/cdrom is a symbolic link to /dev/hdd that is my cdrom drive:

Code:

lrwxrwxrwx    1 root    root            8 2004-01-26 13:54 /dev/cdrom -> /dev/hdd
And works fine when reading a data cdrom.

Also, i cant use the GNOME CD Player to play CD-DA discs, this gives me the next error message:

Code:

It seems you do not have the rights to access to /dev/cdrom.
This means that the CD Player cant be loaded.

Grip doesnt work neither, so i cant rip my music cds.

The next is my fstab file.

Code:

# /etc/fstab: static file system information.
#
# <file system> <mount point>  <type>  <options>                              < dump>  <pass>
/dev/hda6      /      ext2    exec,dev,suid,rw,errors=remount-ro 0 1
/dev/hda7      none    swap    exec,dev,suid,rw,sw 0 0
proc            /proc          proc    defaults                              0
/dev/fd0        /mnt/floppy            auto    user,noauto                    0
/dev/cdrom      /cdrom          iso9660 ro,user,owner,noauto,exec,nodev,nosuid 0/dev/sda1      /mnt/sda1      vfat    rw,user,noauto,umask=0
/dev/hda1      /mnt/hda1      vfat    user,noexec,nodev,nosuid,rw,umask=0 1 1/dev/hda5      /mnt/hda5      vfat    user,noexec,nodev,nosuid,rw,umask=0

Please somebody give me a hint to solve this problem. When i used Mandrake 9.0 i haved no problem, so i dont think is a hardware issue.

Thank You.

HappyTux 02-01-2004 06:36 PM

Re: I cant play VCD and CD-DA in my Debian box
 
Not really sure how to go about it without using the ide-scsi emulation but that line you are using in the /etc/fstab looks real strange. Try something like this for the line:
Code:

/dev/cdrom      /cdrom          iso9660  ro,user,noauto          0      0
Are you a member of the cdrom group? To check use the groups command in a console window if not then use su to become root and adduser user_name cdrom then logout and back in to have the changes take effect. For grip I had a similar problem and I had to:
Code:

chmod g+rw /dev/sg*
chgrp cdrom /dev/sg*

Again this is me using ide-scsi so it may be different for you.

Claus 02-01-2004 10:31 PM

Errata:

As you can imagine, my real fstab is this:

Code:

# /etc/fstab: static file system information.
#
# <file system> <mount point>  <type>  <options>                              < dump>  <pass>
/dev/hda6      /      ext2    exec,dev,suid,rw,errors=remount-ro 0 1
/dev/hda7      none    swap    exec,dev,suid,rw,sw 0 0
proc            /proc          proc    defaults                              0
/dev/fd0        /mnt/floppy            auto    user,noauto                    0
/dev/cdrom      /cdrom          iso9660 ro,user,owner,noauto,exec,nodev,nosuid 0
/dev/sda1      /mnt/sda1      vfat    rw,user,noauto,umask=0
/dev/hda1      /mnt/hda1      vfat    user,noexec,nodev,nosuid,rw,umask=0 1 1
/dev/hda5      /mnt/hda5      vfat    user,noexec,nodev,nosuid,rw,umask=0

HappyTux, I tried with your hints, but i still have the problems....

Im member of cdrom group, and give the rights to /dev/sg* and everything else, but i still have no answer.

Please... somebody help.. :)

Claus 02-01-2004 10:58 PM

End of the problem.

All i needed was adding myself to the group disk, because /dev/hdd is a member of that group...

Life is nice, dont?


All times are GMT -5. The time now is 12:32 AM.