LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-01-2004, 09:43 PM   #1
andymadigan
Member
 
Registered: Aug 2004
Location: Rochester, NY
Distribution: Debian Sid
Posts: 59

Rep: Reputation: 15
Question Howto set permissions and automount for new drive?


I just installed Debian Sarge (testing) and I have managed to get in to GNOME, however, I'm trying to get my usbkey to be acessible to the normal user (andymadigan).

I can mount the key with: mount -t vfat /dev/sda1 /mnt/usbkey

But the normal user can't accesss it, it tried chmod 777 /mnt/usbkey as root
and got permission denied (how is this possible? I'm root!). I would also like the key to automount when it's plugged in (like with CDs) how do I do this?

Note: I have KDE and GNOME, and I'm comfortable enough with the console to be able to run the basic commands, but I've never been able to figure out chmod or chown.
 
Old 08-01-2004, 11:32 PM   #2
webdwarf
LQ Newbie
 
Registered: Aug 2004
Location: Australia
Distribution: Linux From Scratch, Debian Woody & Sarge
Posts: 3

Rep: Reputation: 0
umm.. not overly sure if the following options are right, but you can try adding the following to the end of /etc/fstab
Code:
/dev/sda1       /mnt/usbkey     vfat    rw,user         0       0
and then run "mount -a"
Just to be on the safe side, I would make sure you have a backup of any files on the usbkey.. just incase
HTH
-jrb
 
Old 08-02-2004, 05:28 AM   #3
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
You'll probably want to add "noauto" to the fstab options (rw,user,noauto), so that Debian doesn't try to mount your usbkey automatically at boot time.

I personally don't hold with automounting -- to me mounting and unmounting manually isn't such a big trouble. There's even a GUI program for mounting/unmounting devices easily, called "xvmount".
 
Old 08-02-2004, 02:22 PM   #4
andymadigan
Member
 
Registered: Aug 2004
Location: Rochester, NY
Distribution: Debian Sid
Posts: 59

Original Poster
Rep: Reputation: 15
answer found

Thanks for the replies, I figured it out, I'll post my exact line from fstab when I get home
 
Old 08-02-2004, 10:17 PM   #5
andymadigan
Member
 
Registered: Aug 2004
Location: Rochester, NY
Distribution: Debian Sid
Posts: 59

Original Poster
Rep: Reputation: 15
fstab

Here's the line in my fstab:
/dev/sda1 /mnt/usbkey vfat user,noauto,umask=0 0 0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Not able to set write permissions on external hard drive. jpen8560 Linux - Hardware 19 03-22-2006 10:44 AM
How do I set up proper drive permissions (fstab reamins static despite all mounts) Lechium Linux - Hardware 9 07-03-2004 09:33 AM
Howto change WIndows Drive Permissions? amoor757 Linux - Software 9 11-05-2003 12:11 AM
Howto: set permissions on a ntfs drive. Coramoor Slackware 8 05-12-2003 10:51 PM
hOwtO autOmOunt fadain Linux - Newbie 5 03-23-2003 01:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 06:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration