-   Debian (
-   -   Howto set permissions and automount for new drive? (

andymadigan 08-01-2004 09:43 PM

Howto set permissions and automount for new drive?
I just installed Debian Sarge (testing) and I have managed to get in to GNOME, however, I'm trying to get my usbkey to be acessible to the normal user (andymadigan).

I can mount the key with: mount -t vfat /dev/sda1 /mnt/usbkey

But the normal user can't accesss it, it tried chmod 777 /mnt/usbkey as root
and got permission denied (how is this possible? I'm root!). I would also like the key to automount when it's plugged in (like with CDs) how do I do this?

Note: I have KDE and GNOME, and I'm comfortable enough with the console to be able to run the basic commands, but I've never been able to figure out chmod or chown.

webdwarf 08-01-2004 11:32 PM

umm.. not overly sure if the following options are right, but you can try adding the following to the end of /etc/fstab

/dev/sda1      /mnt/usbkey    vfat    rw,user        0      0
and then run "mount -a"
Just to be on the safe side, I would make sure you have a backup of any files on the usbkey.. just incase

Dead Parrot 08-02-2004 05:28 AM

You'll probably want to add "noauto" to the fstab options (rw,user,noauto), so that Debian doesn't try to mount your usbkey automatically at boot time.

I personally don't hold with automounting -- to me mounting and unmounting manually isn't such a big trouble. There's even a GUI program for mounting/unmounting devices easily, called "xvmount".

andymadigan 08-02-2004 02:22 PM

answer found
Thanks for the replies, I figured it out, I'll post my exact line from fstab when I get home

andymadigan 08-02-2004 10:17 PM

Here's the line in my fstab:
/dev/sda1 /mnt/usbkey vfat user,noauto,umask=0 0 0

All times are GMT -5. The time now is 08:37 PM.